Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

redistributing bgp into ospf

Dear All,

I have three routers R1-R2-R3 connected in a network..

R1 has the following configuration:

interface Loopback0

ip address 10.168.246.11 255.255.255.255

!        

interface GigabitEthernet0/0

ip address 10.168.254.4 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.168.202.3 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

!

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1/1

no ip address

shutdown

clock rate 2000000

!

router ospf 1

log-adjacency-changes

network 10.168.246.11 0.0.0.0 area 9

network 10.168.254.0 0.0.0.255 area 9

!

router bgp 65042

no synchronization

bgp log-neighbor-changes

neighbor 10.168.246.1 remote-as 65042

neighbor 10.168.246.1 update-source Loopback0

network 182.93.93.98 mask 255.255.255.255

no auto-summary

!

ip forward-protocol nd

ip route 182.93.93.98 255.255.255.255 10.168.202.4

no ip http server

no ip http secure-server

R2 has the following Configuration:

interface Loopback0

ip address 10.168.246.1 255.255.255.255

!

interface GigabitEthernet0/0

ip address 10.168.254.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.168.252.30 255.255.255.0

duplex auto

speed auto

!

interface Serial0/2/0

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

redistribute bgp 65042 metric 50 subnets

network 10.168.246.1 0.0.0.0 area 9

network 10.168.252.30 0.0.0.0 area 9

network 10.168.254.0 0.0.0.255 area 9

!

router bgp 65042

no synchronization

bgp log-neighbor-changes

neighbor 10.168.246.11 remote-as 65042

neighbor 10.168.246.11 update-source Loopback0

no auto-summary

!

ip forward-protocol nd

no ip http server

no ip http secure-server

R3 has the following configuration:

!

interface GigabitEthernet0/1

no switchport

ip address 10.168.252.29 255.255.255.0

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 10.168.252.29 0.0.0.0 area 9

Based on the above configurations, I have configured a static route on R1 pointing to 10.168.202.4 and advertised the specific /32 route into BGP using

Network Command. Now, I'm able to see the route on R2 as a BGP prefix but I can't see the particular route on the R3 since BGP route is redistributed into OSPF on R2.

There is a restriction of redistributing the static route of 182.93.93.98/32  route on R1 with redistribute static. How can I make R3 to see the route without configuring redistribution on R1? and Why is it not beeing seen on R3 however it is redistributed? is there any hidden conecpt behind this?

Any suggestion regarding this will be highly appreciated.

Thanks and Regards,

Hari

10 REPLIES

redistributing bgp into ospf

Hello Hari,

Is it possible for you to provide a topology ?

New Member

redistributing bgp into ospf

Hi Hari,

I am assuming that the network for 182.93.93.98/32 is connected directly to the router hosting 10.168.202.4/24 network? If that is the case remove the advertisement on R1 for

network 182.93.93.98 mask 255.255.255.255

And also remove the static route :

ip route 182.93.93.98 255.255.255.255 10.168.202.4 on R1

you can make the router (let give it a name R4) with IP: 10.168.202.4/24 run ospf and advertise the network 10.168.202.4/24 &  182.93.93.98/32, join it to area 9. This will make it visible to any router joined  to the same ospf area 9.

The reason why you are no seeing the network from R3 is because the your redistribution statement is on R2(should be on R1 based on your intention) and also there is no network statment on your bgp commands to inject any network you wish to advertise into ospf. Alternatively, this can also serve as another way to advertise the 182.93.93.98/32 should you choose not to use ospf on R4.

redistributing bgp into ospf

Hi Hari,

Can you share output of following command

show ip ospf database

Regards,

Smitesh

New Member

redistributing bgp into ospf

Thanks for your kind response Smitesh,

I'm outside of the network right now, will share the update soon. But i'm sure, the particular prefix was not displayed on ospf database as well...I just want to remind you a thing that " once a route is redistributed into a routing protocol, that can't be redistributed again into another routing protocol" Considering this rule, can we conclude like same thing about the static route?? I suspect that there might be any hidden concept behind it... if not, then why this issue with static routing only?

Another thing i want to share is , During my lab test I found R3 successfully learned the prefix 182.93.93.98/32 once i created a loopback and put the particular IP of /32. but whenever i tried to fix this issue through my initial objectives what i have shared to you all, I was failed.

I hope you will share your opinion soon .

Thanks again.

New Member

redistributing bgp into ospf

Hi Hari,

Can you please share the topology. I'm trying to understand where the 10.168.202.4 is?

If it is connected to R1 (which I hope so, the other end of Gig0/1) , I'm trying to understand what is the purpose of running bgp just to advertise one network? it can be acheived even with ospf itself.

-Vijay

redistributing bgp into ospf

Hi Hari,

Are you able to ping 182.93.93.98 from R2 ??

Just asking as I tried to lab your config and it seems like though 182.93.93.98 is present in BGP table, but it is not in routing table.

Further more, when I changed R1's BGP config to include next-hop-self, then only I was able to see 182.93.93.98 in routing table...

However, I still have to admit that I'm still not able to see that in OSPF. Let me ponder over that more....

Regards,

Smitesh

New Member

redistributing bgp into ospf

Hi Vijay,

You are right, it is connected next to R1 via g0/1 interface, Answer of your question is- BGP is running since it was configured previously for another purpose in the network. As i mentioned earlier, there is some restriction which compells us to do the needful according to my initial objective. So friends, appreciate if you could find the actual reason of the same and i 'm very much hopeful on it.

and,

Dear Smitesh,

As you found the reason of next-hop-self, I also noticed that earlier,it was just like what you told. As soon as we configure next-hop-self, we see the prefix as a valid indicating > sign, I hope you will focus on the topic  and help me on the resolution as well.

Regards,

Hari

New Member

Re: redistributing bgp into ospf

Hey Guys,

I guess the command is wrong

it should be" redistribute BGP internal "

IBGP routes doesnt get redistributed automatically...

I mean to say use this under BGP

bgp redistribute-internal

Thanks

Vinayak

Message was edited by: vinayak pandit

redistributing bgp into ospf

Good Catch Vinayak...

+5 for pointing that...

Regards,

Smitesh

New Member

Re: redistributing bgp into ospf

Thanks for calling me in Smitesh

Do let me know whenever you come across such good troubleshooting examples

Rgs,

Vinayak

843
Views
5
Helpful
10
Replies
CreatePlease to create content