Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Redistribution and distribution lists

If you are using redistribution of OSPF into EIGRP and also redistribtion of static routes. If you have a distribution-list configured for in is the distribution-list valid for both redistributions? Also can you have distribution-lists in and out.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Redistribution and distribution lists

Jakob

The default metric is not specific to redistribution of OSPF. When you redistribute from most protocols into EIGRP you will need a default metric. You have the option of configuring default metric as a separate command or of including the default metric parameters within the redistribute command.

The requirement for a default metric relative to redistribution is that the metric associated with most redistribution sources is not compatible with EIGRP (there is no algorithmic translation of OSPF cost into EIGRP bandwidth, delay, reliability, load, mtu)

HTH

Rick

5 REPLIES
Hall of Fame Super Gold

Re: Redistribution and distribution lists

Jakob

Your question has two parts and it is easier to answer them separately.

If you are using a distribute list assigned to an interface to contol routing advertisement then it is valid to assign distribute-list both in and out. But if you are using a distribute list to control redistribution then it operates only in a single direction (you are controlling advertisement from the sending protocol to the receiving protocol).

If you are using a distribute list to control redistribution of routes from OSPF into EIGRP and are using a distribute list to control redistribution of static routes into EIGRP it is possible that the same distribute list could be valid for both (if you choose to use the same list for both). There will be 2 redistribute statements and each redistribute statement will use a distribute list. If you specify the same list in both statements it would be valid. This might make sense if the same routes were present as static routes and also present as EIGRP routes. Do you have a situation where this is the case?

While it could be valid for the same distribute list to control both redistribution of EIGRP and redistribution of static it is most common to have one distribute list to control redistribution of EIGRP and a separate distribute list to control the redistribution of static.

HTH

Rick

New Member

Re: Redistribution and distribution lists

I think you gave me a good idea of the process. Do you have a configuration example of this?

Hall of Fame Super Gold

Re: Redistribution and distribution lists

Jakob

Here is an example:

ip route 192.168.2.0 255.255.255.0 192.168.7.65

ip route 192.168.5.0 255.255.255.0 192.168.7.65

ip route 172.16.0.0 255.255.255.0 192.168.7.65

access-list 3 permit 192.168.2.0

access-list 3 permit 192.168.5.0

router eigrp 1

network 192.168.7.0

default-metric 10000 100 255 1 1500

redistribute static

distribute-list 3 out static

This creates 2 static routes of which 2 should be redistributed and 1 should be supressed. So there are 3 static route statements, then a standard access list has permit statements for the routes to be advertised, then under router eigrp there is a redistribute static command and a distribute list command which will control the redistribution of the static routes.

HTH

Rick

New Member

Re: Redistribution and distribution lists

Thank you. Is the default-metric 10000 100 255 1 1500 necessary to configure or is it only necessary when you are redistributing ospf into eigrp.

Hall of Fame Super Gold

Re: Redistribution and distribution lists

Jakob

The default metric is not specific to redistribution of OSPF. When you redistribute from most protocols into EIGRP you will need a default metric. You have the option of configuring default metric as a separate command or of including the default metric parameters within the redistribute command.

The requirement for a default metric relative to redistribution is that the metric associated with most redistribution sources is not compatible with EIGRP (there is no algorithmic translation of OSPF cost into EIGRP bandwidth, delay, reliability, load, mtu)

HTH

Rick

644
Views
0
Helpful
5
Replies
CreatePlease to create content