Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

redundancy between two sites

Hi

I am trying to implement redundancy between two sites using LAN-EXTENSION from two different Service Providers.The following is the configuration and I want FAILOVER to happen automatically WITH TWO LINKS PLUGGED IN ALL THE TIME .

When I plugin both the links I am not able to connect to SITE A from

SITE B or Vice Versa with the following configuration.IF I SHUTDOWN BACKUP LINK or PRIMARY LINK on SITE B everything is working.Please Advise.Right now I have shutdown interface FastEthernet0/48 on 3550-SITE B and everything seems to be good but I want this interface FastEthernet0/48 on 3550-SITE B to be UNSHUT AND STILL EVERYTHING SHOULD BE WORKING

4006-SITE A#

!

interface FastEthernet2/43---------------------primary Service provider A

description primary-LAN-X

switchport access vlan 24

switchport mode access

speed 100

duplex full

end

!

interface FastEthernet3/12---------------------backup Service Provider B

description BACKUP-LAN-X

switchport access vlan 24

switchport mode access

speed 100

duplex full

end

interface Vlan24

ip address 10.32.0.7 255.255.252.0

ip route 0.0.0.0 0.0.0.0 10.32.0.5

ip route 10.32.64.0 255.255.252.0 10.32.0.1

ip route 10.32.72.0 255.255.254.0 10.32.0.1

3750-SITE B:

interface GigabitEthernet1/0/1---------------cross over connection to 3550-SITE B:interface FastEthernet0/1

switchport mode access

power inline never

interface Vlan1

ip address 10.32.0.1 255.255.252.0

ip route 0.0.0.0 0.0.0.0 10.32.0.5

3550-SITE B:

interface FastEthernet0/1---------------------cross over connection to 3750-SITE B:interface FastEthernet0/1

no ip address

duplex full

speed 100

interface FastEthernet0/47------------------primary Service provider A

description to SERVICE POVIDER A

no ip address

duplex full

speed 100

end

!

interface FastEthernet0/48-----------------backup Service Provider B

description to SERVICE POVIDER B

no ip address

duplex full

speed 100

end

interface Vlan1

ip address 10.32.0.10 255.255.252.0

no ip route-cache

ip default-gateway 10.32.0.1

4 REPLIES
Hall of Fame Super Silver

Re: redundancy between two sites

Hello,

add switcport mode access on C3550 ports to service providers links.

if there are service providers switches in the middle another question is the different vlan id at the two sites.

with a single link enabled try to understand what happens at STP level

do

sh spanning-tree interface fas2/43

Hope to help

Giuseppe

New Member

Re: redundancy between two sites

OK.I have only Primary up and backup down and here is the output of

4006-01#sh spanning-tree int fa2/43

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0024 Desg FWD 19 128.107 P2p Peer(STP)

New Member

Re: redundancy between two sites

Not all service provides allow VLAN tagging across their ethernet links. Check with them to make sure.

James

Hall of Fame Super Silver

Re: redundancy between two sites

Hello James,

yes but original poster's ports are configured as access ports on one side.

I've suggested to enforce mode access also on other side on both ports.

CCDE:

do a sh spanning-tree detail and get information about fas2/43

you should check if STP BPDUs have been received.

the port is in designated state. but this could mean no STP peer is there (but we see STP peer).

I would do the following test:

use an access-port in siteB without STP portfast and causes a change of state of that port.

then check again BPDU counters on fast port.

it should increment by 1 if TCN BPDU travels to you.

Hope to help

Giuseppe

124
Views
0
Helpful
4
Replies
CreatePlease to create content