Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Redundancy Edge Sw

Hi

2960 needs reachability to backbone-sw when link between 2960 and 4509 is down

4509 is the server, All 2960 will be VTP client

On 4509

interface gi 0/1

switchport trunk encap dot1q

switchport mode trunk

interface gi 0/2

switchport trunk encap dot1q

switchport mode trunk

interface gi 0/3

switchport trunk encap dot1q

switchport mode trunk

On 2960 ( 1st floor )

interface gi 0/1

switchport trunk encap dot1q

switchport mode trunk

interface gi 0/2

switchport trunk encap dot1q

switchport mode trunk

On 2960 ( 2nd floor )

interface gi 0/1

switchport trunk encap dot1q

switchport mode trunk

interface gi 0/2

switchport trunk encap dot1q

switchport mode trunk

On 2960 ( 3rd floor )

interface gi 0/1

switchport trunk encap dot1q

switchport mode trunk

interface gi 0/2

switchport trunk encap dot1q

switchport mode trunk

Any additional configuration is needed to avoid loop if both connection port is up on 2960.

Thanks

Mel

3 REPLIES
Hall of Fame Super Blue

Re: Redundancy Edge Sw

Melwin

No additional configuration needed as STP will automatically block one of the uplinks. I would recommend running RSTP rather than standard PVST+ as it is a lot quicker to failover and make sure the 4500 switch is STP root for all vlans.

Jon

New Member

Re: Redundancy Edge Sw

Hi

Do I need additional configuration on 4509 for RSTP then mentioned.

Is any config needed on 2960 edge switches for RSTP

Switch(config)# spanning-tree mst configuration
Switch(config-mst)# instance 1 vlan 10-20
Switch(config-mst)# name region1
Switch(config-mst)# revision 1

Hall of Fame Super Blue

Re: Redundancy Edge Sw

melwin.uk wrote:

Hi

Do I need additional configuration on 4509 for RSTP then mentioned.

Is any config needed on 2960 edge switches for RSTP

Switch(config)# spanning-tree mst configuration
Switch(config-mst)# instance 1 vlan 10-20
Switch(config-mst)# name region1
Switch(config-mst)# revision 1

#

#

#

#

#

#

Melwin

The above is config for MST not rapid-pvst+. See the attached docs for rapid-pvst+ config -

4500 -

4500 rstp

2960 -

2960 rstp

Jon

237
Views
0
Helpful
3
Replies