Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Redundancy with Loopback IPs

Hey this seems to be a pretty easy problem to solve but I need help with it.

Here is my diagram:

http://www.flickr.com/photos/31154535@N07/4604946818/sizes/o/

What I want to do is build in redundancy for devices that are dual homed on these two stacked 3750s. My phone tech wants to bind  voice services on the loopbacks on these two Cisco 5350 gateways. he wants it so that if a switch dies we can still route to both loopbacks. The problem starts when one switch goes down. For example when switch01 dies, I cant ping the loopback 5.6.56.31 from sw02.

Here is the routing table on router1 (left in the diagram)

Gateway of last resort is 10.1.56.1 to network 0.0.0.0
     5.0.0.0/24 is subnetted, 1 subnets
C       5.1.56.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.56.0 is directly connected, GigabitEthernet0/0
C       10.1.70.0 is directly connected, GigabitEthernet0/1
S*   0.0.0.0/0 [1/0] via 10.1.56.1

I put in a scond route as you can see here:

VOIPXML01-HVN#sh run | i ip route
ip route 0.0.0.0 0.0.0.0 10.1.56.1
ip route 0.0.0.0 0.0.0.0 10.1.70.1 10

The .1 addresses are the SVI for the vlans on the switch.

Here is the routing table for the stacked 3750:

Gateway of last resort is 10.1.51.1 to network 0.0.0.0

     5.0.0.0/32 is subnetted, 2 subnets
S       5.1.56.31 [1/0] via 10.1.56.31
S       5.1.70.32 [1/0] via 10.1.56.32

S*   0.0.0.0/0 [1/0] via 10.1.51.1

And I have included other routes as well on the switch:

cab8sw1-hvn-3750g#sh run | i ip route
ip route 0.0.0.0 0.0.0.0 10.1.51.1
ip route 5.1.56.31 255.255.255.255 10.1.56.31
ip route 5.1.56.31 255.255.255.255 10.1.70.31 10
ip route 5.1.70.32 255.255.255.255 10.1.70.32
ip route 5.1.70.32 255.255.255.255 10.1.56.32 10

The routers are connected to L2 interfaces on the 3750.  Here is what the entry for router1 looks like:

interface GigabitEthernet1/0/3
description voipxml01 - ge0
switchport access vlan 232
spanning-tree portfast

Any advice would be appreciated. I was going to do an HSRP solution, but the voice guy says he wants to use the loopbacks.

Thanks a million!

1 REPLY
VIP Super Bronze

Re: Redundancy with Loopback IPs

Hi Pener,

I would not design it based on what the voice guy tell you.  Since your 3750s are stacked, you can have your end devices ie servers dually attached to each 3750.  So connect one NIC of the server to one 3750 and connect the other NIC of the same server to the other 3750 and use Etherchannel for load sharing.  This way you have NIC redundancy and also switch redundancy.  On the routers run HSRP or VRRP for gateway redundancy.

HTH

Reza

368
Views
0
Helpful
1
Replies
CreatePlease to create content