Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

redundant layer2 link between a router and 2 switches

Hi,

I want to connect a router (7206VXR, NPE-G2, 12.4(11)T1) to 2 switches (6509, 12.2(18)SXF) at layer 2. The configuration I'm trying is:

router:

!

bridge irb

!

interface GigabitEthernet0/1

description - connection to switch2 gi5/2 -

no ip address

duplex auto

speed auto

media-type rj45

negotiation auto

bridge-group 1

!

interface GigabitEthernet0/2

description - connection to switch1 gi5/1 -

no ip address

duplex auto

speed auto

media-type sfp

negotiation auto

bridge-group 1

!

interface BVI1

ip address 10.37.123.4 255.255.255.0

!

bridge 1 protocol ieee

bridge 1 route ip

!

switch1:

!

vlan 123

!

interface GigabitEthernet5/1

description - connection to router gi0/2 -

switchport

switchport access vlan 123

switchport mode access

no ip address

!

interface vlan 123

ip address 10.37.123.1 255.255.255.0

!

switch2:

!

vlan 123

!

interface GigabitEthernet5/2

description - connection to router gi0/1 -

switchport

switchport access vlan 123

switchport mode access

no ip address

media-type rj45

!

interface vlan 123

ip address 10.37.123.2 255.255.255.0

!

This works well as long as the link choosen for forwarding from spanning tree first (here gi0/2) is online.

router#show spanning-tree brief

Bridge group 1

...

Interface Designated

Name Port ID Prio Cost Sts Cost Bridge ID Port ID

-------------------- ------- ---- ----- --- ----- -------------------- -------

GigabitEthernet0/1 128.2 128 4 BLK 0 32768 0019.a90a.f800 130.2

GigabitEthernet0/2 128.3 128 4 FWD 0 20480 0019.a90a.e800 130.1

If this link (the active one) goes down (by shutting down gi5/1 on switch1 for example) the traffic stops and the spanning tree changes to:

router#show spanning-tree brief

Bridge group 1

...

Interface Designated

Name Port ID Prio Cost Sts Cost Bridge ID Port ID

-------------------- ------- ---- ----- --- ----- -------------------- -------

GigabitEthernet0/1 128.2 128 4 FWD 0 32768 0019.a90a.f800 130.2

GigabitEthernet0/2 128.3 128 4 DWN 4 32768 0019.304d.881b 128.3

So far so good. But then the traffic don't resumes. And that is my problem, I expected the traffic to resume after the second link (gi0/1) is in forwarding state.

Am I doing something wrong?

Can someone of you give me a hint?

Or is there another way to connect one router to two switches and getting a redundant link at layer 2?

kind regards

Mark

3 REPLIES
Hall of Fame Super Bronze

Re: redundant layer2 link between a router and 2 switches

Let's see the whole spanning-tree picture while G0/2 is down from the 2 switches and the router.

Type show spanning-tree vlan 123 and post results.

New Member

Re: redundant layer2 link between a router and 2 switches

Hi

when interface gi0/2 on the router is shutdown the spanning-tree looks like:

router#sh spanning-tree brief

Bridge group 1

Spanning tree enabled protocol ieee

Root ID Priority 20480

Address 0019.a90a.e800

Cost 4

Port 2 (GigabitEthernet0/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 6 sec

Bridge ID Priority 32768

Address 0019.304d.881b

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Designated

Name Port ID Prio Cost Sts Cost Bridge ID Port ID

-------------------- ------- ---- ----- --- ----- -------------------- -------

GigabitEthernet0/1 128.2 128 4 FWD 0 32768 0019.a90a.f800 130.2

GigabitEthernet0/2 128.3 128 4 DWN 4 32768 0019.304d.881b 128.3

router#

switch1#sh spanning-tree vlan 123

MST15

Spanning tree enabled protocol mstp

Root ID Priority 24591

Address 0019.a90a.e800

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 6 sec

Bridge ID Priority 24591 (priority 24576 sys-id-ext 15)

Address 0019.a90a.e800

Hello Time 2 sec Max Age 20 sec Forward Delay 6 sec

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Te3/1 Desg FWD 2000 128.257 P2p

Gi8/1 Desg FWD 20000 128.897 P2p

Gi8/3 Back BLK 20000 128.899 P2p

switch2#sh spanning-tree vlan 123

MST15

Spanning tree enabled protocol mstp

Root ID Priority 24591

Address 0019.a90a.e800

Cost 2000

Port 257 (TenGigabitEthernet3/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 6 sec

Bridge ID Priority 32783 (priority 32768 sys-id-ext 15)

Address 0019.a90a.f800

Hello Time 2 sec Max Age 20 sec Forward Delay 6 sec

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Te3/1 Root FWD 2000 128.257 P2p

Gi5/2 Desg FWD 20000 128.514 P2p Bound(STP)

Gi7/1 Altn BLK 10000 128.769 P2p

Gi7/3 Altn BLK 20000 128.771 P2p

New Member

Re: redundant layer2 link between a router and 2 switches

any idea? anyone?

343
Views
0
Helpful
3
Replies
CreatePlease to create content