Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Regarding a GNS3 with Switch....

Hi All,


I just want to know may I able to configure switching Lab in GNS3 ????


I read some where we can configure swtiching lab in GNS3 by selecting slot ( NM-16ESW). but by selecting this option in router we can make router as a switch with 16 ports.. but we can't configure our router as a switch. Means We can't apply normal CMD's like Vlan ..etc....


I had used IOS :


c3640-jk9o3s-mz.123-14.T7.extracted

c7200-jk9o3s-mz.124-19

SW_c3560-advipservicesk9-mz.122-46.SE


But Not a single IOS is working as a switch... So, I want to know by using which IOS   I can do L3 setiching LAB.????


I want create LAB for Switching only. No need to add router .so, I can make my switch as router  for L3 purpose....


Please Give me solution ASAP.



Thanks,

Rajdeep P.

Thanks & regards, Rajdeep Parmar
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Regarding a GNS3 with Switch....

Hi All,


I just want to know may I able to configure switching Lab in GNS3 ????


I read some where we can configure swtiching lab in GNS3 by selecting slot ( NM-16ESW). but by selecting this option in router we can make router as a switch with 16 ports.. but we can't configure our router as a switch. Means We can't apply normal CMD's like Vlan ..etc....


I had used IOS :


c3640-jk9o3s-mz.123-14.T7.extracted

c7200-jk9o3s-mz.124-19

SW_c3560-advipservicesk9-mz.122-46.SE


But Not a single IOS is working as a switch... So, I want to know by using which IOS   I can do L3 setiching LAB.????


I want create LAB for Switching only. No need to add router .so, I can make my switch as router  for L3 purpose....


Please Give me solution ASAP.



Thanks,

Hi Rajdeep,

For switching practice using GNS3 simulator  there are two options to simulate switches.

1)  Use generic ethernet switch provided by GNS3 features:
- VLANs
- dot1q trunk

2) Use 16 port switch module in 3600 or 3700  series router
- more features than in generic switch
-  not features like PVLAN or MSTP (not in real life either)


Hope to Help !!

Ganesh.H

Remember to rate the helpful post

4 REPLIES
Community Member

Re: Regarding a GNS3 with Switch....

Hi,

   You can do switching labs in GNS3, but the technologies for switching are limited. Basic switching si available. If the vlans are not saved after router reload (vtp transparent) then, use vtp file nvram:vlan.dat , else don't use it.

R1#sh spanning-tree

VLAN20 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address cc00.1218.0000
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag set, detected flag set
  Number of topology changes 1 last change occurred 00:00:30 ago
          from FastEthernet1/1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 1, topology change 5, notification 0, aging 300

Port 42 (FastEthernet1/1) of VLAN20 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.42.
   Designated root has priority 32768, address cc00.1218.0000
   Designated bridge has priority 32768, address cc00.1218.0000
   Designated port id is 128.42, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 27, received 0

R1#
R1#vlan data
R1(vlan)#vl 21
VLAN 21 added:
    Name: VLAN0021
R1(vlan)#vtp tra
Device mode already VTP TRANSPARENT.
R1(vlan)#app
APPLY completed.
R1(vlan)#ex
APPLY completed.
Exiting....
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int vl21
R1(config-if)#ip address 21.21.21.21 255.255.255.0
R1(config-if)#no sh
R1(config)#int f1/1
R1(config-if)#swi
R1(config-if)#switchport access vlan 21
R1(config-if)#switchport trunk allowed vlan 1-2,20,1002-1005
R1(config)#vtp file nvram:vlan.dat
R1(config)#end
R1#
R1#sh spanning-tree summary
Root bridge for: VLAN21.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN21               0        0         1        0          1
-------------------- -------- --------- -------- ---------- ----------
              1 VLAN 0        0         1        0          1
R1#sh vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
20   VLAN0020                         active
21   VLAN0021                         active    Fa1/1
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
20   enet  100020     1500  -      -      -        -    -        0      0
21   enet  100021     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
R1#sh ip int br
*Mar  1 00:05:26.771: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan21, changed state to upief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1     YES NVRAM  up                    up
FastEthernet1/0            unassigned      YES unset  up                    down
FastEthernet1/1            unassigned      YES unset  up                    up
---

Vlan1                      unassigned      YES unset  up                    down
Vlan20                     20.20.20.20     YES manual up                    down
Vlan21                     21.21.21.21     YES manual up                    up
R1#sh  mac-address-table
Destination Address  Address Type  VLAN  Destination Port
-------------------  ------------  ----  --------------------
cc00.1218.0000          Self          1     Vlan1
cc00.1218.0000          Self         20     Vlan20
cc00.1218.0000          Self         21     Vlan21

R1#ping 21.21.21.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 21.21.21.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/26/72 ms
R1#sh  mac-address-table
Destination Address  Address Type  VLAN  Destination Port
-------------------  ------------  ----  --------------------
cc00.1218.0000          Self          1     Vlan1
cc00.1218.0000          Self         20     Vlan20
cc00.1218.0000          Self         21     Vlan21
cc01.1218.0000          Dynamic      21     FastEthernet1/1

R1#
R1#sh ip arp cc01.1218.0000
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  21.21.21.2              1   cc01.1218.0000  ARPA   Vlan21

R1#sh ver
Cisco IOS Software, 3600 Software (C3640-A3JS-M), Version 12.4(25c), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Fri 12-Feb-10 00:48 by prod_rel_team

ROM: ROMMON Emulation Microcode
ROM: 3600 Software (C3640-A3JS-M), Version 12.4(25c), RELEASE SOFTWARE (fc2)

R1 uptime is 11 minutes
System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19
System image file is "tftp://255.255.255.255/unknown"

Cisco 3640 (R4700) processor (revision 0xFF) with 124928K/6144K bytes of memory.
Processor board ID 00000000
R4700 CPU at 100MHz, Implementation 33, Rev 1.2
17 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity enabled.
125K bytes of NVRAM.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

R1#sh run
Building configuration...

Current configuration : 1189 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
vtp file nvram:vlan.dat

!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
switchport access vlan 21
switchport trunk allowed vlan 1,2,20,1002-1005
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan20
ip address 20.20.20.20 255.255.255.0
!
interface Vlan21
ip address 21.21.21.21 255.255.255.0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Re: Regarding a GNS3 with Switch....

Hi All,


I just want to know may I able to configure switching Lab in GNS3 ????


I read some where we can configure swtiching lab in GNS3 by selecting slot ( NM-16ESW). but by selecting this option in router we can make router as a switch with 16 ports.. but we can't configure our router as a switch. Means We can't apply normal CMD's like Vlan ..etc....


I had used IOS :


c3640-jk9o3s-mz.123-14.T7.extracted

c7200-jk9o3s-mz.124-19

SW_c3560-advipservicesk9-mz.122-46.SE


But Not a single IOS is working as a switch... So, I want to know by using which IOS   I can do L3 setiching LAB.????


I want create LAB for Switching only. No need to add router .so, I can make my switch as router  for L3 purpose....


Please Give me solution ASAP.



Thanks,

Hi Rajdeep,

For switching practice using GNS3 simulator  there are two options to simulate switches.

1)  Use generic ethernet switch provided by GNS3 features:
- VLANs
- dot1q trunk

2) Use 16 port switch module in 3600 or 3700  series router
- more features than in generic switch
-  not features like PVLAN or MSTP (not in real life either)


Hope to Help !!

Ganesh.H

Remember to rate the helpful post

Community Member

Re: Regarding a GNS3 with Switch....

Hi ..

Thanks  for your reply ..


Thanks,

Rajdeep P.

Thanks & regards, Rajdeep Parmar
Cisco Employee

Re: Regarding a GNS3 with Switch....

hi raj,

In most of the layer 3 switching all the forwarding are done by the hardware...  so in short , packets are all hardware switched.... so i would say switching is platform dependent which means each switch like 3750/4500/6500 has it own way for forwarding packets in hardware...

since this is platform specific, i think it cannot be done on gns3 even though you have the right IOS.

-balaji

13177
Views
5
Helpful
4
Replies
CreatePlease to create content