Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Regarding VLAN trunk

i team,

What is the effect of the below comand when we configure under swith interface and the same interface if connected to switch or Router.

switchport access vlan 601

switchport mode trunk

Please explain.

Thanks in advance.

Naveen

3 REPLIES
Cisco Employee

Regarding VLAN trunk

Naveen,

If the other side of this port is configured as trunk port then the port would be negotiated as trunk port hence there wouldnt be any use of access vlan 601 on the trunk port.

The command "switchport access vlan 601" has no effect in the second configuration since the switch ports are in trunking mode.

HTH

Regards

INayath

**Plz rate all usefull posts.

Cisco Employee

Regarding VLAN trunk

Let me give you a basic example:

I have connected 2 switches;

Switch 1-----F0/1--------------------F0/1---Switch 2

config

Switch 1

interface FastEthernet0/1

switchport access vlan 20

switchport trunk encapsulation dot1q

switchport mode trunk

Switch 2

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

Result:

========

Trunk negotiated and its passing all the vlans traffic over the trunk ports.

Switch-1

Switch1#sh int trunk

Port        Mode         Encapsulation  Status        Native vlan

Fa0/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/1       1-1005

Port        Vlans allowed and active in management domain

Fa0/1       1,10,20,30,40,50

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/1       1,10,20,30,40,50

=

SWitch2#sh int tr

Port        Mode         Encapsulation  Status        Native vlan

Fa0/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/1       1-1005

Port        Vlans allowed and active in management domain

Fa0/1       1,10,20,30,40,50

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/1       1,10,20,30,40,50

HTH
Regards

Inayath

*PLz rate and mark the thread as answwered if it answered your query.

New Member

Regarding VLAN trunk

Hi shareiff,

Thanks for the reply.

If we connect the router fast ethernet  at other end, what will be the possibility of the above mentioned command when we use router on stick concept.

128
Views
10
Helpful
3
Replies