Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Relay agent and forwarding query on 2960

Hi,

I need support on understanding and configuring dhcp relay agent

And forwarding. Lets say a bunch of TCP/IP devices required a dhcp ip where it is installed on a perticular server to run so. The server having dhcp pool where it provide the devices with IP addresses as he recieve queries from them requesting to release their addresses. On 2960 switch no dhcp configured and ports assigned under specific vlan under those devices. The issue here, if power goes down and booting process started, the devices started to ask the server for ip add and it takes too much time and somehow it does not take ip and those request kind a dropped. As the minimum requirement is to configure relay agent on the switch and forwarding and multicast?

Any idea!!!!

Note that its was been tested under dummy switch and it worked great!!!!

Sent from Cisco Technical Support iPhone App

Everyone's tags (1)
7 REPLIES
Purple

Relay agent and forwarding query on 2960

Hi,

configure  Portfast on all access ports with the global config command: spanning-tree portfast default.

Configuring a DHCP relay feature with ip helper-address command is only mandatory if your DHCP server is not on the same subnet as the DHCP clients.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: Relay agent and forwarding query on 2960

Thank cade. Just to make sure from what u said.

I configured the int of the devices with spanning tree portfast and switchport mode access then switchport access vlan ID.

And the above applied on all edge switches.

So do i have to configure the ip helper address at edge switches or in core switch L3 4503 where all edge switches connected to it?

And to configure ip helper address in specific vlan or in the general configuration?

Thx

Sent from Cisco Technical Support iPhone App

Hall of Fame Super Silver

Re: Relay agent and forwarding query on 2960

I am not clear from your description whether all devices are configured in a single VLAN or whether there are multiple VLANs involved. Perhaps you can clarify.

Pending the clarification I can offer some general advice:

- if all devices are in a single VLAN then no ip helper-address is required. All devices will be sending their DHCP requests to a server in the same VLAN/same subnet.

- if the DHCP server is in one VLAN and devices needing DHCP are in a different VLAN then ip helper-address is needed in the VLAN other than where the DHCP server is.

- if ip helper-address is required then it is configured on the layer 3 interface serving each of the VLANs where the devices are connected.

note that if there are several VLANs sending requests for DHCP then the DHCP server needs to have a unique scope for each of the VLANs.

HTH

Rick

New Member

Relay agent and forwarding query on 2960

all the devices are configured in specific vlan along all edge swithces and the server is in the same subnet mask. in this case no ip helper address needs to be involved as you mentioned becuz requests will go thru the server whose installed in the same subnet/vlan.

herein the confi of single switch :

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

vlan 30

name CCTV

!

vlan 40

name Car_Park

!

--More--         vlan 50

name Management

!

vlan 60

name Storage_1

!

vlan 70

name Storage_2

!

!

!

interface FastEthernet0

no ip address

!

interface GigabitEthernet1/0/1

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/2

switchport access vlan 30

switchport mode access

spanning-tree portfast

--More--         !

interface GigabitEthernet1/0/3

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/4

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/5

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/6

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/7

switchport access vlan 30

--More--          switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/8

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/9

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/10

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/11

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/12

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/13

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/14

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/15

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/16

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/17

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/18

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/19

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/20

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/21

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/22

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/23

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/24

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/25

switchport mode trunk

!

interface GigabitEthernet1/0/26

--More--         !

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface Vlan1

no ip address

!

interface Vlan50

ip address 10.100.50.20 255.255.255.0

!

ip default-gateway 10.100.50.1

ip http server

ip http secure-server

ip sla enable reaction-alerts

above is dupicated in 3-edge switchs and all of the conneted to L3 switch. the vlan which am talking about is 40 and has IP address range of 192.168.100.0/24 and server ip 192.168.100.200/24.

am not configuring any interface vlan 40 ip address. any advice pro !

Hall of Fame Super Silver

Relay agent and forwarding query on 2960

I still find your description confusing and would appreciate some clarification.

The config that you post here has ports in 2 VLANs, vlan 30 and vlan 40. Are both vlans using DHCP?

You seem to be saying that the DHCP server is in vlan 40. Is that correct? If so then there is no need for configuring ip helper-address in vlan 40.

If the DHCP server is in vlan 40 and if clients in vlan 30 need DHCP then there is need for ip helper-address in the SVI for vlan 30 on the layer 3 switch.

HTH

Rick

New Member

Relay agent and forwarding query on 2960

sorry for the consfusing.

yes, i have two vlans. DHCP server and client resides in vlan40 only. ports in vlan30 has no interfernce with vlan40.

so no need to configure ip helper address if both DHCP server and client are in the same Vlan.

then do i have to configure any additional commands to work it out ?

Regards

Hall of Fame Super Silver

Re: Relay agent and forwarding query on 2960

Yes, if the clients and the DHCP server are in the same VLAN there is no need for additional commands to get DHCP to work. Assuming that the DHCP server is correctly configured, and assuming that correct access or trunk connections are working between the edge switch and the layer 3 switch then the clients should be able to get an IP address assigned from the DHCP server.

HTH

Rick

829
Views
0
Helpful
7
Replies