Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

reliable static routing backup using object tracking

hello all. i'd like to confirm the following proposal before telling a customer the scenario is doable. a customer wishes to have a primary internet T1 connection, and a backup cable modem. i've been reading the PDF for reliable static routing and would like to make sure i can acheive the following config (i haven't tested it in a lab):

ip sla monitor 1

type echo protocol ipIcmpEcho 1.1.1.1 source-interface serial 0/1/0:0

timeout 1000

threshold 2

frequency 3

!

!

ip sla monitor schedule 1 life forever start-time now

!

track 50 rtr 1 reachability

!

!

interface Serial0/1/0:0

description - T1 connection -

ip address 1.1.1.2 255.255.255.252

!

interface FastEthernet0/0

description - Backup Cable Modem -

ip address dhcp

!

ip route 0.0.0.0 0.0.0.0 1.1.1.1 track 50

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 254

!

access-list 100 remark ACL to trigger PBR

access-list 100 permit icmp any host 1.1.1.1 echo

!

route-map PBR permit 10

match ip address 100

set ip next-hop 1.1.1.1

set interface Null 0

!

ip local policy route-map PBR

1 REPLY
Bronze

Re: reliable static routing backup using object tracking

I am assuming that you are pinging the far side of your serial interface in this config. if that is the case, you can still ping the /32 interace but that does not mean that the internet is reachable.

I would use either dns or http for the the SLA or ping an internet address. If I use either DNS or HTTP, I would not bother with the PRB.

Regards,

222
Views
0
Helpful
1
Replies
CreatePlease login to create content