Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Reload IOS from tftp problems...

Hi all,

I have a router that is completely dead: no flash, no nvram, nothing. I have an IOS image on my laptop which I am trying to load back onto the router.

When in rommon mode, I am getting the following error when I run the tftp command:

rommon 15 > tftpdnld

IP_ADDRESS: 169.254.160.219

IP_SUBNET_MASK: 255.255.0.0

DEFAULT_GATEWAY: 169.254.160.255

TFTP_SERVER: 169.254.169.218

TFTP_FILE: c2600-i-mz.122-5d.bin

Invoke this command for disaster recovery only.

WARNING: all existing data in all partitions on flash will be lost!

Do you wish to continue? y/n: [n]: y

....

ARP: address resolution for 169.254.169.218 timed out.

ARP failed with failure code 1. TFTP transfer aborted.

TFTP: Operation terminated prematurely.

I have tried various gateway address with the same result. My laptop has the image on it, and I've connected to e0/0 via a crossover ethernet cable. I am using tftpd32.

Help!

Thanks!

Chris

4 REPLIES
Silver

Re: Reload IOS from tftp problems...

Hi Chris ,

The key here is that it uses the e0/0 interface and the gateway must be on

that same segment. Remember that from rommon this router is only a host on the network. It looks and acts like an end device and has no routing capability at all. If the default gateway is not directly connected to the

e0/0 interface then the process will fail.

***The error message here gives you a clue to the problem. It sent an ARP request for 169.254.169.218 and did not receive a response. That indicates that 169.254.169.218 is not directly connected to the e0/0 interface.

Check the below link for tftpdnld procedure.

http://www.cisco.com/warp/public/471/76.html

Also you can try uploading IOS using xmodem command.Check the below link for xmodem procedure.

http://www.cisco.com/warp/customer/701/59.html#rommon

connect laptop to router using console cable and follow the steps mentioned in doc.

All the best..plz rate it..

Thanks,

satish

New Member

Re: Reload IOS from tftp problems...

Ok, but something is wrong here.

This is only a test router I have at work, and in actuality it only has ONE interface! LOL. e0/0.

Now, I am doing tftp for the first time, and what I did was copy the IOS from this router to the laptop in the same exact manner I am now trying to copy it right back (I have since completely wiped the flash and nvram).

But nothing changed from copying off to copying back on, other than wiping the router completely.

I have links on both the router e0/0 and laptop. Crossover cable in use.

I cannot ping the router from the laptop and obviously I cannot ping the laptop from the router.

They are connected, and like I said, this was the same setup i used to dump the IOS off the router in the first place.

Help!

New Member

Re: Reload IOS from tftp problems...

Nevermind...

For some reason, I rebooted the router, tried again, and this time it felt like working... Silly!

Chris

Silver

Re: Reload IOS from tftp problems...

Hi ,

Great ............ :)

thanks,

satish

444
Views
0
Helpful
4
Replies