Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Remove Default gateway IP address

Good morning,

I have a 3500 XL switch with the following default gate IP address that i need to clear from the switch but not quite shore how to remove it.

I've removed the customer original Ip for security reason as this is an open discussion forum and just replaced with 1.1.1.1

switch#show ru

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname switch

!

!

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface VLAN1

no ip address

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 1.1.1.1 

!

line con 0

transport input none

stopbits 1

line vty 0 4

login

line vty 5 15

login

!

end

switch#

regards

Paul

2 REPLIES
Cisco Employee

Remove Default gateway IP address

Hello Paul,

In order to remove the default gateway, you should enter the following command:

no ip default-gateway 1.1.1.1

into the global config mode of the switch.

There is a gotcha, however: It has been my experience that if Catalyst switches do not have their default IP gateway configured, they fall back to using ProxyARP - they ARP for each destination IP address of packets they send out. Because many routers usually have ProxyARP activated, they will respond, allowing these switches to actually access other networks. So even with no default gateway configured, Catalyst switches are usually able to connect to the outside world.

The solution should be twofold: disable ProxyARP on all routers in your network, and define the default gateway IP address on the switches to a non-existent IP address in the network.

Best regards,

Peter

New Member

Remove Default gateway IP address

Hi Peter,

I've run the command & IP on the default gateway has now been removed,

thank you

regards

Paul

9403
Views
5
Helpful
2
Replies
CreatePlease login to create content