Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Reverse telnet does not work - hangs at Opening...

Hey guys, I have a 2610 with IOS 12.0(7) installed and a NM-16A (with two CAB-OCTAL-ASYNC cables connected to some switches and routers). I have configured the lines but am not able to reverse telent to any devices.

The devices range from 2900xl and 2950 switches to 2500/2600/3600 routers.

When I try to reverse telnet, all I get is this message and a blinking cursor:

ACCESS_SERVER#sw1

Trying SW1 (10.10.10.10, 2033)... Open

_

It does the same thing when I try

telnet 10.10.10.10 2033

Here is a copy of the current config:

!

version 12.0

service nagle

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ACCESS_SERVER

!

!

ip subnet-zero

no ip domain-lookup

ip host R5 2045 10.10.10.10

ip host R4 2044 10.10.10.10

ip host R3 2043 10.10.10.10

ip host R2 2042 10.10.10.10

ip host R1 2041 10.10.10.10

ip host SW5 2037 10.10.10.10

ip host SW4 2036 10.10.10.10

ip host SW3 2035 10.10.10.10

ip host SW2 2034 10.10.10.10

ip host SW1 2033 10.10.10.10

ip host ACCESS_SERVER 10.10.10.10

!

!

interface Loopback0

ip address 10.10.10.10 255.255.255.0

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

interface Ethernet0/0

ip address 172.16.11.254 255.255.255.0

no ip directed-broadcast

full-duplex

!

interface Serial0/0

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Group-Async1

no ip address

no ip directed-broadcast

group-range 33 48

!

ip default-gateway 172.16.11.1

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.11.1

ip route 192.168.1.0 255.255.255.0 172.16.11.1

no ip http server

!

line con 0

exec-timeout 30 0

logging synchronous

login local

transport input none

line 33 48

session-timeout 60

exec-timeout 0 0

transport input all

speed 19200

line aux 0

line vty 0 4

exec-timeout 30 0

logging synchronous

login local

transport input telnet

!

no scheduler allocate

end

I've read the tech note on Configuring a Terminal/Comm Server and it seems pretty basic but it's just not working as advertised.

The async interfaces show down/down but I'm not sure what config is needed on these?

Also, there are no lights on for the NM-16A so I'm assuming there is something else that needs to be enabled before this will work but I'm not sure what.

I've probably missed something simple even though I've spent 4 hours researching this and troubleshooting to try to get it to work.

Thanks for any help you can provide!

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Bronze

Re: Reverse telnet does not work - hangs at Opening...

try changing the speed on the lines until you get a response. What setting do you use on a laptop if you were to connect directly on these devices ? Use the same setting under line 33-48.

HTH,

__

Edison.

Hall of Fame Super Silver

Re: Reverse telnet does not work - hangs at Opening...

Since the default speed for console connections is 9600 I suspect that Edison got this one. I missed the setting for line speed in the original post. Now it stands out.

HTH

Rick

7 REPLIES
Hall of Fame Super Bronze

Re: Reverse telnet does not work - hangs at Opening...

Try no exec and enable flowcontrol hardware under line 33-48.

__

Edison.

New Member

Re: Reverse telnet does not work - hangs at Opening...

I added them but no luck...

By the way, the sessions show up but I can't access them so I end up having to close them down:

ACCESS_SERVER#sh sess

Conn Host Address Byte Idle Conn Name

1 sw1 10.10.10.10 0 0 sw1

2 sw4 10.10.10.10 0 0 sw4

3 sw5 10.10.10.10 0 0 sw5

* 4 sw3 10.10.10.10 0 0 sw3

ACCESS_SERVER#disc 1

Closing connection to sw1 [confirm]

ACCESS_SERVER#disc 2

Closing connection to sw4 [confirm]

ACCESS_SERVER#disc 3

Closing connection to sw5 [confirm]

ACCESS_SERVER#disc 4

Closing connection to sw3 [confirm]

ACCESS_SERVER#

Hall of Fame Super Silver

Re: Reverse telnet does not work - hangs at Opening...

Thomas

I agree with Edison that the command no exec helps a lot and is probably the most often overlooked command when configuring reverse telnet. I hope that adding these commands will overcome your problem.

But I am concerned about your statement saying there are no lights on the async module. It might be helpful if you would post the output of show line and the output of show diag from this router.

The other thing that I have seen that would produce this symptom is confusion about which cable is which and the connection they were trying to make is not connected to the device they expect (or sometimes not connected to any device). Can you verify that the cable connected to SW1 is the first connecting cable in the first octal cable?

HTH

Rick

New Member

Re: Reverse telnet does not work - hangs at Opening...

Thanks Rick,

The commands did not help, but I'm sure they are needed as I'm seeing them in other people's sample configs.

Here's the show line:

ACCESS_SERVER#sh line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

* 0 CTY - - - - - 7 0 0/0 -

33 TTY 19200/19200 - - - - - 4 0 0/0 -

34 TTY 19200/19200 - - - - - 0 0 0/0 -

35 TTY 19200/19200 - - - - - 1 0 0/0 -

36 TTY 19200/19200 - - - - - 1 2993 0/150 -

37 TTY 19200/19200 - - - - - 1 0 0/0 -

38 TTY 19200/19200 - - - - - 0 0 0/0 -

39 TTY 19200/19200 - - - - - 0 0 0/0 -

40 TTY 19200/19200 - - - - - 0 0 0/0 -

41 TTY 19200/19200 - - - - - 0 0 0/0 -

42 TTY 19200/19200 - - - - - 0 0 0/0 -

43 TTY 19200/19200 - - - - - 0 0 0/0 -

44 TTY 19200/19200 - - - - - 0 0 0/0 -

45 TTY 19200/19200 - - - - - 0 0 0/0 -

46 TTY 19200/19200 - - - - - 0 0 0/0 -

47 TTY 19200/19200 - - - - - 0 0 0/0 -

48 TTY 19200/19200 - - - - - 0 0 0/0 -

65 AUX 9600/9600 - - - - - 0 0 0/0 -

66 VTY - - - - - 0 0 0/0 -

67 VTY - - - - - 0 0 0/0 -

68 VTY - - - - - 0 0 0/0 -

69 VTY - - - - - 0 0 0/0 -

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

70 VTY - - - - - 0 0 0/0 -

Line(s) not in async mode -or- with no hardware support:

1-32, 49-64

I also verified that the 1st cable (#1) coming from the octal cable is connected to SW1.

Here is the show diag:

ACCESS_SERVER#sh diag

Slot 0:

C2610 1E Mainboard Port adapter, 2 ports

Port adapter is analyzed

Port adapter insertion time unknown

EEPROM contents at hardware discovery:

Hardware revision 2.3 Board revision C0

Serial number 2285005415 Part number 73-2839-13

Test history 0x0 RMA number 00-00-00

EEPROM format version 1

EEPROM contents (hex):

0x20: 01 91 02 03 88 32 6A 67 49 0B 17 0D 00 00 00 00

0x30: 60 66 65 06 00 00 00 00 00 00 00 00 00 00 00 00

WIC Slot 0:

Serial 1T WAN daughter card

Hardware revision 1.0 Board revision J0

Serial number 25737701 Part number 800-01514-01

Test history 0x0 RMA number 00-00-00

Connector type Wan Module

EEPROM format version 1

EEPROM contents (hex):

0x20: 01 02 01 00 01 88 B9 E5 50 05 EA 01 00 00 00 00

0x30: 98 00 00 00 01 07 08 01 FF FF FF FF FF FF FF FF

Slot 1:

Async Port adapter, 16 ports

Port adapter is analyzed

Port adapter insertion time unknown

EEPROM contents at hardware discovery:

Hardware revision 0.1 Board revision E0

Serial number 25098430 Part number 800-02244-05

Test history 0x0 RMA number 00-00-00

EEPROM format version 1

EEPROM contents (hex):

Thanks for looking at this for me guys.

Thomas

Hall of Fame Super Bronze

Re: Reverse telnet does not work - hangs at Opening...

try changing the speed on the lines until you get a response. What setting do you use on a laptop if you were to connect directly on these devices ? Use the same setting under line 33-48.

HTH,

__

Edison.

Hall of Fame Super Silver

Re: Reverse telnet does not work - hangs at Opening...

Since the default speed for console connections is 9600 I suspect that Edison got this one. I missed the setting for line speed in the original post. Now it stands out.

HTH

Rick

New Member

Re: Reverse telnet does not work - hangs at Opening...

That was exactly it! I changed the speed to 9600 per Rick's suggestion and it worked great.

Thanks for your help guys, working like a champ.

Interestingly, the lights on the asynch lines never light up, even when there is data transfering across the wire. Not sure why not but I'm not worried since the access server is up and running now.

Again, thanks for the help.

Thomas

1677
Views
0
Helpful
7
Replies
CreatePlease to create content