Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Rip 1 Across Differents Vlans

Hello ! I've got headache to try to solve a lab .

The situation include 2 cisco routers an 2 switch 3550

so we have  Router A  in Vlan x access ----->Sw1----Trunk----Sw2<------Vlan y Access Router B

I 've to enable rip1 on guys A and B ONLY !!! Avoiding any kind of tunnel

I though it was all around fallBAck bridging ... but after days of tries .... i dont have found any solution ...

May you have any kind of idea ?Better solution

Ty !

Everyone's tags (6)
3 REPLIES
Purple

Re: Rip 1 Across Differents Vlans

Hi,

configure sw1-sw2 as access port in same vlan rtrA and sw2-sw1 as access port in same vlan as rtrB then under RIP process on each router configure no validate-update-source and it should work.

EDIT:  I tried it and the rip routes were propagated indeed but there is a recursive lookup problem due to ARP and it won't work even with static arp entries

so finally not a valid solution for your problem. Gonna think  it over and if I find something working without a tunnel I'll let you know

EDIT2:  configure ip mobile arp on both routers fastethernet then shut/no shut the interface and it iwill work, I've tried it on GNS3.

but I didn't use a trunk link between the 2 switches but configuring the other end access vlan as native vlan on each switch should do the trick with

the trunk link.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re: Rip 1 Across Differents Vlans

Halo Just updates the info about LAb

RTB SERVER DHCP PPPOE ------>FA/0 (172.16.100.1) both access vlan 100  BVi interface bridge

                                                      ------>FA/1

RTC Client DHCP PPPOE FA/0 Access VLan 100

                                                    

Between those guys we SW1 ------ Trunk ------ Sw2

RTD SErver DHCP PPPOE ------- FA0/1 both access vlan 130  (172.16.130.1)  BVI interface bridge                                         --                                                      --                                                     --FA0/0

Between those guys we SW1 ------ Trunk ------ Sw2

RTE Client DHCP PPPOE FA0/0 Access Vlan 130

At thi point i 've to configure w/0 any kind o tunnel a ripv1 session Between RTE And RTC....

BEing a point to point , when i do debug ip rip ...see ofc my dialer 1 send ip to BVI that discard it because it does not hase any FIB lookup ruting.

THis if i left rip in Broadcast ....if i dgt neighobor x.x.x.x it does not work anyway

Using no validate-update under rip process...also

ANy suggestion

Ty in advice ...

Purple

Rip 1 Across Differents Vlans

Hi,

have you tried the solution I posted before because I tested it in GNS3 and it worked, it should even work without the mobile arp but just configuring static arp entries for each RIP router and shutting/no shutting the interfaces.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
450
Views
0
Helpful
3
Replies