Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Rip V2 Loopback Advertisement

Hi, I am having some difficulty understanding a setback I'm experiencing with RIP version 2 advertising and a loopback design.

I have 3 routers, each connected through ethernet and serial, and each with a loopback interface using a /29 mask and the ips 10.1.1.1-3. I have added the networks to my router rip satements, networks 192.168.1.0 and 10.1.1.0. All of my ethernet and serial interafces using the 192.168.1.0 spaces are able to ping fine to and from each router.

The problem I can't understand at the moment is in my router rip statement: it is changing 10.1.1.0 to 10.0.0.0. I thought at first this was because I wasn't using the no auto-summarization statement, but i have added that and it is still changing the network back to 10.0.0.0. I know this is something simple that I am just overlooking in my notes, but I need help. Hints, suggestions and full-on answers are all welcome!

here is a spoke router ip route:

Gateway of last resort is not set

     10.0.0.0/29 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Loopback0

     192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks

C       192.168.1.8/29 is directly connected, Serial1/3

C       192.168.1.0/30 is directly connected, FastEthernet0/0

R       192.168.1.128/25 [120/1] via 192.168.1.1, 00:00:20, FastEthernet0/0

                         [120/1] via 192.168.1.10, 00:00:25, Serial1/3

R2#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

and here is a show run of that router:

R2#show run

Building configuration...

Current configuration : 1041 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$0UdW$yy6AD7sKOwdA1EYZPGp0A0

enable password lab

!

memory-size iomem 30

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

!

!

!

no ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 10.1.1.2 255.255.255.248

!

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.252

duplex auto

speed auto

!

interface Serial1/0

no ip address

shutdown

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

ip address 192.168.1.12 255.255.255.248

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

ip http server

no ip http secure-server

ip classless

!

!

!

!

!

!

!

!

!

!

!

line con 0

login

line aux 0

line vty 0 4

password lab

login

line vty 5 181

password lab

login

!

!

end

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: Rip V2 Loopback Advertisement

Look, you are using 10.1.1.1 - 10.1.1.2 - 10.1.1.3 / 29 for your loopbacks, they are basically in ONE logical subent, and this is where u r getting it wrong. all ur routers think they have these routes Connected, so adv's are getting ignored.

10.1.1.0 - 10.1.1.7 is practically ONE range try ip addresses in another ranges for each Lo0 or use an /32 mask for them.

HTH,

plz Rate if it helped.

Soroush.

Hope it Helps!

Soroush.
6 REPLIES

Re: Rip V2 Loopback Advertisement

RIP always changes the entry to the classful network. Since you have version 2 specified, it will advertise the mask along with your subnets, so what you're seeing is normal. As far as not having your other networks, make sure that you have version 2 specified in the rip process on those routers as well along with no auto-summary. Can you post the other rip processes if this doesn't work?

HTH, John *** Please rate all useful posts ***

Rip V2 Loopback Advertisement

It looks like version 2 is enabled on all the routers, and I can ping on the 192 adresses, just not the 10s.

here are the running configs and ip routes for all three routers:

router 1:

hostname R1

interface Loopback0

ip address 10.1.1.1 255.255.255.248

!

interface Ethernet0

ip address 192.168.1.130 255.255.255.128

!

interface Serial0

ip address 192.168.1.9 255.255.255.248

clockrate 64000

!

interface Serial1

ip address 192.168.1.10 255.255.255.248

clockrate 64000

!

router rip

version 2

network 192.168.1.0

network 10.0.0.0

no auto-summary

!

ip classless

end

Gateway of last resort is not set

     10.0.0.0/29 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Loopback0

     192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks

C       192.168.1.8/29 is directly connected, Serial1

                       is directly connected, Serial0

R       192.168.1.0/30 [120/1] via 192.168.1.129, 00:00:17, Ethernet0

                       [120/1] via 192.168.1.11, 00:00:24, Serial0

                       [120/1] via 192.168.1.12, 00:00:14, Serial1

C       192.168.1.128/25 is directly connected, Ethernet0

R1#ping 10.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R1#ping 10.1.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Router 2:

hostname R2

ip subnet-zero

no ip cef

interface Loopback0

ip address 10.1.1.2 255.255.255.248

!

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.252

duplex auto

speed auto

!

interface Serial1/0

no ip address

shutdown

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

ip address 192.168.1.12 255.255.255.248

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

ip http server

no ip http secure-server

ip classless

!

end

Gateway of last resort is not set

     10.0.0.0/29 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Loopback0

     192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks

C       192.168.1.8/29 is directly connected, Serial1/3

C       192.168.1.0/30 is directly connected, FastEthernet0/0

R       192.168.1.128/25 [120/1] via 192.168.1.1, 00:00:18, FastEthernet0/0

                         [120/1] via 192.168.1.10, 00:00:25, Serial1/3

R2#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R2#ping 10.1.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Router 3:

hostname R3

no aaa new-model

ip subnet-zero

ip cef

interface Loopback0

ip address 10.1.1.3 255.255.255.248

!

interface FastEthernet0/0

ip address 192.168.1.129 255.255.255.128

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.1.11 255.255.255.248

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.252

duplex auto

speed auto

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

no ip http server

ip classless

end

Gateway of last resort is not set

     10.0.0.0/29 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Loopback0

     192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks

C       192.168.1.8/29 is directly connected, Serial0/0

C       192.168.1.0/30 is directly connected, FastEthernet0/1

C       192.168.1.128/25 is directly connected, FastEthernet0/0

R3#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R3#ping 10.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

And just for kicks here are some ping examples over the serial connection that are working:

R3#ping 192.168.1.9

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.9, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/50/64 ms

R3#ping 192.168.1.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/56/84 ms

R3#ping 192.168.1.12

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.12, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/66/80 ms

Gold

Rip V2 Loopback Advertisement

Hey john,

by default rip only sends ver 1 updates, but is open to receive ver 1 and 2. so you have to manually make it send out ver 2 updates.

to make it all ver 2, add these commands under your interfaces involved in rip process:

ip rip send ver 2

ip rip receive ver 2

HTH,

plz Rate if it helped.


Soroush.

Hope it Helps!

Soroush.

Re: Rip V2 Loopback Advertisement

I have added those statements and still cannot ping.

I ran a debug ip rip on R1 and found that the advertisements are being sent across my serial connections. Both are directly connected, but I am not receiving any advertisements from the othe loopbacks. I am however ignoring the advertisement for the loopback on R1. It is sending and receiving in version 2.

Routers 2 and 3 which are spokes from R1 are not sending or receiving any RIP updates. I am getting the sneaking suspicion that this has everything to do with my serial hub and spoke setup. I have not configured encapsulation or any of that. Since I don't have PPP setup, I'm guessing the RIP advertisements are being dropped and routers 2 and 3 simply have nothing to advertise to or receiv from.

Thanks again for all the input!

Also, here is a debug from R1

R1#

RIP: sending v2 update to 224.0.0.9 via Ethernet0 (192.168.1.130)

     192.168.1.8/29 -> 0.0.0.0, metric 1, tag 0

     10.1.1.0/29 -> 0.0.0.0, metric 1, tag 0

RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.1.1)

     192.168.1.8/29 -> 0.0.0.0, metric 1, tag 0

     192.168.1.0/30 -> 0.0.0.0, metric 2, tag 0

     192.168.1.128/25 -> 0.0.0.0, metric 1, tag 0

RIP: sending v2 update to 224.0.0.9 via Serial0 (192.168.1.9)

     192.168.1.128/25 -> 0.0.0.0, metric 1, tag 0

     10.1.1.0/29 -> 0.0.0.0, metric 1, tag 0

RIP: sending v2 update to 224.0.0.9 via Serial1 (192.168.1.10)

     192.168.1.128/25 -> 0.0.0.0, metric 1, tag 0

     10.1.1.0/29 -> 0.0.0.0, metric 1, tag 0

RIP: ignored v2 packet from 10.1.1.1 (sourced from one of our addresses)

RIP: received v2 update from 192.168.1.129 on Ethernet0

     10.1.1.0/29 -> 0.0.0.0 in 1 hops

     192.168.1.0/30 -> 0.0.0.0 in 1 hops

     192.168.1.8/29 -> 0.0.0.0 in 1 hops

RIP: received v2 update from 192.168.1.11 on Serial0

     10.1.1.0/29 -> 0.0.0.0 in 1 hops

     192.168.1.0/30 -> 0.0.0.0 in 1 hops

     192.168.1.128/25 -> 0.0.0.0 in 1 hops

RIP: received v2 update from 192.168.1.12 on Serial1

     10.1.1.0/29 -> 0.0.0.0 in 1 hops

     192.168.1.0/30 -> 0.0.0.0 in 1 hops

RIP: sending v2 update to 224.0.0.9 via Ethernet0 (192.168.1.130)

     192.168.1.8/29 -> 0.0.0.0, metric 1, tag 0

     10.1.1.0/29 -> 0.0.0.0, metric 1, tag 0

RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.1.1)

     192.168.1.8/29 -> 0.0.0.0, metric 1, tag 0

     192.168.1.0/30 -> 0.0.0.0, metric 2, tag 0

     192.168.1.128/25 -> 0.0.0.0, metric 1, tag 0

RIP: sending v2 update to 224.0.0.9 via Serial0 (192.168.1.9)

     192.168.1.128/25 -> 0.0.0.0, metric 1, tag 0

     10.1.1.0/29 -> 0.0.0.0, metric 1, tag 0

RIP: sending v2 update to 224.0.0.9 via Serial1 (192.168.1.10)

     192.168.1.128/25 -> 0.0.0.0, metric 1, tag 0

     10.1.1.0/29 -> 0.0.0.0, metric 1, tag 0

RIP: ignored v2 packet from 10.1.1.1 (sourced from one of our addresses)

RIP: received v2 update from 192.168.1.129 on Ethernet0

     10.1.1.0/29 -> 0.0.0.0 in 1 hops

     192.168.1.0/30 -> 0.0.0.0 in 1 hops

     192.168.1.8/29 -> 0.0.0.0 in 1 hops

RIP: received v2 update from 192.168.1.11 on Serial0

     10.1.1.0/29 -> 0.0.0.0 in 1 hops

     192.168.1.0/30 -> 0.0.0.0 in 1 hops

     192.168.1.128/25 -> 0.0.0.0 in 1 hopsunebug all

Gold

Re: Rip V2 Loopback Advertisement

Look, you are using 10.1.1.1 - 10.1.1.2 - 10.1.1.3 / 29 for your loopbacks, they are basically in ONE logical subent, and this is where u r getting it wrong. all ur routers think they have these routes Connected, so adv's are getting ignored.

10.1.1.0 - 10.1.1.7 is practically ONE range try ip addresses in another ranges for each Lo0 or use an /32 mask for them.

HTH,

plz Rate if it helped.

Soroush.

Hope it Helps!

Soroush.

Rip V2 Loopback Advertisement

Soroushm,

Thank you for that lesson. I misunderstood the concept of discontiguous networks. I thought that in addition to subnets of same network number being able to be connected by subnets of different networknumbers, directly connected routers could all belong to the same network as incremented hosts. Obviously this was wrong.

I changed each loopback to a /32 and I can ping every interface from ever other interace now.

4308
Views
10
Helpful
6
Replies
CreatePlease to create content