Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

rmon recovery using tftp

I have a 2801 primary rotuer with corrupt IOS.I'm trying to get this setup in rmon so I can ull an image from connected tftp server on another network.I have set it up but keep getting the same arp error.

rommon 30 > tftpdnld

IP_ADDRESS: 198.249.243.126

IP_SUBNET_MASK: 255.255.255.224

DEFAULT_GATEWAY: 198.249.243.125

TFTP_SERVER: 207.186.22.241

TFTP_FILE: /adp/c2801-advsecurityk9-mz.124-10c.bin

TFTP_MACADDR: 00:1d:70:14:97:f8

TFTP_VERBOSE: Progress

TFTP_RETRY_COUNT: 2

TFTP_TIMEOUT: 300

TFTP_CHECKSUM: No

FE_PORT: 0

FE_SPEED_MODE: Auto Detect

Invoke this command for disaster recovery only.

WARNING: all existing data in all partitions on flash: will be lost!

Do you wish to continue? y/n: [n]: y

.

ARP: address resolution for 198.249.243.125 timed out.

ARP failed with failure code 1. TFTP transfer aborted.

.125 is the backup router with an attached internet connection which is up on all interfaces.

.126 is the down 2801.

I suspect this may have to do with the fact this router has two fa interfaces and rmon may be config'ing the wrong one.

I am sure the down router has a physical connection to switch.This was all up and running before IOS got corrupted.

Noticed also that from .125 router I cannot ping .126 which again leads me to believe it's not initializing the right

FA port.There are no rmon options to delect a specific FA port.

This is how it was configured just before IOS was corrupted.

interface FastEthernet0/0

description trunk port

no ip address

no ip redirects

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

no ip redirects

ip nat inside

no ip virtual-reassembly

no ip mroute-cache

!

interface FastEthernet0/0.75

encapsulation dot1Q 75

ip address 198.249.243.126 255.255.255.224

no ip redirects

ip nat inside

no ip virtual-reassembly

no ip mroute-cache

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

so why am I getting this ARP error ?

3 REPLIES

Re: rmon recovery using tftp

Based on doc, "If the router has two built-in Ethernet or fast Ethernet interfaces, always use the first interface (usually 0/0). You must use the built-in interface."

Since it is in rommon, the previous config should not be loaded.

Can you try to connect TFTP server in the same subnet?

By the way, what's that TFTP MAC, if they are in the different subnet, your router has no reason to need that info.

Hall of Fame Super Gold

Re: rmon recovery using tftp

Do you have another 2801 physically nearby? You can use the Compact Flash from that to boot this one that's corrupt.

Community Member

Re: rmon recovery using tftp

so you know - the answer was simply enabling spanning-tree portfast on the attached switchport.Thanks

465
Views
0
Helpful
3
Replies
CreatePlease to create content