Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Route from layer 3 switch to router to internet

Hey guys,

I'm trying to figure out how to route packets not in the subnet out the switch to the router and then to the cable modem.

I'm guessing I have to set a static route but I can't figure out how.

I'm lost when it comes to fa0/3 on the L3 switch and fa0/0 on the router. The config files are below. Can anyone help?

Thanks!

 

 

 

R1:

Current configuration : 547 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.6
 encapsulation dot1Q 6
 no ip address
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

 

S1:

Current configuration : 1495 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
 switchport trunk allowed vlan 6-7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 6-7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk allowed vlan 6-7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan6
 ip address 192.168.6.1 255.255.255.0
!
interface Vlan7
 ip address 192.168.7.1 255.255.255.0
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

 

S2:

Current configuration : 1219 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk allowed vlan 6-7
 switchport mode trunk
!
interface FastEthernet0/2
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 6
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 7
 switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

 

S3:

Current configuration : 1121 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk allowed vlan 6-7
 switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 7
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

 

 

2 REPLIES
Bronze

If you trunk from the switch

If you trunk from the switch to the router then you would normally use the router as the default gateway so your performing your routing function on the router rather than the L3 switch. Config would on the router e.g.:

interface FastEthernet0/1
 no ip address
!
interface FastEthernet0/1.6
 description VLAN 6
 encapsulation dot1Q 6
 ip address 192.168.6.2 255.255.255.0
 !
interface FastEthernet0/1.7
 description VLAN 7
 encapsulation dot1Q 7
 ip address 192.168.7.2 255.255.255.0


Or setup a VLAN specifcially for routing out e.g. VLAN10. On the switch configure the switch port as an access port in VLAN10 and setup an SVI e.g. 192.168.10.1.

On the router configure Fa0/0 with an IP address 192.168.10.2.

Setup a default route on the switch to 192.168.10.2.

On the router setup static routes to 192.168.6.0/24 & 192.168.7.0/24 via 192.168.10.1

Hope that makes sense!

New Member

This is 100% correct.If you

This is 100% correct.

If you're hosting your VLANs on the router and trunking to the switch, then the router has to do the routing. 

If you want to do the routing on the switch, then the routing simply becomes a gateway and should be connected on an access port - preferably on a dedicated management VLAN.

969
Views
0
Helpful
2
Replies