Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Route internet traffic from 4 Port Switch C1921 Router

Hey smart peoples.
I have a 1921 router with a 4 port switch for our internet router, I have  our public wireless plugged into the 4 port switch on the router but cannot  figure out how to pass traffic outside of the router from our public wireless  controller. The public wireless is a tagged from the controller vlan 253, I can  ping the vlan ip address but nothing beyond.

Some one did mention the access list is 10 and i have a ip nat inside source list 1, but this is working for our internet router fine, I just need to add our wireless controller to connect directly to the switch so it does not touch our network.

Thanks

Mike

Here is my current config.

Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version  15.1(4)M3, RELEASE SOFTWARE (fc1)


hostname  inet-router
!
boot-start-marker
boot-end-marker
!
!
no logging  console
!
no aaa new-model
clock timezone MST -7 0
clock summer-time  MDT recurring
!
no ipv6 cef
ip source-route
ip  cef
!

!
no ip bootp server
no ip domain lookup

multilink bundle-name authenticated
!
crypto pki token default  removal timeout 0
!
!
!
!
vtp mode transparent
!
!
vlan  253
!
!
interface Embedded-Service-Engine0/0
no ip  address
shutdown
!
interface GigabitEthernet0/0
description  Interface to PIX Firewall
ip address 206.127.2.89 255.255.255.248
duplex  full
speed 1000
!
interface GigabitEthernet0/1
description Link to Internet Provider DS3 Radio
bandwidth 45000
ip address 206.127.0.30  255.255.255.252
no ip redirects
no ip unreachables
no ip  proxy-arp
ip nat outside
ip virtual-reassembly in
duplex  auto
speed auto
!
interface GigabitEthernet0/0/0
description  Interface to Cisco Public Wireless
switchport trunk allowed vlan  1,253,1002-1005
switchport mode trunk
no ip address
!
interface  GigabitEthernet0/0/1
no ip address
shutdown
!
interface  GigabitEthernet0/0/2
no ip address
shutdown
!
interface  GigabitEthernet0/0/3
no ip address
shutdown
!
interface  Vlan1
no ip address
shutdown
!
interface Vlan253
ip address  192.168.253.1 255.255.255.0
ip nat inside
ip virtual-reassembly  in
!
ip forward-protocol nd
!
no ip http server
no ip http  secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0  overload
ip route 0.0.0.0 0.0.0.0 206.127.1.29
ip route 206.127.8.0  255.255.255.0 206.127.2.90
!
access-list 10 permit  206.127.2.90
access-list 10 permit 192.168.253.0 0.0.0.255
dialer-list 1  protocol ip permit
!
!
snmp-server community public RO
snmp-server  enable traps tty

!
control-plane
!

end

1 REPLY
Hall of Fame Super Blue

Route internet traffic from 4 Port Switch C1921 Router

Mike

It's not clear exactly what you are trying to do and there are few things in your config that are confusing ie.

you have two links, one goes to your ISP and the other to your firewall. You have "ip nat outside" on your ISP connection. So does traffic not go via the firewall ?

In terms of your wireless, if you are trying to NAT the 192.168.253.x addresses then your NAT statement is wrong ie. -

ip nat inside source list 1 interface GigabitEthernet0/0  overload

you are referencing acl 1 but your acl in the config is acl 10 so you should remove the above and replace it with -

no ip nat inside soure list 1 interface gi0/0 overload

ip nat inside source list 10 interface gi0/0 overload

or if you want just change the acl from 10 to 1. Up to you.

Jon

136
Views
0
Helpful
1
Replies
CreatePlease to create content