Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Route-Map mistake

HI

please help me for the following config if there is any wrong configuration

**** PLEASE ITS CRITICAL PEOBLEM HELP ME ****

i Have 2 cacheServer in my network and it connected to a  Border Router Via different link for each Cache Server

and the border router connect to 2 Router Users

i create route map to send traffic User 1 to cache server 1 and  send traffic User 2 to Cache Server 2

User 1 IP range : 20.20.20.0 255.255.255.0

User 2 IP range : 30.30.30.0 255.255.255.0

CacheServer 1 : 1.1.1.2

CacheServer 2 : 2.2.2.2

Port gig 0/25  connect to my ISP

interface gig 0/1

description " To - CacheServer 1 "

no switchport

ip address 1.1.1.1 255.255.255.252

!

interface gig 0/2

description " To - CacheServer 2 "

no switchport

ip address 2.2.2.1 255.255.255.252

shutdown

!

interface gig 0/3

description " To - User 1 "

no switchport

ip address 10.10.2.1 255.255.255.248

ip policy route-map Cient_side_map1

!

interface gig 0/4

description "To- User 2"

no switchport

ip address 10.10.3.1 255.255.255.248

ip policy route-map Client_side_map2

!

interface gig 0/25

description " Tishknet-To-ISP "

no switchport

ip address 192.168.1.2 255.255.255.248

ip policy route-map Internet_side_map

!

ip access-list extended Client_side1

permit tcp 20.20.20.0 0.0.0.255 any eq www

ip access-list extended Client_side2

permit tcp 30.30.30.0 0.0.0.255 any eq www

ip access-list extended Internet_side1

permit tcp any eq www 20.20.20.0 0.0.0.255

ip access-list extended Internet_side2

permit tcp any eq www 30.30.30.0 0.0.0.255

!

route-map Cient_side_map1 permit 10

match ip address Client_side1

set ip next-hop 1.1.1.2

!

route-map Internet_side_map permit 10

match ip address Internet_side1

set ip next-hop 1.1.1.2

!

route-map Internet_side_map permit 20

match ip address Internet_side2

set ip next-hop 2.2.2.2

!

route-map Client_side_map2 permit 20

match ip address Client_side2

set ip next-hop 2.2.2.2

!

****PLEASE INFORM ME IF THERE IS ANY ERROR  PLEASE ASS SOON AS POSSIBLE *****

8 REPLIES
Hall of Fame Super Blue

Route-Map mistake

Rawa

It's difficult to tell without seeing a network diagram with IPs. Could you draw a quick diagram showing the router connections with IP addresses. Also the ports the user policy maps are applied to are not in the same subnet as the user vlans so can you include that in the diagram as well.

On other thing. Netpro is full of people who are really happy to help people with their problems but we all do it in our spare time for free. Saying it is crtical does not mean we will treat it any differently than any other question. If it really is critical then perhaps TAC may be a better choice as they are obligated to sort out your problem with a certain timeframe.

Jon

New Member

Route-Map mistake

Thanks Jon

please just let me to know the configuring of multiple Match in one route is like my configuraion ? or my configuration is false ?

Hall of Fame Super Blue

Re: Route-Map mistake

Rawa

Do you mean this -

route-map Internet_side_map permit 10

match ip address Internet_side1

set ip next-hop 1.1.1.2

!

route-map Internet_side_map permit 20

match ip address Internet_side2

set ip next-hop 2.2.2.2

!

the above will -

1) if the packet matches the first permit statement it will be sent to 1.1.1.2. If there is no match then -

2) if the packet matches the second permit it will be sent to 2.2.2.2. If there is no match then - 

3) the packet will be routed using the routing table.

That is how it will work. I don't know whether this will do what you want though without knowing how your network is setup.

Jon

New Member

Route-Map mistake

Thanks Mr JOn

please find the attached Dia in the orignal post , thats my net diagram , and inform me if there is any mistake

Hall of Fame Super Blue

Route-Map mistake

Rawa

Looking at your diagram i think the PBR will work as you want it to.

Jon

Hall of Fame Super Silver

Route-Map mistake

The main issue that I see is not in the route map but is this

interface gig 0/2

description " To - CacheServer 2 "

shutdown

HTH

Rick

Hall of Fame Super Blue

Route-Map mistake

Rick

That certainly wouldn't help

Jon

New Member

Route-Map mistake

Dear Jon

please is it need to write this string below in Interne_Side_Map

route-map Interne_Side_Map permit 30 
set default interface null0

???

222
Views
14
Helpful
8
Replies