Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Route map netx hop to tunnel

Hello,

I set up a route-map,

by cons it does not work, for info I have a default route to the ISP 2

ip route 0.0.0.0 0.0.0.0 172.24.1.1,

when I do a tracert I see it through the ISP2 link then I want it to ISP1 goes through the tunnel.

here is the config:

interface Vlan91

description Chicago

ip address 172.24.5.2 255.255.255.0

ip helper-address 172.20.0.251

ip policy route-map myMap

access-list 101 deny ip 172.24.5.0 0.0.0.255 10.0.0.0 0.255.255.255

access-list 101 deny ip 172.24.5.0 0.0.0.255 172.34.0.0 0.15.255.255

access-list 101 deny ip 192.168.0.0 0.0.0.255 172.24.5.0 0.0.255.255

access-list 101 permit tcp 172.24.5.0 0.0.0.255 any

route-map permit 10 myMap

  match ip address 101

  set ip next-hop 192.168.255.62

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Route map netx hop to tunnel

Where does the IP address of 192.168.255.62 sit in your network?

Can you show us the routing table on this router?

6 REPLIES

Route map netx hop to tunnel

Traceroute uses udp/icmp (depending on the implementation) and you are matching on tcp only. Try changing "access-list 101 permit tcp 172.24.5.0 0.0.0.255 any" to "permit ip" and test again...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Route map netx hop to tunnel

Hi John,

I just change it but still not

I guess the road map is not compatible with the next hop to the tunnel (knowing that I ping the other tunnel interface), you're agree with me?

James,

Bronze

Route map netx hop to tunnel

Where does the IP address of 192.168.255.62 sit in your network?

Can you show us the routing table on this router?

New Member

Re: Route map netx hop to tunnel

Communication is established between the tunnel:

there is no problem on the routing,but does not working !!!

this is a tracert from my host:

C:\Documents and Settings\XXXXX>tracert 192.168.255.62

Détermination de l'itinéraire vers 192.168.255.62 avec un maximum de 30 sauts.

   1    12 ms     1 ms     2 ms  172.24.5.2

  2    45 ms    41 ms    49 ms  192.168.255.62

Itinéraire déterminé.

C:\Documents and Settings\XXXXX>tracert 192.168.255.63

Détermination de l'itinéraire vers 192.168.255.62 avec un maximum de 30 sauts.

  1    24 ms     1 ms     1 ms  192.168.255.63

Itinéraire déterminé.

New Member

Route map netx hop to tunnel

                                     

********************************************************************************************************************

                      

                          I did something wrong, my concern is not solved yet.

********************************************************************************************************************

New Member

Route map netx hop to tunnel

********************************************************************************************************************

                      

                          I did something wrong, my concern is not solved yet.

********************************************************************************************************************

207
Views
0
Helpful
6
Replies
CreatePlease login to create content