Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Route-map (next hop to tunnel)

Hello,

I set up a route-map,

by cons it does not work, for info I have a default route to the ISP 2

ip route 0.0.0.0 0.0.0.0 172.24.1.1,

knowing that the ping is ok between tunnels,

when I do a tracert I see it through the ISP2 link then I want it to ISP1 goes through the tunnel.

here is the config:

interface Vlan91

description Chicago

ip address 172.24.5.2 255.255.255.0

ip helper-address 172.20.0.251

ip policy route-map myMap

access-list 101 deny ip 172.24.5.0 0.0.0.255 10.0.0.0 0.255.255.255

access-list 101 deny ip 172.24.5.0 0.0.0.255 172.34.0.0 0.15.255.255

access-list 101 deny ip 192.168.0.0 0.0.0.255 172.24.5.0 0.0.255.255

access-list 101 permit ip 172.24.5.0 0.0.0.255 any

route-map permit 10 myMap

  match ip address 101

  set ip next-hop 192.168.255.62

Thank you.

5 REPLIES
Purple

Route-map (next hop to tunnel)

Hi,

what does debug ip policy is telling ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Route-map (next hop to tunnel)

Hello,

I just did another test by changing the next hop to the nearest jump (G0/0) from my BBO, and I managed to redirect the flow to the router interface in front of me, so this confirms the route-map is not compatibe with tunneling?

Agree with me are you?

Please have a solution?

Best Regards,

James

New Member

Route-map (next hop to tunnel)

Hi Cadet,

there is no ip policy, i use a simple GRE tunnel,

interface Tunnel1

description vers XXXX

ip address 192.168.255.63 255.255.255.252

tunnel source "@ ip of BBO"

tunnel destination "@ ip of remote BBO 6500"

interface Tunnel1

description vers YYYYY

ip address 192.168.255.62 255.255.255.252

tunnel source "@ ip of remote BBO 6500"

tunnel destination "@ ip of BBO"

Purple

Route-map (next hop to tunnel)

Hi,

int vlan 1

ip policy route-map xxx  ----> there is ip policy

I suppose you want the traffic matched in the route-map to go inside the  GRE tunnel ?

when debug ip policy is turned on what is the output when you initiate traffic that matches your route-map ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re: Route-map (next hop to tunnel)

i can't launch a debug ip policy,it may be that overloading CPU of the BBO,

665
Views
0
Helpful
5
Replies
CreatePlease to create content