Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Route tag is not added - ASR1000

Hello,

I am working an ASR1000 router with the configuration below.

------------------------------------------------------------------------------------------

router ospf 1

redistribute connected metric-type 1 subnets route-map TO-OSPF

!

route-map TO-OSPF permit 10

match ip address 100

set tag 200

!

access-list 100 permit ip 10.1.0.0 0.0.0.255 any

access-list 100 permit ip 10.2.0.0 0.0.0.255 any

access-list 100 deny   ip any any

!

interface GigabitEthernet0/0/1

ip address 192.168.0.253 255.255.255.0

ip address 10.1.0.253 255.255.255.0 secondary

ip address 10.2.0.253 255.255.255.0 secondary

standby 1 ip 192.168.0.254

standby 1 ip 10.1.0.254 secondary

standby 1 ip 10.2.0.254 secondary

------------------------------------------------------------------------------------------

I appended a secondary and standby address, and updated the access-list 100.

But the route newly redistributed into OSPF didn't have the tag 200.

I recreated and reapplied the route-map and ACL, but the problem was not solved.

Is there any solution?

Thanks,

Jun

3 REPLIES
Cisco Employee

Route tag is not added - ASR1000

Hi Jun,

Can you attach the output for the following command:

sh ip ospf da external 10.1.0.0

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Route tag is not added - ASR1000

Hi Harold,

Thanks for your reply.

Attached is the output.

The command output for newly appended subnet, 10.3.0.0/24 was nothing.

Please note that I replaced production IP addresses with the private addresses.

Thanks,

Jun

Cisco Employee

Route tag is not added - ASR1000

I am not sure if I am right, but if you want the external routes to be tagged, like the 10.3.0.0/24 which you have mentioned, I believe you should have had that mentioned in the route-map.

route-map TO-OSPF permit 10

match ip address 100

set tag 200

!

access-list 100 permit ip 10.1.0.0 0.0.0.255 any

access-list 100 permit ip 10.2.0.0 0.0.0.255 any

access-list 100 deny   ip any any

From the above and the logs you have attached, I understand that anything which is permit in the route-map will get tagged whereas the one's which are denied will not get tagged.

A simple test can be made, where in you can do permit ip any any on the route-map and check if the tagging is happening to the routes you expect. If yes, then those routes should be in the permit list and the others in the deny.

Hope this makes sense.

196
Views
0
Helpful
3
Replies
CreatePlease to create content