Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Router 1841 will not do interVlan routing

I have a router 1841 and a swith Catalyst 3560, to set a router on a stick

I set up the vlans, 3 loopback interface with 3 networks, and truck ports in the swith, set up subinterface with fa 0/0 port in the router.  It seems the router will not route between vlans.  I can not ping the loopback addresss in the switch from the router, and I can not ping from the swith to the default gateway in the router.

PDid anybody encounter this kind of problems with router 1841

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Router 1841 will not do interVlan routing

Hello Grace,

Remove the Loopback1, Loopback2 and Loopback3 from your 3560. You have configured them with IP addresses that overlap the addressing on your router's subinterfaces. Because of this, you have tricked your 3560 into believing that the entire networks 172.16.10.0/24, 172.16.20.0/24, 172.16.30.0/24 are connected to the Loopback intefaces while in fact, they are not. Your 3560 must not believe these networks are located on Loopback interfaces because it will never send the packets to the router.

Also, the configuration of the DHCP server should be done only on those devices that actually have direct IP connectivity with the networks they serve. Currently, because your 3560 switch behaves as a Layer2 switch with a direct IP connectivity only to Vlan100, the configuration of the DHCP server is misplaced. Correctly, it should be configured on the router because it is connected to all VLANs in question. Later, as you proceed, you will learn about DHCP Relay Agent service that allows you to put a DHCP server into a different network than the clients are, but let's not complicate things right now.

Best regards,

Peter

3 REPLIES
New Member

Router 1841 will not do interVlan routing

Here is my config on Router 1841:

Current configuration : 1357 bytes

!

! Last configuration change at 14:22:11 UTC Wed Jul 24 2013

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RT-test2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

!

!

dot11 syslog

ip source-route

!

!

!

!

ip cef

!

multilink bundle-name authenticated

!

!

!

!

!

license udi pid CISCO1841 sn FTX1246Z0W4

!

redundancy

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 172.16.10.1 255.255.255.0

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 172.16.20.1 255.255.255.0

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 172.16.30.1 255.255.255.0

!

interface FastEthernet0/0.100

encapsulation dot1Q 100

ip address 172.16.100.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

!

interface Serial0/0/0

no ip address

shutdown

!

!

!

router eigrp 1

network 172.16.0.0

network 172.16.10.0 0.0.0.255

network 172.16.20.0 0.0.0.255

network 172.16.30.0 0.0.0.255

network 172.16.100.0 0.0.0.255

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

end

Here is the config on the swith:

Current configuration : 5163 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SW-Server

!

!

no aaa new-model

ip subnet-zero

ip routing

no ip domain-lookup

ip dhcp excluded-address 172.16.10.1

ip dhcp excluded-address 172.16.10.200 172.16.10.254

ip dhcp excluded-address 172.16.20.1

ip dhcp excluded-address 172.16.20.200 172.16.20.254

ip dhcp excluded-address 172.16.30.1

ip dhcp excluded-address 172.16.30.200 172.16.30.254

!

ip dhcp pool Dhcp-Vlan10

   network 172.16.10.0 255.255.255.0

   default-router 172.16.10.1

!

ip dhcp pool Dhcp-Vlan20

   network 172.16.20.0 255.255.255.0

   default-router 172.16.20.1

!

ip dhcp pool Dhcp-Vlan30

   network 172.16.30.0 255.255.255.0

   default-router 172.16.30.1

!

ip dhcp-server 172.16.10.200

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface Loopback1

ip address 172.16.10.201 255.255.255.0

!

interface Loopback2

ip address 172.16.20.201 255.255.255.0

!

interface Loopback3

ip address 172.16.30.201 255.255.255.0

!

interface FastEthernet0/1

switchport mode access

!

interface FastEthernet0/2

switchport mode access

!

interface FastEthernet0/3

switchport mode access

!

interface FastEthernet0/4

switchport mode access

!

interface FastEthernet0/5

switchport mode access

!

interface FastEthernet0/6

switchport mode access

!

interface FastEthernet0/7

switchport mode access

!

interface FastEthernet0/8

switchport mode access

!

interface FastEthernet0/9

switchport mode access

!

interface FastEthernet0/10

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/14

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/15

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/17

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/18

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/19

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/20

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/21

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/22

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/23

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/24

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/25

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/26

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/27

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/28

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/29

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/30

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/31

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/32

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/33

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/34

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/35

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/36

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/37

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/38

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/39

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/40

switchport mode access

!

interface FastEthernet0/41

switchport mode access

!

interface FastEthernet0/42

switchport mode access

!

interface FastEthernet0/43

switchport mode access

!

interface FastEthernet0/44

switchport mode access

!

interface FastEthernet0/45

switchport mode access

!

interface FastEthernet0/46

switchport mode access

!

interface FastEthernet0/47

description trunk to router

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/48

description trunk to SW-Client

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/1

switchport mode access

!

interface GigabitEthernet0/2

switchport mode access

!

interface GigabitEthernet0/3

switchport mode access

!

interface GigabitEthernet0/4

switchport mode access

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

no ip address

!

interface Vlan20

no ip address

!

interface Vlan30

no ip address

!

interface Vlan100

ip address 172.16.100.2 255.255.255.0

!

ip default-gateway 172.16.100.1

ip classless

ip http server

!

!

control-plane

!

!

line con 0

line vty 0 4

no login

line vty 5 15

no login

!

!

end

Thanks in advanced!

Cisco Employee

Router 1841 will not do interVlan routing

Hello Grace,

Remove the Loopback1, Loopback2 and Loopback3 from your 3560. You have configured them with IP addresses that overlap the addressing on your router's subinterfaces. Because of this, you have tricked your 3560 into believing that the entire networks 172.16.10.0/24, 172.16.20.0/24, 172.16.30.0/24 are connected to the Loopback intefaces while in fact, they are not. Your 3560 must not believe these networks are located on Loopback interfaces because it will never send the packets to the router.

Also, the configuration of the DHCP server should be done only on those devices that actually have direct IP connectivity with the networks they serve. Currently, because your 3560 switch behaves as a Layer2 switch with a direct IP connectivity only to Vlan100, the configuration of the DHCP server is misplaced. Correctly, it should be configured on the router because it is connected to all VLANs in question. Later, as you proceed, you will learn about DHCP Relay Agent service that allows you to put a DHCP server into a different network than the clients are, but let's not complicate things right now.

Best regards,

Peter

New Member

Router 1841 will not do interVlan routing

Hi! Peter:

Thank you for all the help.  I removed all the loopbacks, and add ip helper-address to each subinterface in the router.  Now I can ping and get IP for my hosts now.

Thanks again!

Grace

238
Views
0
Helpful
3
Replies