Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Router behind router configuration

Hello,

I am in need of assistance with my router configuration. This is a Cisco 1941 running iOS 15.

Goal: Configure router to route traffic through gi0/0. Configure gi0/1 to assign DHCP addresses to whatever connects to this interface and have those devices route traffic out gi0/0 interface.

Scenario: This router lies behind a home router that routes out to the internet where it will be receiving it's address from.

Details: gi0/0: 10.20.100.10 assigned from LAN. Would route to 10.20.100.1 out to internet.

              gi0/1: 10.10.10.10   Should assign dhcp addresses out through this interface.

 

Please help and thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Enable routing with:ip

Enable routing with:

ip routing

 

See if you can ping your DNS server or go to the web after doing this...

 

Thanks!

HTH, John *** Please rate all useful posts ***
11 REPLIES

Is your home router going to

Is your home router going to do natting for you, or is this more of a cable modem that doesn't have that type of intelligence? From your description, it sounds like you are going to be natting on the home router which would make this config really simple. Otherwise, the config is just the start of what you'll need:

 

int g0/0

ip address 10.20.100.10 255.255.255.0

no shut

 

int g0/1

ip address 10.10.10.10 255.255.255.0

no shut

 

ip dhcp pool Home

network 10.10.10.0 255.255.255.0

default-router 10.10.10.10

dns-server 8.8.4.4 8.8.8.8

 

ip route 0.0.0.0 0.0.0.0 10.20.100.1

 

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

John,Thanks for your reply.

John,

Thanks for your reply. The cable modem does not have NAT capability. 

Would gi0/0 be NAT outside and gi0/1 be NAT inside on the Cisco router?

*I would like the Cisco to provide a type of subnet within the home LAN.

I will configure router with the info you've provided so far.

So, if you're going to be

So, if you're going to be doing nat on your router, you'll probably be expecting to receive the public address directly on the Cisco router. If the cable modem doesn't nat at all, then you won't have a default gateway for the cisco to send to. Personally, what I would do is to try to configure the cisco with a dhcp address and then configure nat based on that. See if this will work:

 

int g0/0

ip address dhcp

ip nat outside

no shut

 

int g0/1

ip address 10.10.10.10 255.255.255.0

ip nat inside

no shut

 

ip dhcp pool Home

network 10.10.10.0 255.255.255.0

default-router 10.10.10.10

dns-server 8.8.4.4 8.8.8.8

 

ip nat inside source list 100 interface g0/0 overload

access-list 100 permit ip 10.10.10.0 0.0.0.255 any

 

 

HTH, John *** Please rate all useful posts ***
New Member

John,I've configured the

John,

I've configured the Cisco for dhcp as suggested above. I can ping external addresses from the router itself and it looks like it's working well.

Regarding int 0/1, I have my laptop plugged into it and it receives a dhcp address but no internet.

When you connect your laptop,

When you connect your laptop, are you getting a dhcp address? Are you using a crossover cable or a standard cable to connect? Is it connected directly to the laptop or through a switch? Can you post:

sh ip dhcp binding

sh ip int brie

 

Try to ping 8.8.8.8 from the laptop and then post:

sh ip nat trans

 

HTH, John *** Please rate all useful posts ***
New Member

Yes, when I connect my laptop

Yes, when I connect my laptop I receive an ip address of 10.10.10.1. I am using a standard Ethernet cable to connect and it is connected directly to gi0/1 on the router - not through a switch.

sh ip dhcp binding:

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

sh ip int brie:

Interface IP-Address OK? Method Status Protocol

Embedded-Service-Engine0/0 unassigned YES NVRAM administratively down down

GigabitEthernet0/0 10.20.100.2 YES DHCP up up

GigabitEthernet0/1 10.10.10.10 YES NVRAM up up

NVI0 unassigned YES unset administratively down down

 

When I run sh ip nat trans from the router, it does not return a result.

Please post the complete

Please post the complete config and we'll take a look at it further. The NVI shouldn't be down... (remove usernames and passwords please :)

HTH, John *** Please rate all useful posts ***
New Member

show running-configBuilding

show running-config

Building configuration...

Current configuration : 1618 bytes

!

! No configuration change since last restart

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Blue

!

boot-start-marker

boot-end-marker

!

!

! card type command needed for slot/vwic-slot 0/0

enable secret 5 $1$5TlN$lXcg0KMOpMIrfO2J250k01

enable password **********

!

no aaa new-model

!

no ipv6 cef

ip source-route

no ip routing

no ip cef

!

!

ip dhcp pool Blue

network 10.10.10.0 255.255.255.0

default-router 10.10.10.10

dns-server 107.150.40.234 107.170.95.180

!

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

license udi pid CISCO1941/K9 sn FGL1624212Y

!

!

interface Embedded-Service-Engine0/0

no ip address

no ip route-cache

shutdown

!

interface GigabitEthernet0/0

ip address dhcp

ip nat outside

ip virtual-reassembly in

no ip route-cache

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/1

ip address 10.10.10.10 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

duplex auto

speed auto

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list 100 interface GigabitEthernet0/0 overload

!

access-list 100 permit ip 10.10.10.0 0.0.0.255 any

!

!

snmp-server community public RO

!

control-plane

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password **********

login

transport input all

!

scheduler allocate 20000 1000

end

Enable routing with:ip

Enable routing with:

ip routing

 

See if you can ping your DNS server or go to the web after doing this...

 

Thanks!

HTH, John *** Please rate all useful posts ***
New Member

John, That did it !! Thanks

John,

 

That did it !! Thanks so much for your help!!

That's good to hear. :) Thank

That's good to hear. :) Thank you for letting me know!

HTH, John *** Please rate all useful posts ***
187
Views
0
Helpful
11
Replies