Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Router cannot ping outside network

The situation:

Router A (ip 192.168.16.1) is the default gateway for the entire company

Anybody in the company is able to go on the internet and ping 8.8.8.8 (google DNS) from there PC

I myself from my laptop have IP 192.168.16.170 and i can ping 8.8.8.8 my default gw is 192.168.16.1

I configured a lab with Router B a 1841 router with NAT

On Router B FastEth 0/0 is facing Router A

On Router B FastEth 0/1 is facing my lab

The problem:

From Router B, both interfaces can ping 192.168.16.1 (Router A, the default gateway)

From Router B i am unable to ping 8.8.8.8 or any other adress outside the 192.168.16.0 network

I dont undersand how i am able to ping my default gateway yet not be able to ping outside my network.

Keep in mind it works from my laptop or any other PC in the building.

Thank you for the insight

**********************************************************************************

Router#sh ip int br

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            192.168.16.137  YES DHCP up                    up

FastEthernet0/1            192.168.55.11   YES manual up                    up

NVI0                       unassigned      NO  unset  up                    up

Router#

***********************************************************************************

Router#sh run

Building configuration...

Current configuration : 712 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

!

!

!

!

!

--More--

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.55.11 255.255.255.0

ip nat inside

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

!

no ip http server

ip nat inside source static 192.168.55.170 192.168.16.10

ip nat inside source static 192.168.55.11 192.168.16.11

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

end

Router#

*************************************************************************

Router#sh ver

Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.4(17a), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Wed 07-Nov-07 11:21 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Router uptime is 4 hours, 34 minutes

System returned to ROM by power-on

System image file is "flash:c1841-ipbase-mz.124-17a.bin"

Cisco 1841 (revision 7.0) with 114688K/16384K bytes of memory.

Processor board ID FTX1153W03K

2 FastEthernet interfaces

DRAM configuration is 64 bits wide with parity disabled.

191K bytes of NVRAM.

31360K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2142

Router#

***********************************************************************

Router#ping 192.168.16.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.16.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

*******************************************************************

Router#ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions

Router cannot ping outside network

Try changing your default route from "0.0.0.0 0.0.0.0 fa0/0" to "0.0.0.0 0.0.0.0 192.168.16.1".

Can you ping 192.168.16.1 from RouterB?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
3 REPLIES
Purple

Router cannot ping outside network

  The default gateway is dirtectly attached so you should be able to ping it .  Does router A have a static pointing back to the subnets on router B ?

New Member

Router cannot ping outside network

**I should add that between Router A and B theres a switch**

I do not have access to see Router A routes but i dont think it should matter since its all layer 2 from Router A to the Switch then to Router B (same subnets - facing interfaces)

Router B is uses is interface Fa0-0 (192.168.16.137) to ping Router A (192.168.16.1) wich has an adress on the same subnet.

When i plug my PC into that same switch port with the same static IP (192.168.16.137) i can ping 8.8.8.8

When i plug the Router B in that same port with an interface conigure with the same IP (192.168.16.137), i cannot ping 8.8.8.8

Router cannot ping outside network

Try changing your default route from "0.0.0.0 0.0.0.0 fa0/0" to "0.0.0.0 0.0.0.0 192.168.16.1".

Can you ping 192.168.16.1 from RouterB?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
5989
Views
5
Helpful
3
Replies
CreatePlease login to create content