Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Router does not see Switch via sh CDP Neighbors

Router A ------------ Switch A -------------- Access Point 1 ------------ Access Point 2 -------------- Switch B ------------ Router B

Above is my topology design, two branches are connected through access points.Router A is able to ping Router B but they are not able to form neighbourship if I run any protocol and before that Router B even does not show switch B through CDP neigbour command.

Following is the configuration of Router B's interface connected to Switch B, access list on the router & nat commands.

interface FastEthernet0/1

ip address 78.93.41.217 255.255.255.248 secondary

ip address 192.168.17.10 255.255.255.0 secondary

ip address 192.168.1.10 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

access-list 10 permit 192.168.1.0 0.0.0.255

access-list 10 permit 192.168.17.0 0.0.0.255

ip nat inside source list 10 pool no-overload overload

ip nat inside source static tcp 192.168.1.240 22 78.93.41.220 22 extendable

ip nat inside source static tcp 192.168.1.240 1300 78.93.41.220 1300 extendable

ip nat inside source static 192.168.1.2 78.93.41.221

configuration of Router A's interface connected to Switch A

interface FastEthernet0/1

ip address 192.168.1.229 255.255.255.0

duplex auto

speed auto

Can anybody please get me out of this problem.Thanks

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Router does not see Switch via sh CDP Neighbors

I would not get too bogged down with CDP - you have said that the switches are managed so you can't definitely say that CDP is enabled on switch B. Bear in mind that when you form a routing protocol adjacency you may use either broadcast or multicast packets - so a ping may work but if you don't control the bit in the middle you can not be sure that all packets are passed. You could try creating a BGP relationship between the routers as this uses directed unicast. If that works then the issue is in the bit in the middle.

19 REPLIES
Silver

Router does not see Switch via sh CDP Neighbors

Can you confirm that you have CDP enabled on Switch B and Router B and that it is enabled on both interfaces?

What do you mean when you say "not able to form neighbourship" - are you talking about forming an adjacency with a routing protocol? If so which routing protocol and can we see the configuration of both routers please?

Community Member

Router does not see Switch via sh CDP Neighbors

CDP is by default enable on routers & switches.

It means when i check with "sh cdp neighbor" on router B, it does not show switch B as its neighbor however i can ping from router B to Router A.

After that if I run any protocol both routers are unable to form adjacancy.It seems to be problem between Router B & Switch B.

Silver

Router does not see Switch via sh CDP Neighbors

It would really help if you could provide your configurations.

Community Member

Router does not see Switch via sh CDP Neighbors

All your hardware is Cisco ? If the Access Point aren't Cisco CDP doesn't work, because CDP es a proprietary protocol. If this is the case Router_A can see Switch_A , and Router_B can see Switch_B but Switch_A can't see Switch_B.

You could check this : http://netcert.tripod.com/ccna/switches/cdp.html

Reggards.

Silver

Router does not see Switch via sh CDP Neighbors

I don't think he means that - he said that switch B can't see router B via CDP. I don't think he expects switch A to see switch B via CDP.

Community Member

Router does not see Switch via sh CDP Neighbors

Hi Julio,

My point is that why Router B does not see Switch B in sh cdp neighbor command on router which is directly connected to it.

Hi mfurnival,

Here is the configuration of Router B:(fa0/1 of router B is directly connected to Switch B)

FAYHA-SC#sh running-config

Building configuration...

Current configuration : 5690 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname FAYHA-SC

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret 5 ***********

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.40

ip dhcp excluded-address 192.168.1.230 192.168.1.254

ip dhcp excluded-address 192.168.1.229

ip dhcp excluded-address 192.168.1.224

!

ip dhcp pool 1

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.10

   dns-server 192.168.1.2 192.168.1.4

   lease 0 1

!

!

ip domain name yourdomain.com

ip name-server 84.22.224.11

ip name-server 84.22.224.12

multilink bundle-name authenticated

!

!

archive

log config

hidekeys

!

!

!

!

!

interface Tunnel1

description tunnel to fayhaa1@512

ip address 172.26.1.130 255.255.255.252

tunnel source 192.168.221.106

tunnel destination 192.168.141.171

!

interface Tunnel3

description tunnel to fayhaa@512

ip address 172.26.3.130 255.255.255.252

tunnel source 192.168.221.106

tunnel destination 213.184.183.173

!

interface Tunnel4

ip address 172.26.4.130 255.255.255.252

tunnel source 192.168.221.106

tunnel destination 192.168.166.18

!

interface Tunnel5

description tunnel to fayhaa5@512

ip address 172.26.5.130 255.255.255.252

tunnel source 192.168.221.106

tunnel destination 78.93.14.169

!

interface Tunnel17

ip address 172.26.17.130 255.255.255.252

tunnel source 192.168.221.106

tunnel destination 213.184.183.173

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 192.168.221.106 255.255.255.252

ip access-group 101 in

ip nat outside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 78.93.41.217 255.255.255.248 secondary

ip address 192.168.17.10 255.255.255.0 secondary

ip address 192.168.1.10 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.221.105

ip route 10.68.20.0 255.255.255.0 Tunnel1

ip route 192.168.2.0 255.255.255.0 Tunnel1

ip route 192.168.3.0 255.255.255.0 Tunnel3

ip route 192.168.4.0 255.255.255.0 Tunnel4

ip route 192.168.4.0 255.255.255.0 192.168.1.252

ip route 192.168.10.0 255.255.255.0 192.168.1.252

ip route 192.168.11.0 255.255.255.0 192.168.1.252

ip route 192.168.12.0 255.255.255.0 192.168.1.252

ip route 192.168.14.0 255.255.255.0 Tunnel5

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat pool no-overload 78.93.41.218 78.93.41.220 netmask 255.255.255.248

ip nat inside source list 10 pool no-overload overload

ip nat inside source static tcp 192.168.1.240 22 78.93.41.220 22 extendable

ip nat inside source static tcp 192.168.1.240 1300 78.93.41.220 1300 extendable

ip nat inside source static 192.168.1.2 78.93.41.221

!

access-list 10 permit 192.168.1.0 0.0.0.255

access-list 10 permit 192.168.17.0 0.0.0.255

access-list 23 permit 10.10.10.0 0.0.0.7

access-list 101 deny   ip host 180.92.187.122 any

access-list 101 deny   ip host 50.31.129.129 any

access-list 101 deny   ip host 69.72.255.8 any

access-list 101 deny   ip host 128.63.2.53 any

access-list 101 deny   ip host 46.249.48.209 any

access-list 101 deny   ip host 72.20.38.18 any

access-list 101 deny   ip host 91.234.36.30 any

access-list 101 permit ip any any

!

!

control-plane

!

!

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

password *******

login local

transport input telnet

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet

!

scheduler allocate 20000 1000

end

Community Member

Router does not see Switch via sh CDP Neighbors

I also tried OSPF on both sides but nothing was happening on both sides, no exhange of hellos even nothing was showing after i enabled debugging on both sides.I don't know what is the reason behind it.

Router does not see Switch via sh CDP Neighbors

is there any requirements of cdp neighbours to form adjuncy with routing protocol. Personally i dont think so.

Correct me if i am wrong.

Jawad

Router does not see Switch via sh CDP Neighbors

If you are able to ping bohat side routing protocal must go on

Router A ------------ Switch A -------------- Access Point 1  ------------ Access Point 2 -------------- Switch B ------------ Router B

If its ISP involved you will have to coordinate with your Service provider also to run routing protocol

Jawad

Jawad
Community Member

Router does not see Switch via sh CDP Neighbors

I agree CDP is not required; however l2 adjacency must be available, CDP is a good way of seeing that Layer 2 is working. as it'll show up even if someone has made a mistake and allocated the wrong ip address.

Can Switch B ping Router B? can switch B ping switch A? Can switch B ping router A?

Tony

Community Member

Router does not see Switch via sh CDP Neighbors

Tony,

If you see toplogy Router B is reaching to Router A via Switch B and both routers are pinging to each other.Do you really think there can be issue with switch B?

I would like to mention that these switches are not manageable.

Community Member

Re: Router does not see Switch via sh CDP Neighbors

What type of switches are Switch A and B?

Tony

      

Are you sure they have CDP?

Community Member

Router does not see Switch via sh CDP Neighbors

Jawad,

You did not get my point, I am trying to troublshoot this issue from the basics.As cdp is by default enabled on all devices and all devices are cisco devices then it should work in my scenerio......don't you agree????

I also mentioned that I also tried with OSPF but routers could not form adjacancy and they are not propagating anything even I enabled the debugging..........

Silver

Re: Router does not see Switch via sh CDP Neighbors

I would not get too bogged down with CDP - you have said that the switches are managed so you can't definitely say that CDP is enabled on switch B. Bear in mind that when you form a routing protocol adjacency you may use either broadcast or multicast packets - so a ping may work but if you don't control the bit in the middle you can not be sure that all packets are passed. You could try creating a BGP relationship between the routers as this uses directed unicast. If that works then the issue is in the bit in the middle.

Community Member

Router does not see Switch via sh CDP Neighbors

Switches on both sides are ESW 520 and cdp is enable by default on this switch and the access points model is RDL-2000.

Community Member

Re:Router does not see Switch via sh CDP Neighbors

Silver

Router does not see Switch via sh CDP Neighbors

I take it that he meant that he does not have management access to the switches rather than they *can't* be managed. Did you try what I suggested regarding BGP Shahzad?

Community Member

Router does not see Switch via sh CDP Neighbors

not yet, i will try in the evening and update you.thanks

Community Member

Re: Router does not see Switch via sh CDP Neighbors

thanks mfunival

routers are exchanging routes via bgp.

rgds

shahzad

10675
Views
3
Helpful
19
Replies
CreatePlease to create content