Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Router not booting up to configured IOS and Bootldr

Hi

I've got a new 7206vxr-NPE-G2 router that for some reason I can't boot into a new IOS image, it keeps booting up with the IOS that came with the router. I've got another 7206VXR-NPE-G2 that is also new and that is working fine. I've got to deply this router in less than an hours time, can someone please help me to figure this out before I deploy?

show version:

Cisco IOS Software, 7200 Software (C7200P-IPBASE-M), Version 12.4(4)XD8, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 13-Aug-07 20:08 by hqluong

ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)
BOOTLDR: Cisco IOS Software, 7200 Software (C7200P-KBOOT-M), Version 12.4(4)XD8, RELEASE SOFTWARE (fc3)

router uptime is 1 minute
System returned to ROM by reload at 04:07:27 UTC Thu Aug 3 2000
System image file is "disk2:c7200p-ipbase-mz.124-4.XD8.bin"
Last reload reason: Reload Command

254464K bytes of ATA PCMCIA card at slot 2 (Sector size 512 bytes).
65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102

show bootvar:

BOOT variable = c7200p-adventerprisek9-mz.124-24.T2.bin,1;
CONFIG_FILE variable does not exist
BOOTLDR variable = bootflash:c7200p-kboot-mz.124-4.XD8.bin
WARM_REBOOT variable = FALSE
Configuration register is 0x2102

dir
Directory of disk2:/

    1  -rw-    20538028  Aug 29 2008 09:51:24 +00:00  c7200p-ipbase-mz.124-4.XD8.bin
    2  -rw-    39788188  Jul 27 2000 07:39:28 +00:00  c7200p-adventerprisek9-mz.124-24.T2.bin

260124672 bytes total (199794688 bytes free)

dir bootflash:
Directory of bootflash:/

    1  -rw-     7948348  Jun 16 2000 07:40:07 +00:00  c7200p-kboot-mz.124-4.XD8.bin
    2  -rw-     8798228  Jul 27 2000 07:41:12 +00:00  c7200p-kboot-mz.124-24.T2.bin

65536000 bytes total (48789168 bytes free)

Any thoughts?

Thanks

Dan

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Router not booting up to configured IOS and Bootldr

dan_track wrote:

Hi


dir
Directory of disk2:/

    1  -rw-    20538028  Aug 29 2008 09:51:24 +00:00  c7200p-ipbase-mz.124-4.XD8.bin
    2  -rw-    39788188  Jul 27 2000 07:39:28 +00:00  c7200p-adventerprisek9-mz.124-24.T2.bin

260124672 bytes total (199794688 bytes free)

dir bootflash:
Directory of bootflash:/

    1  -rw-     7948348  Jun 16 2000 07:40:07 +00:00  c7200p-kboot-mz.124-4.XD8.bin
    2  -rw-     8798228  Jul 27 2000 07:41:12 +00:00  c7200p-kboot-mz.124-24.T2.bin

65536000 bytes total (48789168 bytes free)

Any thoughts?

Thanks

Dan

Dan

What do you see when you boot it up on the console ?

If it can't find the new image try adding this to your config -

7200(config)# boot system flash disk2:/

if you already have a boot system flash statement for another image you need to delete that one, add in the one above, and then put back the existing one.

Jon

9 REPLIES
Hall of Fame Super Blue

Re: Router not booting up to configured IOS and Bootldr

dan_track wrote:

Hi


dir
Directory of disk2:/

    1  -rw-    20538028  Aug 29 2008 09:51:24 +00:00  c7200p-ipbase-mz.124-4.XD8.bin
    2  -rw-    39788188  Jul 27 2000 07:39:28 +00:00  c7200p-adventerprisek9-mz.124-24.T2.bin

260124672 bytes total (199794688 bytes free)

dir bootflash:
Directory of bootflash:/

    1  -rw-     7948348  Jun 16 2000 07:40:07 +00:00  c7200p-kboot-mz.124-4.XD8.bin
    2  -rw-     8798228  Jul 27 2000 07:41:12 +00:00  c7200p-kboot-mz.124-24.T2.bin

65536000 bytes total (48789168 bytes free)

Any thoughts?

Thanks

Dan

Dan

What do you see when you boot it up on the console ?

If it can't find the new image try adding this to your config -

7200(config)# boot system flash disk2:/

if you already have a boot system flash statement for another image you need to delete that one, add in the one above, and then put back the existing one.

Jon

New Member

Re: Router not booting up to configured IOS and Bootldr

Hi JOn,

Thanks for the reply,

Here's what I get after a reload:

reload
Proceed with reload? [confirm]

System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2006 by cisco Systems, Inc.
Socket jumper: not present Failsafe jumper: present = normal
FPGA revision 0x00000026
C7200 platform with 1046528 Kbytes of main memory


Readonly ROMMON initialized

Self decompressing the image : ################################################################################################################################# [OK]

%SYS-6-READ_BOOTFILE_FAIL: tftp://255.255.255.255/flash:c7200p-adventerprisek9-mz.124-24.T2.bin File read failed -- Timed out.

%Error opening tftp://255.255.255.255/flash:c7200p-adventerprisek9-mz.124-24.T2.bin (Timed out)
%SYS-6-BOOT_MESSAGES: Messages above this line are from the boot loader.

Self decompressing the image : ################################################################################################################################################################################################################################################################################################################################################################### [OK]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706

Cisco IOS Software, 7200 Software (C7200P-IPBASE-M), Version 12.4(4)XD8, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 13-Aug-07 20:08 by hqluong
Image text-base: 0x0000A3B8, data-base: 0x0235E000

Cisco 7206VXR (NPE-G2) processor (revision A) with 917504K/65536K bytes of memory.
Processor board ID 20394524
MPC7448 CPU at 1666Mhz, Implementation 0, Rev 2.2
6 slot VXR midplane, Version 2.0

Last reset from power-on

PCI bus mb1 (Slots 1, 3 and 5) has a capacity of 600 bandwidth points.
Current configuration on bus mb1 has a total of 0 bandwidth points.
This configuration is within the PCI bus capacity and is supported.

PCI bus mb2 (Slots 2, 4 and 6) has a capacity of 600 bandwidth points.
Current configuration on bus mb2 has a total of 0 bandwidth points.
This configuration is within the PCI bus capacity and is supported.

Please refer to the following document "Cisco 7200 Series Port Adaptor
Hardware Configuration Guidelines" on Cisco.com <http://www.cisco.com>
for c7200 bandwidth points oversubscription and usage guidelines.


1 FastEthernet interface
3 Gigabit Ethernet interfaces
2045K bytes of NVRAM.

254464K bytes of ATA PCMCIA card at slot 2 (Sector size 512 bytes).
65536K bytes of Flash internal SIMM (Sector size 512K).


Press RETURN to get started!

C

Thanks

Dan

Hall of Fame Super Blue

Re: Router not booting up to configured IOS and Bootldr

Dan

What does your "sh run" look like.

Can you add that boot system command and then try again

Jon

New Member

Re: Router not booting up to configured IOS and Bootldr

Here's the set of commands I ran prior to reloading, i.e. the same reload I pasted in my previous post:

ext02(config)#boot
ext02(config)#boot sys
ext02(config)#boot system fl
ext02(config)#boot system flash ?
  WORD  System image filename
 

ext02(config)#boot ?
  bootldr    Boot loader (RxBoot) image name
  bootstrap  Bootstrap image file
  config     Configuration file
  host       Router-specific config file
  network    Network-wide config file
  system     System image file

ext02(config)#boot boot
ext02(config)#boot boots
ext02(config)#boot bootstrap ?
  WORD  TFTP filename or URL
  mop   Boot from a Decnet MOP server
  tftp  Boot from a tftp server

ldc-rt-ext02(config)#boot bootl
ldc-rt-ext02(config)#boot bootldr
% Incomplete command.

ext02(config)#boot bootldr ?
  bootflash:  URL of the Boot helper image
  disk2:      URL of the Boot helper image

ext02(config)#boot bootldr boo
ext02(config)#boot bootldr bootflash:?
bootflash:c7200p-kboot-mz.124-24.T2.bin
bootflash:c7200p-kboot-mz.124-4.XD8.bin

ext02(config)#boot bootldr bootflash:c7200p-kboot-mz.124-4.XD8.bin ?
 

ext02(config)#boot bootldr bootflash:c7200p-kboot-mz.124-4.XD8.bin
ext02(config)#boot di
ext02(config)#boot dis
ext02(config)#boot ?
  bootldr    Boot loader (RxBoot) image name
  bootstrap  Bootstrap image file
  config     Configuration file
  host       Router-specific config file
  network    Network-wide config file
  system     System image file

ext02(config)#boot sy
ext02(config)#boot system ?
  WORD   TFTP filename or URL
  flash  Boot from flash memory
  ftp    Boot from a server via ftp
  mop    Boot from a Decnet MOP server
  rcp    Boot from a server via rcp
  tftp   Boot from a tftp server

ext02(config)#boot system fl
ext02(config)#boot system flash ?
  WORD  System image filename
 

ext02(config)#$ flash c7200p-adventerprisek9-mz.124-24.T2.bin
ext02(config)#^Z

show run:

ext02#sh run
Building configuration...

Current configuration : 2611 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ext02
!
boot-start-marker
boot system flash c7200p-adventerprisek9-mz.124-24.T2.bin
boot bootldr bootflash:c7200p-kboot-mz.124-4.XD8.bin
boot-end-marker
!
logging buffered 64000 debugging
no logging rate-limit
no logging console
enable secret 5 xxxx.
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication login console line
aaa authorization exec default group tacacs+ none
aaa authorization exec console none
!
aaa session-id common
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username freddy privilege 15 password 7 xxxxxx
archive
log config
  hidekeys
!
!
!
!
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface FastEthernet0/2
ip address dhcp
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 84.x.x.x 255.255.255.0
ip nat outside
duplex auto
speed auto
media-type sfp
negotiation auto
!
interface GigabitEthernet0/3
ip address 81.x.x.x 255.255.255.0
ip nat inside
duplex auto
speed auto
media-type rj45
negotiation auto
standby 100 ip 81.x.x.x
!
ip classless
ip route 0.0.0.0 0.0.0.0 84.x.x.x
no ip http server
!
!

Dan

Hall of Fame Super Blue

Re: Router not booting up to configured IOS and Bootldr

Dan

Can you change this in your config -

boot system flash c7200p-adventerprisek9-mz.124-24.T2.bin

to

boot system flash disk2:/c7200p-adventerprisek9-mz.124-24.T2.bin

Jon

New Member

Re: Router not booting up to configured IOS and Bootldr

Hi Jon,

You're a star . The worked for the IOS, how do I get the boot lloader to work?

If the disk2 option was required, why then did the flash option get accepted when I entered the command and what is flash?

Additionally when the router is booting up why does it do the following i.e do a tftp?


Self decompressing the image : ################################################################################################################################# [OK]

%SYS-6-READ_BOOTFILE_FAIL: tftp://255.255.255.255/flash:c7200p-adventerprisek9-mz.124-24.T2.bin File read failed -- Timed out.

%Error opening tftp://255.255.255.255/flash:c7200p-adventerprisek9-mz.124-24.T2.bin (Timed out)
%SYS-6-BOOT_MESSAGES: Messages above this line are from the boot loader.

Thanks

Dan

Hall of Fame Super Blue

Re: Router not booting up to configured IOS and Bootldr

dan_track wrote:

Hi Jon,

You're a star . The worked for the IOS, how do I get the boot lloader to work?

If the disk2 option was required, why then did the flash option get accepted when I entered the command and what is flash?

Additionally when the router is booting up why does it do the following i.e do a tftp?


Self decompressing the image : ################################################################################################################################# [OK]

%SYS-6-READ_BOOTFILE_FAIL: tftp://255.255.255.255/flash:c7200p-adventerprisek9-mz.124-24.T2.bin File read failed -- Timed out.

%Error opening tftp://255.255.255.255/flash:c7200p-adventerprisek9-mz.124-24.T2.bin (Timed out)
%SYS-6-BOOT_MESSAGES: Messages above this line are from the boot loader.

Thanks

Dan

Dan

Your bootldr is specified for DX8 ie. from your running-config

boot bootldr bootflash:c7200p-kboot-mz.124-4.XD8.bin

if you want it changed then change it there.

"boot system flash" is the first part of the command. It should then be following by the image name with a full location, in your case disk2:/.

Because both your IOS images were on disk2 and this was not specified to boot from then the router tried to get an IOS using tftp.

Hope this has got you sorted so you can deploy as i have to go out this afternoon

Jon

New Member

Re: Router not booting up to configured IOS and Bootldr

Hi Jon,

If you're in London, UK then go out and enjoy the sun while it lasts. I owe you a drink as you've helped me get past this issue and I can now deploy the router.

Many thanks.

Dan

Hall of Fame Super Blue

Re: Router not booting up to configured IOS and Bootldr

dan_track wrote:

Hi Jon,

If you're in London, UK then go out and enjoy the sun while it lasts. I owe you a drink as you've helped me get past this issue and I can now deploy the router.

Many thanks.

Dan

Dan

I'm in Bristol, UK but it's still sunny. You have to make the most of it over here as you never know how long it's going to last

Glad you got it working.

Jon

2454
Views
5
Helpful
9
Replies
CreatePlease to create content