Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

router not saving configuration

I have a 1711 Catalyst router hooked up behind a cable modem.  I configured the router, copied running-config to startup-config then wrote it to memory with "write mem".  I unplugged router to move it and when I plugged it back in, I had to start from scratch.

Is this normal, or should router be able to save configuration if powered down?

BTW, I'm using Putty to access router console.  Is that the hot setup for Windows 7 or is there something better?

Thanks!

-Bruce

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: router not saving configuration

What is your conifguration register set to?

http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a008022493f.shtml

I believe you want this:

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#config

Router(config)#config-register 0x2102

Router(config)#end

Been alittle while since I read up on that.  Let us know how it works. The article is helpful also.

Message was edited by: Jimmy Sands

Purple

Re: router not saving configuration

  More than likely it is the config register.  Your config did not dissappear  it was still there but the config register was set to load a blank default config, someone may have done a password recovery or something previously , like the previous poster said change it to 0x2102  and make sure you have the correct boot statement.

5 REPLIES

Re: router not saving configuration

What is your conifguration register set to?

http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a008022493f.shtml

I believe you want this:

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#config

Router(config)#config-register 0x2102

Router(config)#end

Been alittle while since I read up on that.  Let us know how it works. The article is helpful also.

Message was edited by: Jimmy Sands

Purple

Re: router not saving configuration

  More than likely it is the config register.  Your config did not dissappear  it was still there but the config register was set to load a blank default config, someone may have done a password recovery or something previously , like the previous poster said change it to 0x2102  and make sure you have the correct boot statement.

New Member

router not saving configuration

Glenn;

What is "correct boot statement"?

New Member

router not saving configuration

Jimmy;

That was what the problem was.  Once I configure the memory, it now saves it if it loses power.

Thanks for your help.

-Bruce

router not saving configuration

Glad to help, thanks for the update and glad you got it working.

546
Views
0
Helpful
5
Replies
CreatePlease to create content