Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Router on a stick config cant ping

I'm trying to build a router on a stick and cant figure out why nothing is pingable. I cant even ping from the switch to the client.

Clients have their respective ip's 10.1.10.2 and 10.1.20.2 and correct default gateways configured and the port from the switch to the router is trunked. On the switch vlans 10 and 20 are created and up. Everything on the router looks ok. Can anyone help on what the problem is? I cant ping from any device ot any other device. Thanks.

SWITCH

sw.JPG

ROUTER

        router.JPG

router1.JPG

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Router on a stick config cant ping

Hello

Switch

The switch interface connecting to you router - this needs to be a trunk interface - would that be fa0/3  in your post and is it running dot1q  encapsulation?

Also make sure the switch its running as a host siwtch ( ip default-gateway x.x.x.x ) and doesnt have ip routing enabled.

Router-

int fa0/1.2

encapsulation dot1q 20

ip address 10.1.20.1 255.255.255.0

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
2 REPLIES

Re: Router on a stick config cant ping

Hello

Switch

The switch interface connecting to you router - this needs to be a trunk interface - would that be fa0/3  in your post and is it running dot1q  encapsulation?

Also make sure the switch its running as a host siwtch ( ip default-gateway x.x.x.x ) and doesnt have ip routing enabled.

Router-

int fa0/1.2

encapsulation dot1q 20

ip address 10.1.20.1 255.255.255.0

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.

Router on a stick config cant ping

Yes, it was the Router, I didnt know that the number after the encapsulation dot1q 20 - had to be the vlan id number!

Thanks.

302
Views
0
Helpful
2
Replies
CreatePlease login to create content