Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Router reboot

Hello,

We have one cisco 7206 router, facing a problem with the same. Routing is getting rebooted frequently.

We are on console & getting this error on the screen from router:-

% SYS-6-REAB_BOOTFILE_fail : disk0:c7200-p-mz-122-14.S3.bin file boot failed -- file not accessible

Nov 10 09:19:15 % SYS-3-LOGGER_FLUSHING : system paushing to ensure console debugging output

Queued message : free space check for bootflash : crashinfo - 20091110-09205 Failed (1/3768)

Trackback = 0 0

Please suggest about the issue

14 REPLIES
Hall of Fame Super Silver

Re: Router reboot

Hello Jimmy,

the router appears not able to load the IOS image in disk0.

if you have someone near it :

check if flash in disk0: is still there or has been removed or just partially extracted.

if you were to upgrading it to that IOS image you need to verify that the image is correct for your hardware:

IOS images good for NPE-G1 and NPE-G2 are not good for older NPE-400 and other.

images for NPE-G1/2 are named like:

c7200p-advsecurityk9-mz.124-15.T6.bin

the difference is in that p following c7200.

if the image is appropriate for your HW and the flash has not been removed I would consider the possibility the flash has been corrupted.

I would consider to remove the flash to have the router to stabilize in rommon.

Hope to help

Giuseppe

New Member

Re: Router reboot

Hii Giuseppe,

We have remove the flash card from router, post which getting "Router(boot)#" prompt.

This router is NPE300, e are now thinking to format flash card and install the flash of NPE-G1 7206 router(another router with us) into faulty router.

Or do we have some other solution, Please suggest.

New Member

Re: Router reboot

Hi,

We have formatted the Flash memory/card with Version 12.2(25)S6 IoS. after which router rebooting intensity is bit less, But still the same is keeping reboots.

Please suggest...

New Member

Re: Router reboot

Its very clearly related to the flash.

The file either doesnt exist on the flash, the flash is not accessible (maybe bad), or you have a type in your config.

My suggestions:

Do a dir flash: and see what files you have in your flash. Then make sure your boot statement matches EXACTLY what the file on flash says it is.

Otherwise issue the no boot system command and the system should automatically scroll through the flash and boot the first usable image.

Thirdly, if none of that work, I would suspect a bad flash and for you to replace it.

Good luck.

James

New Member

Re: Router reboot

Thxns James,

Plz clear second point "Do a dir flash: and see what files you have in your flash. Then make sure your boot statement matches EXACTLY what the file on flash says it is".

New Member

Re: Router reboot

Actually, since your image is on disk0: then from enable mode do a dir disk0: and see what the output is.

For example, for me it looks like this:

c6513-CoreA#dir disk0:

Directory of disk0:/

1 -rw- 103415140 Oct 22 2009 10:29:24 -08:00 s72033-adventerprisek9_wan-mz.122-33.SXI2.bin

2 -rw- 100940548 Oct 27 2009 09:24:56 -08:00 s72033-adventerprise_wan-mz.122-33.SXI2a.bin

511705088 bytes total (307347456 bytes free)

Then in my config, I have the following statements:

boot system disk0:s72033-adventerprise_wan-mz.122-33.SXI2a.bin

boot system sup-bootdisk:s72033-adventerprisek9_wan-mz.122-33.SXI2a.bin

For me I am looking at disk0: first and if for some reason that is unavailable I have the same file on my sup-bootdisk which will be looked at next due to my boot statement order of preference.

If you mis-typed your boot statement and it does not match exactly the file name on disk0: then you might get the error you are seeing.

Best way to ensure proper name is to do the dir disk0: then copy the name of the file you want to boot. Then go to config and say boot system disk0: then paste the filename.bin

Hope that helps.

James

New Member

Re: Router reboot

Hii James,

Thxns again 4 quick response, But for your info again as updated in my previous post recently we have upgraded the IOS. but still router keeps on rebooting.

We have a bit doubt on the new Image also. Could you pls post me a process for upgrading IOS as this router as we wanna match the process (whether we have done all fine or skipped any step).

NOte:- 20Mb Flash memory card is installed on the router. Hence we first need to format the Flash due to lack of memory.

New Member

Re: Router reboot

For me a router upgrade goes like this:

1) get in enable mode

2) Download the new code to whatever boot disk you want (in your case disk0:)

3) Change your boot statement in your running config to point to the new file on disk0:

4) Copy run start

4) reload the router

When it comes back up do a show version to make sure it is on the correct code.

Thats it.

Oh, and the flash doesn't need to IOS that is currently running and the IOS that you WANT to run at the same time. You can blow away the old IOS and add the new one. You dont have to format, just delete the old file instead. There is some risk in this in that if the new file somehow gets corrupted then you wont easily be able to go back to the old IOS.

One more thing, make sure your config reg is set to 0x2102.

James

New Member

Re: Router reboot

Hii James/Netpros,

I have again upgraded router with new(other) IOS image, devices still keeps rebooting. seems some different issue. please suggest some more posssibilites.

regards

New Member

Re: Router reboot

If you upgraded to a new code an it is still rebooting and giving you the same error then you may very well have an issue with your actual flash. You may need to replace it.

Open a case with TAC and they can help you from there.

James

New Member

Re: Router reboot

Hii James,

We have another router now in our network having the same problem(rebooting).

is this possible that there may b e virus /ddos attacks on thies router. if yes . then how to varify the same and solution...

Gold

Re: Router reboot

now I am not to familiar with the 7200 but it seems to me that you have two problems.

1) The router reloads

2) the router cannot access a binary file in flash

The two errors are actually only loosly connected in such a way that if you did not have error 1 then error 2 would still exist but it would not pop up as frequent as it does since fault 1 does exist.

so lets start with the "easy" one.

Nr 2 should be easy to check.

I would guess that the command would be "fsck flash:" to start a test of the flash.

Look it up in the command reference for the ios version you are using on the router. or just do a "fsck ?" if that works just fine then most likely its the wrong IOS that can not load so check that you have downloaded the right file is the next thing to check. download it again and replace the existing one.

ok back to problem nr 1 wich is the hard part.

start with "show version"

if you didnt powercycle it or reloaded it

it will tell you somethings like router uptime and system restarted by error - software forced crach and something.

if that is the "problem" and it is not obvious why I would open a tac case about it.

if it is not the "problem" I would start with looking in the logs and setting up a syslog server and start logging.

if you have the possibillity then use snmp to help you find out why.

also I would look for scheduled reloads in the config.

HTH

New Member

Re: Router reboot

Hii,

Please find the error showing in "Sh version" :-

system returned to ROM by bus error at PC 0x614C7A40 , address 0xE19B5C8

command fsck is not supporting.

New Member

Re: Router reboot

hello,

We have another cisco router also 3600 series. the same was also auto-rebooted once.

ON "Sh ver" output the below information is reflecting.

System returned to ROM by error - a Software forced crash, PC 0x60430B94

please suggest.

930
Views
0
Helpful
14
Replies
CreatePlease login to create content