Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing between 2 vlans on same device

Feeling a bit out of sorts this morning.....

I have a 3560E with 2 vlans that I want to route between.  one device with 2 vlans and route between.

Interfaces are configured as such:

int g0/11

switchport mode access

switchport access vlan 10

int g0/12

switchport mode access

switchport access vlan 11

int vlan 10

ip address 10.10.10.1

int vlan 11

ip address 10.10.11.1

Laptops on each port with 10.10.10.2 and 10.10.11.2 configured on them.  I can ping from 10.10.10.2 to 10.10.11.1, but not to 10.10.11.2.

What do I have to configure to be able to get the 2 laptops to talk to each other?

Thank you in advance.....

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Routing between 2 vlans on same device

Little typos in your questions. If i consider based on your subject line, i feel you have two VLANs on the same device. For interVLAN routing to happen you need to enable it via ip routing command, which i assume you have done it as you are able to ping from 10.10.10.2 to 10.10.11.1. Another IP which you are not able to ping is 10.10.11.2?

What i feel is, this has to do something with that PC (surely running windows ). Disable the windows firewall service & give it a try.

THanks

Vivek

9 REPLIES

Routing between 2 vlans on same device

Try using a routing protocol:

router eigrp 100

Network 10.10.10.0

network 10.10.11.0

no auto-summary

Routing between 2 vlans on same device

Little typos in your questions. If i consider based on your subject line, i feel you have two VLANs on the same device. For interVLAN routing to happen you need to enable it via ip routing command, which i assume you have done it as you are able to ping from 10.10.10.2 to 10.10.11.1. Another IP which you are not able to ping is 10.10.11.2?

What i feel is, this has to do something with that PC (surely running windows ). Disable the windows firewall service & give it a try.

THanks

Vivek

New Member

Routing between 2 vlans on same device

I know it is not the laptops as I have been using them in the same lab and able to ping between them, just on a different segments and situations.....

I do have the IP route command in the config, just forgot to put it in there....

I will try using a routing protocol, but wish I didn't have to, as I need to keep this as simple as possible....

Routing between 2 vlans on same device

Hello Tracey,

Could you please explain me your setup with a topology possibly?

Thanks

Vivek

New Member

Routing between 2 vlans on same device

Sure.

I have one 3560E.  Port g0/11 has a laptop configured with 10.10.10.2 IP, def gateway 10.10.10.1.  Port g0/12 has a laptop configured with 10.10.11.2 IP, def gateway 10.10.11.1.  I want the 2 laptops to talk to each other on the different segments.

Rest of the configuration is above....

New Member

Routing between 2 vlans on same device

Thanks Vivek!

I know I had put in the IP routing command!  However, I went back and checked again and it was not in there!  I put it in and am able to ping between the laptops!  Thanks for all the inputs! 

New Member

Routing between 2 vlans on same device

Hello,

I have the same issue. I tried to IP ROUTING but I could not see. See my config below.

Any suggestion.

Thanks,

no spanning-tree

vlan database

vlan 2

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

interface vlan 2

ip address 10.10.9.1 255.255.255.0

exit

interface vlan 1

ip address 10.10.13.11 255.255.255.0

exit

ip route 0.0.0.0 0.0.0.0 10.10.13.1 

interface  gi11

ip dhcp relay enable

exit

interface vlan 1

no ip address dhcp

exit

hostname switchd2fac1

interface gigabitethernet11

switchport mode access

switchport access vlan 2

exit

Bronze

Routing between 2 vlans on same device

Which device is 10.10.13.1?

ip route 0.0.0.0 0.0.0.0 10.10.13.1

New Member

Routing between 2 vlans on same device

It is the gateway.

1659
Views
0
Helpful
9
Replies
CreatePlease login to create content