Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing from a specific IP address

I am not sure if this is possible with the gear I have or possible at all.  Here is what I am trying to accomplish...

I would like all traffic from a specific IP address (192.168.80.55) to a specific subnet (192.168.90.x) to go out Fa0/1.  I currently have all of the traffic on the 192.168.90.x network going across that interface from the other side.  Any help is greatly appreciated.

Router 1 -  Cisco IOS Software, 2800 Software (C2800NM-ENTBASEK9-M), Version 12.4(24)T3

interface FastEthernet0/0

ip address 192.168.80.254 255.255.255.0

duplex full

speed 100

!

interface FastEthernet0/1

ip address 172.16.0.14 255.255.255.248

duplex auto

speed auto

service-policy output phone-trunk-wireless

!

interface FastEthernet0/1/0

ip address 172.16.0.1 255.255.255.252

duplex full

speed 100

service-policy output phone-trunk

track 100 ip sla 1 reachability

delay down 8 up 30

!

track 120 ip sla 2 reachability

delay down 15 up 1

ip route 0.0.0.0 0.0.0.0 192.168.80.253 track 100

ip route 0.0.0.0 0.0.0.0 192.168.80.252 100 track 120

ip route 192.168.81.0 255.255.255.0 192.168.80.1

ip route 192.168.82.0 255.255.255.0 192.168.80.1

ip route 192.168.83.0 255.255.255.0 192.168.80.1

ip route 192.168.84.0 255.255.255.0 192.168.80.253

ip route 192.168.85.0 255.255.255.0 192.168.80.252

ip route 192.168.90.0 255.255.255.0 172.16.0.2

ip route 192.168.90.0 255.255.255.0 172.16.0.9 200

ip route 192.168.91.0 255.255.255.0 172.16.0.2

ip route 192.168.91.0 255.255.255.0 172.16.0.9 200

ip route 192.168.92.0 255.255.255.0 172.16.0.2

ip route 192.168.92.0 255.255.255.0 172.16.0.9 200

ip route 192.168.93.0 255.255.255.0 172.16.0.2

ip route 192.168.93.0 255.255.255.0 172.16.0.9 200

sh ip route

Gateway of last resort is 192.168.80.253 to network 0.0.0.0

S    192.168.91.0/24 [1/0] via 172.16.0.2

S    192.168.90.0/24 [1/0] via 172.16.0.2

S    192.168.93.0/24 [1/0] via 172.16.0.2

S    192.168.92.0/24 [1/0] via 172.16.0.2

C    172.16.0.8/29 is directly connected, FastEthernet0/1

C    172.16.0.0/30 is directly connected, FastEthernet0/1/0

S    192.168.81.0/24 [1/0] via 192.168.80.1

C    192.168.80.0/24 is directly connected, FastEthernet0/0

S    192.168.83.0/24 [1/0] via 192.168.80.1

S    192.168.82.0/24 [1/0] via 192.168.80.1

S    192.168.85.0/24 [1/0] via 192.168.80.252

S    192.168.84.0/24 [1/0] via 192.168.80.253

S*   0.0.0.0/0 [1/0] via 192.168.80.253

Router 2 - Cisco IOS Software, 2800 Software (C2800NM-ENTBASEK9-M), Version 12.4(24)T3

interface FastEthernet0/0

ip address 192.168.90.254 255.255.255.0

duplex full

speed 100

!

interface FastEthernet0/1

  ip address 172.16.0.9 255.255.255.248

duplex auto

speed auto

service-policy output phone-trunk-wireless

!

interface FastEthernet0/1/0

ip address 172.16.0.2 255.255.255.252

duplex full

speed 100

service-policy output phone-trunk

!

ip route 0.0.0.0 0.0.0.0 172.16.0.1

ip route 0.0.0.0 0.0.0.0 172.16.0.14 200

ip route 192.168.80.55 255.255.255.255 172.16.0.14

ip route 192.168.91.0 255.255.255.0 192.168.90.1

ip route 192.168.92.0 255.255.255.0 192.168.90.1

ip route 192.168.93.0 255.255.255.0 192.168.90.1

sh ip route

S    192.168.91.0/24 [1/0] via 192.168.90.1

C    192.168.90.0/24 is directly connected, FastEthernet0/0

S    192.168.93.0/24 [1/0] via 192.168.90.1

S    192.168.92.0/24 [1/0] via 192.168.90.1

C    172.16.0.8/29 is directly connected, FastEthernet0/1

C    172.16.0.0/30 is directly connected, FastEthernet0/1/0

S    192.168.80.55 [1/0] via 172.16.0.14

S*   0.0.0.0/0 [1/0] via 172.16.0.1

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Routing from a specific IP address

Pete

On router1 -

access-list 101 permit ip host 192.168.80.55 192.168.90.0 0.0.0.255

route-map PBR permit 10

match ip address 101

set next-hop 172.16.0.9

int fa0/0

ip policy route-map PBR

you have a static host route on router2 for 192.168.80.55 so you don't need PBR on the other router.

Jon

4 REPLIES
Hall of Fame Super Blue

Routing from a specific IP address

Pete

On router1 -

access-list 101 permit ip host 192.168.80.55 192.168.90.0 0.0.0.255

route-map PBR permit 10

match ip address 101

set next-hop 172.16.0.9

int fa0/0

ip policy route-map PBR

you have a static host route on router2 for 192.168.80.55 so you don't need PBR on the other router.

Jon

New Member

Routing from a specific IP address

I was assuming I would have to use an ACL since I couldn't static route it. 

Thank you, I will give it a shot.

New Member

Routing from a specific IP address

The only thing I had to change was:

set next-hop 172.16.0.9

to

set ip next-hop 172.16.0.9

Thanks

Hall of Fame Super Blue

Re: Routing from a specific IP address

Pete

Sorry about that, i missed it out.

Happy to have helped.

Jon

421
Views
0
Helpful
4
Replies