Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing Issue with two ADSL NICS in 1841

Hi EveryBody !!!, Im just tryiing to configure an 1841 Router with 2 ADSL Nics, to route request directed to internet, the issue is that im tryiing to route some origin subnets to one ADSL NIC (Dialer0) and othe subnets trough ADSL NIC (Dialer 1), the show ip nat translations, show that the translations are been made trough the two interfaces, diferentiating traffic by a route map inside each ip nat inside statement , but i think that the problem is that the two defaulte route but to different destination interfaces ip route 0.0.0.0 0.0.0.0 dialer 0 , ip route 0.0.0.0 0.0.0.0 dialer 1. The config works fine for one router statement or one dialer at a time if the correct ip route is deactivated with "no ip route"

I tried this configuration because i found a similar example for load balancing.

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml

Can any body help me with this issue or give a comment about an similar experience ?

Best Regards !

ELO

The config of my router is the following;

5 REPLIES
Hall of Fame Super Blue

Re: Routing Issue with two ADSL NICS in 1841

eduardo.leyva wrote:

Hi EveryBody !!!, Im just tryiing to configure an 1841 Router with 2 ADSL Nics, to route request directed to internet, the issue is that im tryiing to route some origin subnets to one ADSL NIC (Dialer0) and othe subnets trough ADSL NIC (Dialer 1), the show ip nat translations, show that the translations are been made trough the two interfaces, diferentiating traffic by a route map inside each ip nat inside statement , but i think that the problem is that the two defaulte route but to different destination interfaces ip route 0.0.0.0 0.0.0.0 dialer 0 , ip route 0.0.0.0 0.0.0.0 dialer 1. The config works fine for one router statement or one dialer at a time if the correct ip route is deactivated with "no ip route"

I tried this configuration because i found a similar example for load balancing.

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml

Can any body help me with this issue or give a comment about an similar experience ?

Best Regards !

ELO

The config of my router is the following;

If you are sending some subnets one way and other the other way then you need to use PBR. Try this -

modify your config -

change the "match interface ..." line in the 2 route-map entries to "set interface ...."  ie.

route-map SDialer0 permit 1
description "Route MAP NAT DIALER0"
match ip address 100
set interface Dialer0
!
route-map SDialer1 permit 1
description "Route MAP NAT DIALER1"
match ip address 101
set interface Dialer1

then apply the route-maps to the interfaces -

int dialer0

ip policy route-map SDialer0

int dialer1

ip policy route-map SDialer1

Note, try the above first but if it doesn't like you using the same route-maps for NAT and PBR then leave the route-maps above as is and then create new route-map entries with the "set interface ...." command and apply to the interfaces as above.

Jon

New Member

Re: Routing Issue with two ADSL NICS in 1841

Hi Jon thanks for the answer, i just tried what you recommended to me, but it still dont work ..... i put the set statement for each of the Route maps, and i applied the route maps to the dialer just as you suggested me but stil doesnt work , does i have to configure the default routes for the two dialers ?

ip route 0.0.0.0 0.0.0.0 dialer 0,  ip route 0.0.0.0 0.0.0.0 dialer 1 ? , or any other suggestion ?

Best Regards !

ELO

Bronze

Re: Routing Issue with two ADSL NICS in 1841

Hi.

Don't apply the policy route to the dialer  interface, apply it to the Fa0/0 interface. The route-maps used for PBR  send traffic to the dialer, but they're applied to the dialer. How will  traffic ever get to them?

If you create 1 route-map and  use it for PBR on the FA0/0 interface, it will be applied to traffic  entering the interface from the LAN and properly route the traffic to  the appropriate Dialer..

I.E.

route-map split-traffic permit 10
description "Route MAP NAT DIALER0"
match ip address 100
set interface Dialer0
!
route-map split-traffic permit 20
description "Route MAP NAT DIALER1"
match ip address 101
set interface Dialer1

interface FastEthernet0/0

ip policy route-map split-traffic

Hope to Help!

Hall of Fame Super Blue

Re: Routing Issue with two ADSL NICS in 1841

rtjensen4 wrote:

Hi.

Don't apply the policy route to the dialer  interface, apply it to the Fa0/0 interface. The route-maps used for PBR  send traffic to the dialer, but they're applied to the dialer. How will  traffic ever get to them?

If you create 1 route-map and  use it for PBR on the FA0/0 interface, it will be applied to traffic  entering the interface from the LAN and properly route the traffic to  the appropriate Dialer..

I.E.

route-map split-traffic permit 10
description "Route MAP NAT DIALER0"
match ip address 100
set interface Dialer0
!
route-map split-traffic permit 20
description "Route MAP NAT DIALER1"
match ip address 101
set interface Dialer1

interface FastEthernet0/0

ip policy route-map split-traffic

Hope to Help!


Oh dear, how stupid am i

Thanks for clearing up my mistake.

Jon

New Member

Re: Routing Issue with two ADSL NICS in 1841

Hi Jon & Rtjensen4

I just configured my route maps as you suggested to me and the seggregation

of the traffic its working fine ! Thak you for the help !

Best Regards !

ELO

|

411
Views
5
Helpful
5
Replies