Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Routing protocol neighbor between SVI and routed port

I have a special issue that I'm dealing with here...

I have a collapsed core design with routed ports between all components. Access layer switches, data center switches, core/aggregation. All routed (no spanning-tree at all).

Now...

I have to add an IBM BladeCenter with a BNT layer 3 switch to my topology. However, those nasties don't seem to support routed ports.

How can I have a routed port on my cisco switch and a standard access port on the BNT and still establish an adjacency with an SVI? I am running OSPF, but I am labbing this in my home lab with 2 x 3550s and EIGRP.

On SW2:

*Mar  1 00:57:00.711: EIGRP: Received HELLO on Vlan100 nbr 10.1.1.1

*Mar  1 00:57:00.711:   AS 999, Flags 0x0, Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1

*Mar  1 00:57:02.303: EIGRP: Sending UPDATE on Vlan100 nbr 10.1.1.1, retry 9, RTO 5000 tid 0

*Mar  1 00:57:02.303:   AS 999, Flags 0x1, Seq 17/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1

SW1:

*Mar  1 00:58:50.539: EIGRP: Received UPDATE on FastEthernet0/13 nbr 10.1.1.2

*Mar  1 00:58:50.539:   AS 999, Flags 0x1, Seq 18/0 interfaceQ 0/0

*Mar  1 00:58:50.539: EIGRP: Neighbor(10.1.1.2) not yet found

*Mar  1 00:58:52.503: EIGRP: Sending HELLO on FastEthernet0/13

*Mar  1 00:58:52.503:   AS 999, Flags 0x0, Seq 0/0 interfaceQ 0/0

Basically, SW1 is not receiving the HELLOs from SW2, but SW2 receives SW1 and figures the adjacency is done and sends updates.

SW1:

interface FastEthernet0/13

no switchport

ip address 10.1.1.1 255.255.255.0

SW2:

interface Vlan100

ip address 10.1.1.2 255.255.255.0

end

interface FastEthernet0/13

switchport access vlan 100

switchport mode access

end

Any insight?

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Routing protocol neighbor between SVI and routed port

Yea, I did it with both OSPF and EIGRP. Advertised a loop back and the pinged across..

It's gotta be something ridiculously simple. Just post some additional output tomorrow and we'll go from there

Sent from Cisco Technical Support iPhone App

10 REPLIES

Re: Routing protocol neighbor between SVI and routed port

I'm not 100% certain this will work, but you could try the neighbor command under the eigrp process. Can you also post "debug ip packet"?

** Edit **

I just did this in GNS with no issues. Can you post debug ip packet? The SVI neighboring with routed port works fine and I get a route for my loopback from the other switch.

HTH, John *** Please rate all useful posts ***
New Member

Re: Routing protocol neighbor between SVI and routed port

I just shut down my lab for the night. I'll post a debug ip packet tomorrow. How did you sim switches in GNS3?

Re: Routing protocol neighbor between SVI and routed port

You can use an Etherswitch router or a router with the NM-16ESW module in it. It's far from perfect, but it'll do SVIs and routed ports fine....

HTH, John *** Please rate all useful posts ***
New Member

Re: Routing protocol neighbor between SVI and routed port

The output you have here doesn't show SW1 sending any hellos for SW2 to receive.

I would try the neighbor command to stoically define a neighbor with the SVI. Can you post the show ip eigrp adjacency output, topology, and the configs you have on the switches?

Also, how exactly is this BladeCenter built? The L3 switch in it is Cisco I assume because you're trying to use EIGRP on it?

Sent from Cisco Technical Support iPhone App

New Member

Re: Routing protocol neighbor between SVI and routed port

@Ryan: Exactly. SW1 doesn't seem to send HELLOs.

I tried with static neighbors and that didn't change anything.

The configs are what I posted. I wiped the switches and they are blank except for these commands. Oh and the

router eigrp 100

network 10.0.0.0

on both.

The BladeCenter switches are BNTs. I am running OSPF on them as stated, however I am simply testing with EIGRP at home to experiment with this...

New Member

Re: Routing protocol neighbor between SVI and routed port

Oh, somehow I missed the OSPF part. Odd how it's not sending hellos, though. I'll probably try this on my 3750s tonight.. I'll let you know if I work it out. I'll try with OSPF/EIGRP.

Sent from Cisco Technical Support iPhone App

New Member

Re: Routing protocol neighbor between SVI and routed port

Thanks guys for your assistance!

New Member

Re: Routing protocol neighbor between SVI and routed port

Yea, I did it with both OSPF and EIGRP. Advertised a loop back and the pinged across..

It's gotta be something ridiculously simple. Just post some additional output tomorrow and we'll go from there

Sent from Cisco Technical Support iPhone App

New Member

Re: Routing protocol neighbor between SVI and routed port

Just got an email this morning from IBM (BNT) and they told me the latest firmware update finally adds the ability to do routed ports lol.. talk about timing. Although a basic feature like that should have been there from day 1.

New Member

Re: Routing protocol neighbor between SVI and routed port

Wow, how convenient..

Sent from Cisco Technical Support iPhone App

632
Views
6
Helpful
10
Replies
CreatePlease to create content