Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing question

Simple question:

Will a 6509 still route traffic between connected vlans ( with interfaces and addresses assigned ) without the "ip routing" command in it's configuration?

  • LAN Switching and Routing
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Routing question

IP Routing on a C6500 it is enabled by default, and it is also enabled on your C6500.

8 REPLIES
Silver

Re: Routing question

Hi,

no this will not work.

When you disable routing you turn your C6500 into a bridge. In fact, you won't be able to have more than 1 L3 interface active.

HTH,

Dario

New Member

Re: Routing question

Reason I asked is that I have a 6509 with 7 vlans.  Each VLAN has a VLAN interface configured with an IP address assigned.  Traffic flows between VLANs with no problem.  The 6509 configuration does not include the "ip routing" command.  The following is from my 6509.  I trimmed unneccessary details to keep it small. 

no aaa new-model

ip subnet-zero

!

ip domain-name **********

ip name-server **.**.**.**

mls flow ip destination

mls flow ipx destination

no mls acl tcam share-global

!

redundancy

mode sso

main-cpu

auto-sync running-config

auto-sync standard

spanning-tree mode pvst

diagnostic cns publish cisco.cns.device.diag_results

diagnostic cns subscribe cisco.cns.device.diag_commands

!

vlan internal allocation policy ascending

!

!

interface Vlan1

no ip address

shutdown

!

interface Vlan23

ip address 10.6.23.1 255.255.255.0

!

interface Vlan24

description Net_10.6.24.0/24-10.6.25.0/24

ip address 10.6.24.1 255.255.255.0

ip helper-address 10.6.24.93

no ip redirects

!

interface Vlan26

description Net_10.6.26.0/24

ip address 10.6.26.1 255.255.255.0

ip helper-address 10.6.24.93

no ip redirects

!

interface Vlan27

description Net_10.6.27.0/24

ip address 10.6.27.1 255.255.255.0

ip helper-address 10.6.24.93

no ip redirects

!

interface Vlan28

description Net_10.6.28.0/24

ip address 10.6.28.1 255.255.255.0

ip helper-address 10.6.24.93

no ip redirects

!

interface Vlan29

ip address 10.6.29.1 255.255.255.0

ip helper-address 10.6.24.93

no ip redirects

!

interface Vlan30

ip address 192.168.1.6 255.255.255.0

ip helper-address 10.6.24.93

no ip redirects

!

interface Vlan40

ip address 10.10.4.1 255.255.252.0

ip helper-address 10.6.24.93

no ip redirects

!

ip default-gateway 10.6.23.10

ip classless

ip route 0.0.0.0 0.0.0.0 10.6.23.10

ip route 10.0.46.0 255.255.255.0 10.6.23.5

!

no ip http server

!

tftp-server exit

!

dial-peer cor custom

!

end

Silver

Re: Routing question

what do you get if you do a "show ip route"?

New Member

Re: Routing question

I see connected subnets and static routes for other subnets.

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.6.23.10 to network 0.0.0.0

     204.187.87.0/32 is subnetted, 1 subnets
S       204.187.87.33 [1/0] via 10.6.24.201
S       81.255.165.0/24 [1/0] via 10.6.23.10
S       81.255.170.41/32 [1/0] via 10.6.23.10
S       81.255.165.149/32 [1/0] via 10.6.23.10
     10.0.0.0/8 is variably subnetted, 30 subnets, 5 masks
S       10.26.16.0/20 [1/0] via 10.6.23.10
C       10.10.4.0/22 is directly connected, Vlan40
C       10.6.28.0/24 is directly connected, Vlan28
C       10.6.29.0/24 is directly connected, Vlan29
C       10.6.24.0/24 is directly connected, Vlan24
C       10.6.25.0/24 is directly connected, Vlan24
C       10.6.26.0/24 is directly connected, Vlan26
S       10.13.16.0/24 [1/0] via 10.6.23.10
C       10.6.27.0/24 is directly connected, Vlan27
C       10.6.23.0/24 is directly connected, Vlan23
S       10.1.16.0/20 [1/0] via 10.6.23.10
S       10.11.28.0/22 [1/0] via 10.6.23.10
S       10.6.46.0/24 [1/0] via 10.6.23.5
S       10.0.46.0/24 [1/0] via 10.6.23.5
S       10.65.0.0/16 [1/0] via 10.6.23.10

Silver

Re: Routing question

Hi,

Routing is enabled on your C6500. It is not in the config because it is enabled by default.

HTH,

Dario

New Member

Re: Routing question

I 'm not sure that routing is enabled by default.  The 6509 (w/msfc2) has MLS enabled.  With Multilayer switching enabled, it will "switch" layer 3 traffic.  Sort of like routing, only it appears to have some limitations.  But, I wouldn't expect it to allow me to create static routes without routing enabled.

Silver

Re: Routing question

IP Routing on a C6500 it is enabled by default, and it is also enabled on your C6500.

Re: Routing question

Then it looks like ip routing is on by default.  I expect if you disabled it you would see no ip routing in the configuration, just like you do in a 4500.

Kevin Dorrell

Luxembourg

(Sorry Dario, crossed posting).

363
Views
0
Helpful
8
Replies