Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing vlans without a trunk

Hi,

Is there a way to route between 2 vlans WITHOUT using vlan trunking and using only 1 cable between the Router and the Switch.

Scenario:

Router

|

|

Switch

/ \

Vlan1 Vlan2

8 REPLIES
Hall of Fame Super Silver

Re: Routing vlans without a trunk

Ernesto

Given the limitations of 2 VLANs on the switch, one cable from the switch to one interface on the router, I do not believe that Inter-VLAN routing is possible without trunking (UNLESS the switch happens to be a layer 3 switch which can do its own Inter-VLAN routing).

HTH

Rick

New Member

Re: Routing vlans without a trunk

Hi Rick,

It's a switch layer 2.

Re: Routing vlans without a trunk

Not with a Cisco switch afaik. You need a trunk or two physical links between the router and the switch.

Regards,

Francois

Re: Routing vlans without a trunk

BTW, why is that requirement? Are you trying to do something similar to private vlans? (private vlans might help here)

Regards,

Francois

New Member

Re: Routing vlans without a trunk

Hi Francois,

It was a challenge Lab. I didn't get to know what was the correct answer thats why I wanted to doublecheck with the forum if there could be any possible way around given the limitations.

Do you think it could be possible using private vlans?

Re: Routing vlans without a trunk

Oh I see;-)

Yes, I guess they were expecting private vlans here. A promiscuous port allow you to have l3 connectivity between two private vlans while preventing direct l2 connectivity. Now, of course, you can challenge the fact that the two vlans are different, as they share the same primary vlan;-)

Regards,

Francois

New Member

Re: Routing vlans without a trunk

I'm pretty sure you can use Subinterfaces on each side if you run ios on both sides...

you'll still have some 802.1q config, but it would look something this:

ROUTER

interface GigabitEthernet2/0

description ROUTER

ip address 10.14.2.254 255.255.255.0

!

interface GigabitEthernet2/0.1

encapsulation dot1Q 1 native

no snmp trap link-status

no cdp enable

no shut

!

interface GigabitEthernet2/0.14

description ROUTER-OPER-NET-GATEWAY

encapsulation dot1Q 14

ip address 10.14.1.254 255.255.255.0

ip access-group lan-ROUTER-OPER-in in

ip access-group lan-ROUTER-OPER-out out

!

interface GigabitEthernet2/0.114

description ROUTER-MGMT-NET-GATEWAY

encapsulation dot1Q 114

ip address 10.19.14.254 255.255.255.0

ip access-group lan-ROUTER-MGMT-in in

ip access-group lan-ROUTER-MGMT-out out

no shut

!

SWITCH

interface GigabitEthernet0/1

description SWITCH

ip address 10.14.2.253 255.255.255.0

!

interface GigabitEthernet0/1.1

encapsulation dot1Q 1 native

no snmp trap link-status

no cdp enable

no shut

!

interface GigabitEthernet0/1.14

description SWITCH-OPER-NET-GATEWAY

encapsulation dot1Q 14

ip address 10.14.1.253 255.255.255.0

ip access-group lan-SWITCH-OPER-in in

ip access-group lan-SWITCH-OPER-out out

!

interface GigabitEthernet0/1.114

description SWITCH-MGMT-NET-GATEWAY

encapsulation dot1Q 114

ip address 10.19.14.253 255.255.255.0

ip access-group lan-SWITCH-MGMT-in in

ip access-group lan-SWITCH-MGMT-out out

no shut

!

New Member

Re: Routing vlans without a trunk

Thanks for the answer, I'm sure this could work, but the challenge question was without using trunking (without using ISL or dot1q)

BTW In the scenario both the switch and router are Cisco, and the switch is a layer 2 device.

158
Views
3
Helpful
8
Replies
CreatePlease login to create content