Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Routing

I have 2 1600 routers with one ethernet conn each. Cisco Router A is connected to a normal home router and Cisco router B is connected to a pc nic. Both cisco routers are connected to eachother with a serial back to back cable. I want that from the pc which is connected to Router B pass through router A and have an internet connection through my basic home router. Since router B lan interface is on a different subnet than the Lan home router interface I cannot ping it from Router B. can someone help thank you. All I can reach from router B is the Lan interface of Router A by using Eigrp

4 REPLIES

Re: Routing

Assuming you can get to the Internet from routerA through your home router you can make routerB LAN access the Internet by configuring NAT on routerA.

The NAT configuration on routerA would something like this. Substitute the interface name and addresses according to your setup.

RouterA:

int e0/0

description connection to home router

ip nat outside

int e0/1

description connection to routerB

ip nat inside

ip nat inside source list 10 interface e0/0 overload

access-list 10 permit

Try this and let us know if it helped.

HTH

Sundar

New Member

Re: Routing

these are my config

RouterA#show run

Building configuration...

Current configuration : 708 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RouterA

!

boot system tftp newc1600z.123-6.bin 192.168.0.2

enable password xxx

!

ip subnet-zero

!

!

!

!

interface Ethernet0

description Connection to pc nic

ip address 192.168.1.33 255.255.255.224

no ip route-cache

no ip mroute-cache

!

interface Serial0

description Connection To Router B

ip address 192.168.0.100 255.255.255.0

!

router eigrp 20

network 192.168.0.0

network 192.168.1.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip http server

!

!

line con 0

line vty 0 4

password xxx

login

!

end

RouterB#show run

Building configuration...

Current configuration : 814 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RouterB

!

enable secret xxx.

enable password xxx

!

ip subnet-zero

ip name-server 192.168.1.66

!

!

!

!

interface Ethernet0

description Connection to Home Router

ip address 192.168.1.65 255.255.255.224

no ip mroute-cache

no cdp enable

!

interface Serial0

description Connection to Router A

ip address 192.168.0.101 255.255.255.0

no ip mroute-cache

clockrate 125000

!

router eigrp 20

network 192.168.0.0

network 192.168.1.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.66

no ip http server

!

!

line con 0

exec-timeout 0 0

line vty 0 4

password xxx

login

!

end

192.168.1.66 is my home router Lan ip address and the problem I want to fix is that from Router A I cannot ping 192.168.1.66 and therefore my pc which is connected to Router A cannot browse the internet.

How can I use NAT to fix the problem or is there a different way

Thank you for your time

Re: Routing

What am I missing here. You say routerA is connected to home router and routerB is connected to PC. However, the configuration is showing exactly the opposite. Which is correct?

New Member

Re: Routing

sorry the configuration is right

170
Views
0
Helpful
4
Replies
CreatePlease to create content