Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

'rtr responder' instead of 'ip sla monitor' ?

I have written some code for a Cisco 6509. I want to check traffic on all LAN and WAN VLANs to see if it is destined to, or arriving from, a particular Data Centre. If it is, then I want that traffic redirected to a particular device. I first want to check that the device is alive; if it is not alive, then I want the traffic to ignore the code and traverse the network as per usual. I wrote the below code only to find out that the version of software (12.2) on the 6509 does not support the ‘ip sla monitor’ command. I have been advised that I should use the ‘rtr responder’ command instead. Can someone tell me what code I would need to run to replace the below code that I had already written? I’m a little short on time and don’t have time to spend days researching; I was hoping someone in here might have the knowledge?

vlan database

vlan 120 name vlan120

exit

en

conf t

interface vlan 120

description Redirect_Device

ip address 10.11.11.11 255.255.255.248

no shutdown

no ip redirects

standby 12 ip 10.11.11.10

standby 12 timers 2 5

standby 12 priority 150

standby 12 preempt delay minimum 30

standby 12 authentication BRvlan120

interface GigabitEthernet 2/3

switchport access vlan 120

description “Redirect Device on this Interface”

no shutdown

exit

ip sla monitor 1

type echo protocol ipicmpecho 10.11.11.13

ip sla monitor schedule 1 start-time now life forever

track 123 rtr 1 reachability

exit

access-list 100 permit ip 0.0.0.0 255.255.255.255 10.58.11.0 0.0.15.255

access-list 110 permit ip 10.58.11.0 0.0.15.255 0.0.0.0 255.255.255.255

route-map DataCentre_Outbound permit 10

match ip address 100

set ip next-hop verify-availability 10.11.11.11.13 track 123

exit

route-map DataCentre_Inbound permit 10

match ip address 110

set ip next-hop verify-availability 10.11.11.13 track 123

exit

!!!Apply to relevant interfaces

!Inbound route-map

interface range vlan 50 – 200

ip policy route-map DataCentre_Inbound

end

! Outbound route-map

interface range vlan 201 – 300

ip policy route-map DataCentre_Outbound end

write m

2 REPLIES
Purple

'rtr responder' instead of 'ip sla monitor' ?

Hi,

Can you post your sh ver output .

Regards.

Alain

Don't forget to rate helpful posts.
New Member

'rtr responder' instead of 'ip sla monitor' ?

output of show ver is:

SWITCHNAME#show version
Cisco Internetwork Operating System Software
IOS (tm) c6sup2_rp Software (c6sup2_rp-JSV-M), Version 12.1(23)E1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Tue 14-Sep-04 19:55 by pwade
Image text-base: 0x40008F90, data-base: 0x41B84000

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)
BOOTLDR: c6sup2_rp Software (c6sup2_rp-JSV-M), Version 12.1(23)E1, RELEASE SOFTWARE (fc3)

SWITCHNAME uptime is 10 weeks, 5 days, 18 hours, 4 minutes
Time since SWITCHNAME switched to active is 10 weeks, 5 days, 18 hours, 5 minutes
System returned to ROM by power-on (SP by power-on)
System restarted at 05:21:17 UTC Wed Mar 7 2012
System image file is "sup-bootflash:c6sup22-jsv-mz.121-23.E1.bin"

cisco WS-C6509 (R7000) processor (revision 3.0) with 112640K/18432K bytes of memory.
Processor board ID SMG0820A408
R7000 CPU at 300Mhz, Implementation 39, Rev 3.3, 256KB L2, 1024KB L3 Cache
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
17 Virtual Ethernet/IEEE 802.3  interface(s)
48 FastEthernet/IEEE 802.3 interface(s)
52 Gigabit Ethernet/IEEE 802.3 interface(s)
381K bytes of non-volatile configuration memory.

32768K bytes of Flash internal SIMM (Sector size 512K).
Standby is up
Standby has 112640K/18432K bytes of memory.

Configuration register is 0x102

766
Views
0
Helpful
2
Replies