Cisco Support Community
Community Member

RV320 VLAN and Advanced routing.

Have setup an RV320 with VLAN 1, 25,100. VLAN 1 are for administration purposes. VLAN 25 for company LAN and VLAN 100 for guests.

VLAN 1 =

VLAN 25 =

VLAN 100 =

SG300-52 switch i setup same way and everything is working smoothly.

Now I need to route to i.e. another gateway on LAN. So i go to advanced routing, type in the route.

When I try to trace route of from a computer on VLAN 25 I get first hop to i.e. VLAN 1 instead of VLAN 25 -

Is this normal? How do you "direct" it to VLAN 25?. Haven't tried this setup before.. But routing worked before adding VLANs

(Used on VLAN 1 before adding extra VLANs.)


Any help highly appreciated.





Everyone's tags (1)
Community Member

Got the same problem here.I

Got the same problem here.

I am only able to route in vlan1.


sound like a bug to me.

Community Member

You are fortunate. For our

You are fortunate. For our RV320, routing between VLANs was entirely broken out of the box. No instructions in the text documentation for enabling it when it doesn't work. Can't ping the router on any of the added subnets, only the default. No help from the setup video since it shows the same steps we followed. So much about this 'router' that's not normal for an IP router, including subnet configuration being straight-jacketed down to 255 addresses or less. 

CreatePlease to create content