Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Purple

SCP transfer failure

Having issue with some devices not being able to save to a file server using SCP .  The problem seems to be a 1 way issue so it's not a FW issue also I have devices which are the same device running the same code  yet one works but one does not work . The failure is saving a config back to the server.  We are able to copy from the server back into say bootflash of the devices.  File permissions are open on all files we are having issues with. The puzzling thing it is one way only.  We had to go to SCP due to security requirements, tftp  worked fine on all devices before . Any input appreciated .  Done all the searching i can on this. We have issues on 3750,2960, and 4500's .  Some of the code is backleveled so it could be that ,not sure.

 

col-tccc1-sa-2a#copy start scp:
Address or name of remote host []? 161.162.xxx.xx
Destination username [col-tccc1-sa-2a]? ggrant
Destination filename [col-tccc1-sa-2a-confg]? /network/tftpboot/col-tccc1-sa-2a-confg
Uncompressed configuration from 12372 bytes to 40286 bytes
Writing /network/tftpboot/col-tccc1-sa-2a-confg
Password:
%scp: error: unexpected filename: /network/tftpboot/col-tccc1-sa-2a-confg      FAILURE to Transfer


%Error writing scp://ggrant@161.162.xxx.xx//network/tftpboot/col-tccc1-sa-2a-confg (Permission denied)

4 REPLIES
New Member

Have you tried the

Have you tried the destination filename without the /, such as:

Destination filename [col-tccc1-sa-2a-confg]? network/tftpboot/col-tccc1-sa-2a-confg

 

 

Purple

   Yes same issue and same

   Yes same issue and same error .

New Member

Is your scp server a Linux

Is your scp server a Linux box?  If so, I've always had to create the empty file in the directory and give write permissions to it when writing to my Linux servers.  And those permissions would need to be applied up the directory, tftpboot, network. 

Purple

   After looking at this

   After looking at this further I think it is probably related  to this bug . Covered a wide range of ios versions and it is pretty much the same thing as I am seeing .  Unfortunetly their work around does not work on my boxes.

CSCsb62045

Symptom:
When attempting to scp files from a router, when connecting to some scp servers the following error is generated:

ROUTER#copy running-config scp://root@1.2.3.4://tmp/test
Address or name of remote host [1.2.3.4]?
Destination username [root]?
Destination filename [/tmp/test]?
Writing /tmp/test
Password:
Sink: C0644 693 /tmp/test
%scp: error: unexpected filename: /tmp/test


%Error writing scp://root@172.18.124.187//tmp/test (Permission denied)

Conditions:
The customer must be copying the files from the router using the scp method, and must specify the
remote filename

Workaround:
Do not specify the filename in the scp command. Simply specify the destination address, and let
the router prompt for the remainder of the information, as below:

ROUTER#copy running-config scp://root@1.2.3.4
Address or name of remote host [1.2.3.4]?
Destination username [root]?
Destination filename [router-config]?
Writing router-config
Password:
Sink: C0644 693 router-config
!
693 bytes copied in 5.288 secs (131 bytes/sec)
ROUTER#
 
 
Customer Visible
 
 
3494
Views
5
Helpful
4
Replies