Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Second MGMT IP

I have to re ip a network.  The current network is 10.110.46.0/24 and the 10.110.49.0/24.  I am trying to keep both networks up and running at the same time.  They are connected back to my corporate network via MPLS network.

 

When i change the switchport access on the switches to the new 49 network pc's work fine and can talk back to corporate network.  Get DCHP fine from my network.

 

There is a switch currently IP'd as 10.110.46.221 its a 2950.  When I add a new vlan interface as 10.110.49.221 I lose contact with the switch.  I can get back into the switch from the router via the 10.110.49.221.  I read that the 2950 can only have one active vlan ip address.  Is this true?

 

Also, from the new switch when the 49.221 ip address is active I can not ping my router of 10.110.49.254 which is a virutal ip setup for HSRP.  I can ping the physical interface fine.  When I switch default gateway on the switch from 10.110.49.254 10.110.49.218(VIP) I can then get to it.

 

 

Any ideas of why I cant ping virtual IP?

 

 

 

Also seeing theses errors on the switch when I turn on 49 vlan int:

 

*Feb 28 19:00:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan46, change
d state to up
*Feb 28 19:00:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/
24, changed state to up
May 15 10:47:57: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer
 vlan id 1 on FastEthernet0/25 VLAN46.
May 15 10:47:57: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/25 on VLAN0
001. Inconsistent peer vlan.
May 15 10:47:57: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/25 on VLAN
0046. Inconsistent local vlan.
May 15 10:48:32: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/25 o
n VLAN0001. Port consistency restored.
May 15 10:48:32: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/25 o
n VLAN0046. Port consistency restored.
May 15 10:48:47: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2
5, changed state to down
May 15 10:48:52: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2
5, changed state to up

 

 

Thanks

  • LAN Switching and Routing
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Could you post the output of

Could you post the output of "show interfaces trunk" on both switches please?

12 REPLIES
New Member

Could you post your switch

Could you post your switch config? It looks like you might have an STP issue. And the 2950 can only have one SVI.
 

New Member

aaa new-modelaaa

aaa new-model
aaa authentication login default group tacacs+
aaa authentication login consoleport group tacacs+ local
aaa authentication login vtyport group tacacs+ local
aaa authentication ppp default if-needed group tacacs+
aaa authorization exec default group tacacs+ local if-authenticated
aaa authorization commands 15 default group tacacs+ if-authenticated
aaa authorization network default group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting network default start-stop group tacacs+

!

clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
ip subnet-zero
!

!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 46
 rmon collection stats 1 owner PMmonitor
 --More--          rmon collection history 1 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan 46
 rmon collection stats 2 owner PMmonitor
 rmon collection history 2 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan 46
 rmon collection stats 3 owner PMmonitor
 rmon collection history 3 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan 46
 rmon collection stats 4 owner PMmonitor
 rmon collection history 4 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport access vlan 46
 --More--          rmon collection stats 5 owner PMmonitor
 rmon collection history 5 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport access vlan 46
 rmon collection stats 6 owner PMmonitor
 rmon collection history 6 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/7
 switchport access vlan 46
 rmon collection stats 7 owner PMmonitor
 rmon collection history 7 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/8
 switchport access vlan 46
 rmon collection stats 8 owner PMmonitor
 rmon collection history 8 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/9
 --More--          switchport access vlan 46
 rmon collection stats 9 owner PMmonitor
 rmon collection history 9 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/10
 switchport access vlan 46
 rmon collection stats 10 owner PMmonitor
 rmon collection history 10 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/11
 switchport access vlan 46
 rmon collection stats 11 owner PMmonitor
 rmon collection history 11 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/12
 switchport access vlan 46
 rmon collection stats 12 owner PMmonitor
 rmon collection history 12 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
 --More--         interface FastEthernet0/13
 switchport access vlan 46
 rmon collection stats 13 owner PMmonitor
 rmon collection history 13 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport access vlan 46
 rmon collection stats 14 owner PMmonitor
 rmon collection history 14 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/15
 switchport access vlan 46
 rmon collection stats 15 owner PMmonitor
 rmon collection history 15 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/16
 switchport access vlan 46
 rmon collection stats 16 owner PMmonitor
 rmon collection history 16 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
 --More--         !
interface FastEthernet0/17
 switchport access vlan 46
 rmon collection stats 17 owner PMmonitor
 rmon collection history 17 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/18
 switchport access vlan 46
 rmon collection stats 18 owner PMmonitor
 rmon collection history 18 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/19
 switchport access vlan 46
 rmon collection stats 19 owner PMmonitor
 rmon collection history 19 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/20
 switchport access vlan 46
 rmon collection stats 20 owner PMmonitor
 rmon collection history 20 owner PMmonitor buckets 50 interval 1800
 --More--          spanning-tree portfast
!
interface FastEthernet0/21
 switchport access vlan 46
 rmon collection stats 21 owner PMmonitor
 rmon collection history 21 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/22
 switchport access vlan 46
 rmon collection stats 22 owner PMmonitor
 rmon collection history 22 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/23
 switchport access vlan 46
 rmon collection stats 23 owner PMmonitor
 rmon collection history 23 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/24
 switchport access vlan 46
 rmon collection stats 24 owner PMmonitor
 --More--          rmon collection history 24 owner PMmonitor buckets 50 interval 1800
 spanning-tree portfast
!
interface FastEthernet0/25
 switchport mode trunk
 rmon collection stats 25 owner PMmonitor
 rmon collection history 25 owner PMmonitor buckets 50 interval 1800
!
interface FastEthernet0/26
 switchport mode trunk
 rmon collection stats 26 owner PMmonitor
 rmon collection history 26 owner PMmonitor buckets 50 interval 1800
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan46
 ip address 10.110.46.221 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.110.46.254

 

^C
!
line con 0

 login authentication consoleport
 stopbits 1
line vty 0
 exec-timeout 0 0

 login authentication vtyport


 login authentication vtyport
line vty 5 15

 login authentication vtyport
!
ntp clock-period 17179899

!
end

 

 

Port 25 is the uplink.  Not passing a native vlan on either side.  I rebooted the switch to get it back up and working.  vlan 49 was configured same way as 46 just with 49 IP. 

New Member

I see those spanning tree

I see those spanning tree errors right when I turn on the new SVI. 

New Member

It looks like you have a

It looks like you have a native vlan mismatch, even though it would normally tell you as much in the log, and STP is putting the port into a blocking state. Because it's a layer 2 switch it can only have one active SVI and shutting down vlan 1 is causing the mismatch. Is the other device a layer 3 switch or router?

New Member

Its the same exact switch.  I

Its the same exact switch.  I didnt define native vlan on either trunk.  It is still operating with a 10.110.46.222 address on it and was not moved over to 10.110.49.222 address. 

New Member

Could you post the output of

Could you post the output of "show interfaces trunk" on both switches please?

New Member

From 10.110.46.221 which is

From 10.110.46.221 which is far end switch:

 

Port        Mode         Encapsulation  Status        Native vlan
Fa0/25      on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/25      1-4094

Port        Vlans allowed and active in management domain
Fa0/25      1,40,46,49,89,109,145-146,440,445-446,449,489,501-502,540,546

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/25      1,40,46,49,89,109,145-146,440,445-446,449,489,501-502,540,546

 

 

 

From 10.110.46.222 which is the neighbor:

Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       desirable    802.1q         trunking      1
Fa0/24      on           802.1q         trunking      1
Fa0/25      on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/1       1-4094
Fa0/24      1-4094
Fa0/25      1-4094

Port        Vlans allowed and active in management domain
Fa0/1       1,40,46,49,89,109,145-146,440,445-446,449,489,501-502,540,546
Fa0/24      1,40,46,49,89,109,145-146,440,445-446,449,489,501-502,540,546
Fa0/25      1,40,46,49,89,109,145-146,440,445-446,449,489,501-502,540,546

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,40,46,49,89,109,145-146,440,445-446,449,489,501-502,540,546
Fa0/24      1,40,46,49,89,109,145-146,440,445-446,449,489,501-502,540,546
Fa0/25      1,40,46,49,89,109,145-146,440,445-446,449,489,501-502,540,546

 

 

 

I will try to clear the arp when I have a window to take the switch down again.  Are you thinking that the router didn't know what to do since it had an arp entry for the same mac address for two different IP's?

 

 

Thanks

 

New Member

I'd recommend that you check

I'd recommend that you check the bug tracker for any issues related to your IOS version because from the log output it shows that when you make the svi change, your native vlan is changing...

New Member

Why don't you try setting the

Why don't you try setting the native vlan on the trunk interfaces before you make any changes? Make it a vlan you'll never actually use in production, like 999.

switchport trunk native vlan 999

90
Views
0
Helpful
12
Replies
This widget could not be displayed.