Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

sending mail problem

Hi all,

I have the following problem: My customer has a mail server at their site. They are using Alt-N Mdaemon Pro for Windows mail server, cisco 837 ADSL router. Recently, they reported that they can receive email from outside but cannot send mail outside. However, when I change Cisco 837 by a Linksys router, the local mail server can send mail outside.

I have tried to remove all ACL on the router, ADSL connection is ok but still cannot send mail outside. This is my router configuration:

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname xxxxxxxxxx

!

enable password xxxxxxxxx

!

no aaa new-model

ip subnet-zero

no ip source-route

no ip domain lookup

!

!

no ip bootp server

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

!

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.10

ip dhcp excluded-address 192.168.1.250 192.168.1.254

!

ip dhcp pool xxxxxxxxxxx

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 203.162.x.x.162.4.191

update arp

!

!

!

interface Ethernet0

description <xxxxxxxxxxxxxxxxx>

ip address 192.168.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc ATM0.1 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

description <Connection to Internet via ADSL>

bandwidth 640

ip address negotiated

no ip redirects

no ip unreachables

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp pap sent-username xxxxxxxxxx password xxxxxxxxxxxxx

!

ip nat inside source list 1 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

no ip http secure-server

!

access-list 1 permit any

access-list 1 remark The local LAN.

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 120 0

password xxxxxxxxx

login

no modem enable

stopbits 1

line aux 0

line vty 0 4

exec-timeout 120 0

login local

!

scheduler max-task-time 5000

!

end

Can anyone help me to isolate/fix this problem? Thanks in advance.

3 REPLIES

Re: sending mail problem

Hi

Can you try configuring the below commands under your dialer interface ?

ip mtu 1492

ip tcp adjust-mss 1452

regds

New Member

Re: sending mail problem

spremkumar,

Thanks alot. It works right now. So there is no default setting for maximum segment size (MSS) value of TCP SYN packets, right?

regards,

Re: sending mail problem

Hi

I have seen quite a few issues inline with the MSS and MTU sizes especially when it comes to DSL/ADSL connectivity.

AFAIK the default size of MTU would be 1500 bytes which comes with most of the interfaces which i feel required to be tweaked in case of these kida connectivity issues.

Usually the MSS will be 40 bytes lesser than the normal mtu which u define under the interface..thats the thumb rule being used at present ..:-)

regds

159
Views
4
Helpful
3
Replies
CreatePlease login to create content