Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Server-Client VTP Domain

I have VTP server running on 6509 (IOS) and a VTP client running on a nx7000 (NXOS).

When a new vlan is configured on  VTP server 6509 (IOS), it is not distributed on VTP client nx7000 (NXOS).

NX7000# sh vtp status

VTP Status Information

----------------------

VTP Version                     : 2 (capable)

Configuration Revision          : 1

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 27

VTP Operating Mode              : Client

VTP Domain Name                 : impa

VTP Pruning Mode                : Disabled (Operationally Disabled)

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 Digest                      : 0xA2 0x12 0x87 0x66 0x49 0x8E 0x1D 0x93

Configuration last modified by 147.65.2.7 at 11-1-11 20:27:46

VTP version running             : 2

Local updater ID is 147.65.2.7

6509-E#sh vtp status

VTP Version                     : 2

Configuration Revision          : 90

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 28

VTP Operating Mode              : Server

VTP Domain Name                 : impa

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Enabled

MD5 digest                      : 0x4A 0xA6 0x0B 0x78 0xAB 0x2E 0xA2 0xA4

Configuration last modified by 0.0.0.0 at 11-7-11 16:13:39

Local updater ID is 0.0.0.0 on interface Po99 (preferred interface mandatory)

Preferred interface name is Port-channel99 (mandatory)

6509-E

#

3 ACCEPTED SOLUTIONS

Accepted Solutions

Server-Client VTP Domain

Hi,

Vlan 1 should be enabled on all switch trunks otherwise VTP may not work properly.

Best regards,

Alex

Purple

Server-Client VTP Domain

  Realistically vlan 1 does not need to be on the trunks for vtp  to work correctly .  

Re: Server-Client VTP Domain

Hi Glen,

On Nexus it does. Especially in previuos versions where only transperant mode could be used.

Best regards,

Alex

EDIT: Here it is written in cisco documentation:

http://www.cisco.com/en/US/docs/switches/datacenter/sw/5_x/nx-os/layer2/configuration/guide/Cisco_Nexus_7000_Series_NX-OS_Layer_2_Switching_Configuration_Guide_Release_5.x_chapter5.html#task_1273736

12 REPLIES
VIP Super Bronze

Server-Client VTP Domain

Is the password the same for both devices?

Remove that password temporary and see if the data base syncs.  If it work without password then you know the problem.

HTH

Server-Client VTP Domain

Hi Rosa,

Additionaly to what Reza already suggested you can issue "show vtp statistics" and look for errors.

Best regards,

Alex

Purple

Server-Client VTP Domain

  Is there an actual working trunk line between these 2 devices ?   Make sure the trunk is link is configured correctly and the native vlans match up.

Hall of Fame Super Gold

Server-Client VTP Domain

Compare the password using the command "sh vtp password". 

Silver

Server-Client VTP Domain

Rosa Ladeira wrote:

I have VTP server running on 6509 (IOS) and a VTP client running on a nx7000 (NXOS).

When a new vlan is configured on  VTP server 6509 (IOS), it is not distributed on VTP client nx7000 (NXOS).

NX7000# sh vtp status

VTP Status Information

----------------------

VTP Version                     : 2 (capable)

Configuration Revision          : 1

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 27

VTP Operating Mode              : Client

VTP Domain Name                 : impa

VTP Pruning Mode                : Disabled (Operationally Disabled)

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 Digest                      : 0xA2 0x12 0x87 0x66 0x49 0x8E 0x1D 0x93

Configuration last modified by 147.65.2.7 at 11-1-11 20:27:46

VTP version running             : 2

Local updater ID is 147.65.2.7

6509-E#sh vtp status

VTP Version                     : 2

Configuration Revision          : 90

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 28

VTP Operating Mode              : Server

VTP Domain Name                 : impa

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Enabled

MD5 digest                      : 0x4A 0xA6 0x0B 0x78 0xAB 0x2E 0xA2 0xA4

Configuration last modified by 0.0.0.0 at 11-7-11 16:13:39

Local updater ID is 0.0.0.0 on interface Po99 (preferred interface mandatory)

Preferred interface name is Port-channel99 (mandatory)

6509-E

#

What version of NXOS are you running? Prior to 5.1(1), VTP was only supported in transparent mode, from memory.

Maybe a silly question, but have you turned on the VTP feature on the Nexus with the "feature vtp" command?

And I second Glen's comments - make sure you have a valid trunk between the two devices and the native VLAN numbers match.

Cheers

New Member

Server-Client VTP Domain

Software

  BIOS:      version 3.22.0

  kickstart: version 5.1(1)

  system:    version 5.1(1)

  BIOS compile time:       02/20/10

  kickstart image file is: bootflash:///n7000-s1-kickstart-npe.5.1.1.bin

  kickstart compile time:  12/25/2020 12:00:00 [10/24/2010 08:25:25]

  system image file is:    bootflash:///n7000-s1-dk9-npe.5.1.1.bin

  system compile time:     9/2/2010 19:00:00 [10/24/2010 09:34:48]

Hardware

  cisco Nexus7000 C7010 (10 Slot) Chassis ("Supervisor module-1X")

  Intel(R) Xeon(R) CPU         with 4109596 kB of memory.

  Processor Board ID JAF1444BLKS

  Device name: nx7000-wc0

  bootflash:    2029608 kB

  slot0:              0 kB (expansion flash)

Kernel uptime is 5 day(s), 23 hour(s), 51 minute(s), 36 second(s)

Last reset at 254133 usecs after  Sat Nov  5 09:47:59 2011

  Reason: Reset Requested by CLI command reload

  System version: 5.1(1)

  Service:

plugin

  Core Plugin, Ethernet Plugin

CMP (Module 5) ok

CMP Software

  CMP BIOS version:        02.01.05

  CMP Image version:       5.1(1) [build 5.0(0.66)]

  CMP BIOS compile time:   8/ 4/2008 19:39:40

  CMP Image compile time:  9/2/2010 19:00:00

nx7000-wc0#

New Member

Server-Client VTP Domain

nx7000-wc0# sh feature

Feature Name          Instance  State  

--------------------  --------  --------

amt                   1         disabled

bfd                   1         disabled

bfd_app               1         disabled

bgp                   1         disabled

dhcp                  1         enabled

dot1x                 1         disabled

eigrp                 1         disabled

eigrp                 2         disabled

eigrp                 3         disabled

eigrp                 4         disabled

eou                   1         disabled

eth_port_sec          1         disabled

fex                   1         enabled

fipsm                 1         disabled

glbp                  1         disabled

hsrp_engine           1         disabled

interface-vlan        1         enabled

isis                  1         disabled

isis                  2         disabled

isis                  3         disabled

isis                  4         disabled

lacp                  1         disabled

ldap                  1         disabled

lisp                  1         disabled

lldp                  1         disabled

msdp                  1         enabled (not-running)

netflow               1         enabled

ospf                  1         disabled

ospf                  2         disabled

ospf                  3         disabled

ospf                  4         disabled

ospfv3                1         disabled

ospfv3                2         disabled

ospfv3                3         disabled

ospfv3                4         disabled

otv                   1         disabled

pbr                   1         disabled

pim                   1         enabled (not-running)

pim6                  1         disabled

private-vlan          1         disabled

privilege             1         disabled

rip                   1         disabled

rip                   2         disabled

rip                   3         disabled

rip                   4         disabled

scheduler             1         disabled

scpServer             1         disabled

sftpServer            1         disabled

sshServer             1         enabled

tacacs                1         disabled

telnetServer          1         enabled

tunnel                1         enabled

udld                  1         disabled

vpc                   1         disabled

vrrp                  1         disabled

vtp                   1         enabled

wccp                  1         disabled

nx7000-wc0#

New Member

Server-Client VTP Domain

It works fine if  6509 and only if :

cat6509-wc1#sh vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 30

VTP Operating Mode              : Transparent

VTP Domain Name                 : impa

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Enabled

MD5 digest                      : 0x3C 0x9B 0x6B 0xE5 0x63 0xF3 0x77 0xC5

Configuration last modified by 147.65.14.8 at 11-7-11 16:13:39

cat6509-wc1#

and NX7000

nx7000-wc0# sh vtp status

VTP Status Information

----------------------

VTP Version                     : 2 (capable)

Configuration Revision          : 3

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 29

VTP Operating Mode              : Server

VTP Domain Name                 : impa

VTP Pruning Mode                : Disabled (Operationally Disabled)

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 Digest                      : 0x81 0x1F 0x16 0x12 0x58 0x44 0x4B 0x34

Configuration last modified by 147.65.2.7 at 11-7-11 13:23:01

VTP version running             : 2

Local updater ID is 147.65.2.7

nx7000-wc0#

Server-Client VTP Domain

Hi,

Vlan 1 should be enabled on all switch trunks otherwise VTP may not work properly.

Best regards,

Alex

New Member

Server-Client VTP Domain

OK.

Thanks.

Rosa

Purple

Server-Client VTP Domain

  Realistically vlan 1 does not need to be on the trunks for vtp  to work correctly .  

Re: Server-Client VTP Domain

Hi Glen,

On Nexus it does. Especially in previuos versions where only transperant mode could be used.

Best regards,

Alex

EDIT: Here it is written in cisco documentation:

http://www.cisco.com/en/US/docs/switches/datacenter/sw/5_x/nx-os/layer2/configuration/guide/Cisco_Nexus_7000_Series_NX-OS_Layer_2_Switching_Configuration_Guide_Release_5.x_chapter5.html#task_1273736

627
Views
0
Helpful
12
Replies