Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Service Module is failed

Hi all, we have approx. 70 Cisco 1941W routers deployed in our company. I used to be able to console into the internet wireless AP by issuing the below command

service-module wlan-ap0 session

However lately this hasn't been working and AP just simply refuses connection. Here is what I have for Status. I have tried reseting the Service Module to no avail. Please advise.

Router#service-module wlan-ap0 status

Service Module is Cisco wlan-ap0

Service Module supports session via TTY line 67

Service Module is failed

Service Module reset on error is disabled

Service Module heartbeat-reset is enabled

Service Module is in fail open

Service Module status is not available

Everyone's tags (4)
3 REPLIES
Purple

Service Module is failed

Sounds like maybe the WLC card has bit the dust .  Open a tac case and get there opinion and then get it replaced.

New Member

Re: Service Module is failed

I was experiencing the same issue and error (connection refused by 192.168.1.30 2066,  ip address and the reverse tenlet port of the Wlan-Ap). Checked the status and had same information as you did.  As the message says (connetion refused), so i cleared the line (66 in this case) and then tried again.   It worked.   So try clearing your internal line and then test again.   Command  is  below

Router#clear line 67 ( in your case it is 67)

confirm

New Member

Re: Service Module is failed

This issue has been resolved. It turned out, for some reason, line 67 was set to accept incoming connection via SSH only. I had to change it to telnet in order to be able to access the built-in AP.

Thanks

1629
Views
10
Helpful
3
Replies