Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Setting COS on a 6513

I would like to set the COS of 4 to a video server that we have attached to a 6513 module WS-X6748-GE-TX.

I have done this before on a 3750 by using the following commands

mls qos cos 4

mls qos cos override

However the 'override' option is not available on a Cat 6500 and if you use just the mls qos cos 4 command the packets are not marked.

I have tried writing a QOS policy (below) but this does not work and the packets still don't have any QOS values set when monitoring with Wireshark.

Any help on resolving this would be appreciated.

class-map match-all set_dscp_video

match access-group 110

policy-map setqos

class set_dscp_video

set ip dscp 41

interface GigabitEthernet9/47

switchport

switchport access vlan 30

switchport mode access

wrr-queue cos-map 2 1 1 2

wrr-queue cos-map 3 5 3 4

wrr-queue cos-map 3 7 6 7

rcv-queue cos-map 1 2 1

rcv-queue cos-map 1 3 2

rcv-queue cos-map 1 4 3

rcv-queue cos-map 1 5 4

rcv-queue cos-map 1 6 5

rcv-queue cos-map 1 7 6

rcv-queue cos-map 1 8 7

spanning-tree portfast

service-policy input setqos

access-list 110 permit ip any any

3 REPLIES

Re: Setting COS on a 6513

COS value can only be carried when packet has tag.

Your policy-map is to set dscp, it should work.

what is IOS version?

What's the port trust status?

show queueing int gig 9/47

New Member

Re: Setting COS on a 6513

Try changing to:

service-policy output setqos

New Member

Re: Setting COS on a 6513

A couple of things here strike me as odd.

The setting of COS is the changing of a tag value within a vlan tagged packet. This means the COS is set and retained as long as the packets traverse trunks, yours is an access port so the COS will be retained only within VLAN 30. The next issue is the setting of the DSCP value which is a field within an IP packet, this is set on a layer three configured port ie:routed. This configuration is a layer two port.

If the COS is used, and it is routed or hits an access port the COS is stripped from the packet and lost. So if trunked links that pass VLAN 30 are suffering congestion then OK change the COS ( QOS only has an effect if the problem is congestion and there is a need for queueing to manipulate this ) otherwise no need to waste effort and electrons.

The DSCP value will need to be set on a port that has an IP address assigned to it ie: a routed port, usually the default gateway for the VLAN or a layer three egress point.

Wireshark will need to sniff a trunk port to see the COS field and values.

Usually the DSCP values for video and VOIP are set by the server in the IP packet and the switches just pass it through untouched.

Try applying the service policy at the default gateway and change the access list to pass the IP address of the video server.

Cheers,

Brian

168
Views
0
Helpful
3
Replies
CreatePlease to create content