Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Setting up for internet access through DSL

Good morning,

  I'm setting up my home lab for an eventual CCNA certification and have purchased some routers and switches.  I'm trying for a basic setup where I have a laptop wired to a switch, which is wired to a router, which is itself connected to a Bell DSL router.

Here are some specs:

Switch: 2950

Router: 2610XM

Bell Router: Alcatel Lucent 7130

Here are my Show Runs:

Switch:

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Switch_1

!

enable secret 5 $1$vaA0$A26rMRzLqXPdI/48zElpt1

!

ip subnet-zero

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

duplex full

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface Vlan1

ip address 192.168.10.1 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.10.2

ip http server

banner motd

********

SWITCH_1

********

!

line con 0

password 7 02050D480809

login

line vty 0 4

password 7 02050D480809

login

line vty 5 15

login

!

!

end

Router:

Current configuration : 3222 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router_1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$0XqM$WNMipOJUubUovb9qJs/911

!

no aaa new-model

!

resource policy

!

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.10.3 192.168.10.99

ip dhcp excluded-address 192.168.10.151 192.168.10.254

!

ip dhcp pool INSIDE_LAN

   import all

   network 192.168.10.0 255.255.255.0

   domain-name homestead.ca

   dns-server 4.2.2.2

   default-router 192.168.2.1

   lease 3

!

!

ip domain name homestead.ca

!

!

crypto pki trustpoint TP-self-signed-1228350807

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1228350807

revocation-check none

rsakeypair TP-self-signed-1228350807

!

!

crypto pki certificate chain TP-self-signed-1228350807

certificate self-signed 01

  3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31323238 33353038 3037301E 170D3032 30333031 30373334

  30345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32323833

  35303830 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100BE44 5DAC82C6 06D1A92C C5D39B63 19BF0DE6 956680FA A5E753D7 364C9A26

  4D320F7C A3DF4660 23061EB3 CB0D9E50 A27FB5A7 337ECBE8 38364BFF 6761F4D1

  2B61EFC3 B043FD26 A78067A0 11173C87 93EA9ACB FCD72545 8BC172EC 5C27905E

  F276735C 7EDA0092 2A39C515 6D87564D 73AE94E9 4D0B9DE9 09EC5153 F89BCCEE

  3DA70203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 30200603

  551D1104 19301782 15526F75 7465725F 312E686F 6D657374 6561642E 6361301F

  0603551D 23041830 1680146D A307E3B4 5834790B E13AB4B2 F8C15D8C B72C6330

  1D060355 1D0E0416 04146DA3 07E3B458 34790BE1 3AB4B2F8 C15D8CB7 2C63300D

  06092A86 4886F70D 01010405 00038181 00BA7A90 10657F35 F80E75E1 4DC0612F

  976FBCEA A9B28242 A9CA9876 7EC6AE3F 113CDB78 90A112F5 B3ACF80A B42874C7

  8342FFD2 8FEE5644 764F0A06 DFEFF664 B1B6C40B DE4D5A35 E979F742 F8A516E4

  6B8B53DB A3852360 56230938 7E686CD0 DD767F8C 40CE9DEA 2ED576CE CAD8F3FE

  665E9459 A845D15A A0C392F5 658CE1DA AE

  quit

username marc privilege 15 password 0 cisco

!

!

interface FastEthernet0/0

ip address 192.168.2.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

!

interface Serial0/1

no ip address

shutdown

!

interface Ethernet1/0

ip address 192.168.10.2 255.255.255.0

full-duplex

!

interface Ethernet1/1

no ip address

shutdown

full-duplex

!

interface Ethernet1/2

no ip address

shutdown

full-duplex

!

interface Ethernet1/3

no ip address

full-duplex

!

ip route 0.0.0.0 0.0.0.0 192.168.2.1

!

!

ip http server

ip http authentication local

ip http secure-server

!

!

control-plane

!

!

banner motd%

*******

Router_1

********%

^C

!

line con 0

password cisco

login

line aux 0

line vty 0 4

password cisco

login local

transport input telnet ssh

!

!

end

The PC can ping the switch and both inbound/outbound ports of the router but cannot ping the DSL (192.168.2.1).

The Switch can ping the PC and both inbound/outbound ports of the router but cannot ping the DSL (192.168.2.1).

The Router can ping the Switch, the PC, the DSL and the outside (I used 4.2.2.2)

Suggestions?

Thank you.

  • LAN Switching and Routing
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Setting up for internet access through DSL

Marc

The DSL needs a route back to the 192.168.10.x network. So using IOS terminology (although the DSL will have different syntax) -

ip route 192.168.10.0 255.255.255.0 192.168.2.2

if you cannot add a route to the DSL then the other option is to NAT all 192.168.10.x  IPs  to 192.168.2.2 so that DSL knows where to send teh return traffic eg.

int eth1/0

ip nat inside

int fa0/0

ip nat outside

access-list 101 permit ip 192.168.10.0 0.0.0.255 any

ip nat inside source list 101 interface fa0/0 overload

Jon

3 REPLIES
Hall of Fame Super Blue

Setting up for internet access through DSL

Marc

The DSL needs a route back to the 192.168.10.x network. So using IOS terminology (although the DSL will have different syntax) -

ip route 192.168.10.0 255.255.255.0 192.168.2.2

if you cannot add a route to the DSL then the other option is to NAT all 192.168.10.x  IPs  to 192.168.2.2 so that DSL knows where to send teh return traffic eg.

int eth1/0

ip nat inside

int fa0/0

ip nat outside

access-list 101 permit ip 192.168.10.0 0.0.0.255 any

ip nat inside source list 101 interface fa0/0 overload

Jon

New Member

Setting up for internet access through DSL

Hi Jon,

     Thanks for the help.  I used NAT since I didn't want to mess what is admittedly a tempermental Bell router.  Works like a charm.

Marc

Hall of Fame Super Blue

Re: Setting up for internet access through DSL

Marc

No problem, glad to have helped

Jon

163
Views
0
Helpful
3
Replies