Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

setting up VLAN with 802.1p

Hi,

I am new to switch configuration.

I am trying to setup QoS on the 3560 switch with CoS (802.1p)

I would be running some devices which would send traffic with CoS marking (this is the changes I have done and would like to test the code changes done)

I am able to create twl VLAN 20, and 30

I have allocated port 5 to 12 to VLAN 30 and

13 to 24 to VLAN 20, I have also enabled 'mls qos trust cos' for all the ports.

I have also run 'ip routing'

now on the devices (linux machines) I have assinged eth0 to 192.168.20.10 and other device to 20.11 with VLAN as 20.101 and 20.102 resp.

on the other device I have eth0 to 192.168.30.10 and 30.11 with VLAN as 30.101 and 30.102 resp

from the switch I can ping eth0 interface of the device but not the VLAN interface, since CoS would be on the VLAN interface that is what I need to work.

I also tried to configure all the ports to 20 and 30 VLAN togather so that I cna keep VLAN on one subnet say .30 and eth0 on one say .20

but I am not able to allocate same ports to two different VLAN's.

I am reading thru articale and configuring the switch as what I understood as I have not done this before, please bare with me.

any help would be appreciated.

my current config :

*******************************************

!

ip subnet-zero

ip routing

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

switchport access vlan 30

switchport mode access

switchport voice vlan 30

switchport priority extend trust

mls qos trust cos

spanning-tree portfast

!

interface FastEthernet0/6

switchport access vlan 30

switchport mode access

switchport voice vlan 30

switchport priority extend trust

mls qos trust cos

spanning-tree portfast

!

interface FastEthernet0/7

switchport access vlan 30

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/8

switchport access vlan 30

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/9

switchport access vlan 30

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/10

switchport access vlan 30

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/11

switchport access vlan 30

switchport mode access

switchport priority extend trust

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

mls qos cos override

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface FastEthernet0/12

switchport access vlan 30

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/13

switchport access vlan 20

switchport mode access

switchport priority extend trust

mls qos trust cos

!

interface FastEthernet0/14

switchport access vlan 20

switchport mode access

switchport priority extend trust

mls qos trust cos

!

interface FastEthernet0/15

switchport access vlan 20

switchport mode access

switchport priority extend trust

mls qos trust cos

!

interface FastEthernet0/16

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/17

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/18

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/19

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/20

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/21

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/22

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/23

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface FastEthernet0/24

switchport access vlan 20

switchport mode access

switchport priority extend trust

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 148.147.179.172 255.255.255.0

shutdown

!

interface Vlan20

description for 20

ip address 192.168.20.1 255.255.255.0

priority-group 4

!

interface Vlan30

description 30 subnet

ip address 192.168.30.1 255.255.255.0

!

ip default-gateway 148.147.179.1

ip classless

ip http server

!

!

!

control-plane

!

banner login ^CC

Warnning

this is a Cisco

!

line con 0

exec-timeout 0 0

logging synchronous

login

line vty 0 4

password XXX

login

line vty 5 15

password XXX

login

!

end

********************************************

Everyone's tags (2)
2 REPLIES
Silver

Re: setting up VLAN with 802.1p

Hi,

An access port belongs to and carries the traffic of only one VLAN (unless it is configured as a voice VLAN port). Traffic is received and sent in native formats with no VLAN tagging. Traffic arriving on an access port is assumed to belong to the VLAN assigned to the port.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_52_se/configuration/guide/swint.html#wp1107751

Hope this helps.

New Member

setting up VLAN with 802.1p

Hi Leo,

Thanks for the reply.

I have configured with voice vlan and access, with this I can assign two different subnets on the same port(two VLAN's)

now my routing is working perfectly.

I just have a single issue now, I want to change the DSCP marking based on a particular CoS (802.1p) 4, but the DSCP marking is not changing.

I am trusting CoS in my setup.

Thanks

1649
Views
0
Helpful
2
Replies