Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

setup dhcp on core switch and have access switch point to core for dhcp

Hi,

please check attached file. can I setup core switch for dhcp and have access switch point to core switch for dhcp....how do I do it? I never came across such scenario.

dhcpQue.jpg

please help.

  • LAN Switching and Routing
3 REPLIES
Silver

setup dhcp on core switch and have access switch point to core f

gavin han wrote:

Hi,

please check attached file. can I setup core switch for dhcp and have access switch point to core switch for dhcp....how do I do it? I never came across such scenario.

please help.

If the VLAN's on switch 1, 2, 3 & 4 have SVI's which route to the core, then you just need to add the following line to the SVI configuration for the VLAN's on the access switches

ip helper-address w.x.y.z global

Where w.x.y.z is the IP address of your core switch.

If there are NO SVI's on your access switches (I.E. if they're layer 2 trunks), you shouldn't even need to do that - your DHCP server configuration on the routing device (I.E. the core) should be enough (unless the DHCP server isn't residing on the core, in which case you need to apply the ip helper command on the routing interface or SVI to point it to the DHCP server's IP address).

Cheers

New Member

setup dhcp on core switch and have access switch point to core f

Thanks Darren.

but if I configure DHCP on core switch then how would the core switch know from which DHCP pool to assign IP address? i.e. if request from sw1 comes then how would the core switch know which dhcp pool to pick?

Silver

setup dhcp on core switch and have access switch point to core f

gavin han wrote:

Thanks Darren.

but if I configure DHCP on core switch then how would the core switch know from which DHCP pool to assign IP address? i.e. if request from sw1 comes then how would the core switch know which dhcp pool to pick?

Gavin.

The DHCP server would make the decision based on the SVI (or routed port) the request comes in on.

Basically, you would configure a pool for each VLAN, defining the default router for the pool as the SVI in your core router - and the DHCP server process would look at the request and process it based on "This came in from router port X, router port X is configured to pool X, so I'll allocate an IP address out of pool X to this request".

So, on your core switch, you'd have something like this

Interface VLAN10 (switch 1)

ip addres 10.10.1.254 255.255.255.0

interface VLAN20 (switch 2)

ip address 10.10.2.254 255.255.255.0

interface VLAN30 (switch 3)

ip address 10.10.3.254 255.255.255.0

interface VLAN40 (switch 4)

ip address 10.10.4.254

ip dhcp pool 10.10.1.0/24

network 10.10.1.0 255.255.255.0

default-router 10.10.1.254

ip dhcp pool 10.10.2.0/24

network 10.10.2.0 255.255.255.0

default-router 10.10.2.254

ip dhcp pool 10.10.3.0/24

network 10.10.3.0 255.255.255.0

default-router 10.10.3.254

ip dhcp pool 10.10.4.0/24

network 10.10.4.0 255.255.255.0

default-router 10.10.4.254

Then just set your uplinks on switch 1, 2, 3 & 4 to be trunks with allowed VLAN's appropriate for each switch, set each access port into that VLAN (the same as your interface VLAN), and DHCP should just go.

You obviously will need to create the VLAN's on your core switch as well as the access switches.

Cheers

2245
Views
0
Helpful
3
Replies