Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Severe GigaEtherchannel Problem between two Catalyst 6500

Hi,

I have two Catalyst 6500 and a Giga-Etherchannel of 2 links between them. One switch has a Sup-720 with IOS version 12.2(18)SXF1 and the other switch has a Sup2-MSFC2 running IOS version 12.1(20)E2.

Now here is the very strange behaviour :

I want to add a third link in the Etherchannel. If, on the switch with the Sup-720, I use a supervisor port as the third connection, the switch generates an error message as soon the link comes up and after two seconds, all Etherchannel links and the port-channel are in err-disable state !

The error message is the following :

------------------------------------

%EC-SP-5-UNSUITABLE: Gi7/1 will not join any port-channel, Access port with voice VLAN configured cannot be part of an etherchannel.

If I connect the link on another fibre module port, everything is fine and the third link joins the Etherchannel !

The supervisor GbE port is configured exactly the same way as the other ports...

Here is the supervisor port and the portchannel config :

!

interface GigabitEthernet7/1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-1005

switchport mode trunk

no ip address

mls qos trust dscp

channel-group 2 mode on

!

!

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-1005

switchport mode trunk

no ip address

mls qos trust dscp

!

I don't understand the error message, which tells us that the port is an access port with a voice VLAN configured! The port is definitly not ans access port but a trunk port with no voice vlan configured...

Can anybody explain this ?

Thank you for any help

Yves

2 REPLIES
New Member

Re: Severe GigaEtherchannel Problem between two Catalyst 6500

Yves, this is just a shot in the dark, but do you have a voice VLAN somewhere in the allowed range on the trunk?

New Member

Re: Severe GigaEtherchannel Problem between two Catalyst 6500

Jeff,

Thank you for taking care of my question, We are actually in areal trouble with this problem...The answer to your question is no, there is no statement like "switchport voice vlan" in the switches configuration. However, there is voice vlans on the access-layer switches connected to the 6500 switch with the Sup720. But it should not cause any problem as the voice VLAN is just transported as any other vlan...

The strange thing is also that, on the switch with the Sup2, the following message is dispayed when we try to connect the additional Etherchannel link to port G7/1 :

%PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po2, putting Gi1/1 in err-disable state

%PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po2, putting Gi1/2 in err-disable state

%PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po2, putting Gi2/1 in err-disable state

As you see, as soon we connect the other end of port G2/1 on the Supervisor port G7/1 of the other switch, all links go in err-disable ! But if I connect the link on port G3/10 instead of the supervisor port, everything is OK !

if you have an idea, this would be more than appreciated...

Yves

384
Views
0
Helpful
2
Replies
CreatePlease to create content