Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

sg300-10 VLAN IP helper

I have an office with 4 departments. each room have 10 pc connected to a simple switch, then all swictches uplink to a router then to cisco RV082. ok so what i would like to do is to vlan every room and set up a seperate vlan for my servers (DHCP, ADDS, DNS, and fileserver). I am running into a problem when the computers try to optain an ip address, i read the manual for the sg300-10 to setup vlan and also tried to understand the difference between LAG, vlan, tagged vs untagged and nothing works unless i have all on the same vlan but the network proformance sucks.. so if someone can provide me with a solution i would be nice.

2 REPLIES
New Member

sg300-10 VLAN IP helper

really no one here can help me with this problem...come on guys you are all experts..

Green

sg300-10 VLAN IP helper

Hi Sean, I know this reply is a bit late (nearly 10 months!)  I actually saw this post on top of a google search, clicked on it and noticed it is empty.

The RV082 supports multiple subnet and port based vlan. It doesn't support 802.1q vlan, trunk/tag, etc. To be able to set up separate vlans with the RV082 and have all VLAN's working, the SG300 switch needs to be in layer 3 mode.

To keeps things simplified on the switch configuration, log in to the CLI;

set system mode router

reload

config t

vlan database

vlan 2-4

interface vlan 1

ip address 192.168.1.254 /24

interface vlan 2

ip address 192.168.2.254 /24

interface vlan 3

ip address 192.168.3.254 /24

interface vlan 4

ip address 192.168.4.254 /24

exit

ip dhcp relay enable

ip dhcp relay address (your dhcp server address)

interface gi1

switchport trunk allowed vlan add 2,3,4

interface gi2

switchport mode trunk

switchport trunk vlan 2

interface gi3

switchport mode trunk

switchport trunk vlan 3

interface gi4

switchport mode trunk

switchport trunk vlan 4

I choose interface gi1 for your DHCP server to connect to. This should take care of your switch configuration and enable your DHCP server to relay all subnets configured on it provided your DHCP server is set up correctly. I chose port 2 to be vlan 2, port 3 to be vlan 3, port 4 to be vlan 4 and all other ports will be vlan 1 without modification.

The next part of your configuration is your router. The intial issue you will run in to, only your Vlan 1 will work. All of the other Vlans will not work. The reason is, all traffic being sent from those subnets, the router has no idea where those subnets are (the router isn't very bright!).

To remedy this you need to make static routes on the router.  On my example, my RV0XX router is 192.168.2.x and I want 192.168.4.x to work.

Using this example, your Vlan 4 will now get to the internet and work!

When you set up your DHCP server, make sure the default gateway being propogated is going to be that of the switche's vlan interface you are connecting to. So if you connect to port 4 which is vlan 4, your dhcp server needs to provide such;

ip- 192.168.4. 100

mask - 255.255.255.0

gateway- 192.168.4.254

The rest is on you

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
6704
Views
5
Helpful
2
Replies
CreatePlease to create content